summaryrefslogtreecommitdiff
path: root/games-util/ucon64/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /games-util/ucon64/files
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'games-util/ucon64/files')
-rw-r--r--games-util/ucon64/files/ucon64-2.2.1-change-mem2-64bit.patch23
-rw-r--r--games-util/ucon64/files/ucon64-2.2.1-respect-flags.patch35
-rw-r--r--games-util/ucon64/files/ucon64-2.2.1-zlib.patch26
-rw-r--r--games-util/ucon64/files/ucon64-2.2.2-respect-flags.patch29
4 files changed, 29 insertions, 84 deletions
diff --git a/games-util/ucon64/files/ucon64-2.2.1-change-mem2-64bit.patch b/games-util/ucon64/files/ucon64-2.2.1-change-mem2-64bit.patch
deleted file mode 100644
index d07a18fdd8f0..000000000000
--- a/games-util/ucon64/files/ucon64-2.2.1-change-mem2-64bit.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Fix crash on 64bit platforms in change_mem2()
-https://bugs.gentoo.org/753950
-
-From upstream:
-https://sourceforge.net/p/ucon64/svn/2821/
---- a/libdiscmage/misc.c
-+++ b/libdiscmage/misc.c
-@@ -1875,5 +1875,5 @@
- if (strpos == pos_1st_esc)
- setindex = 0; // reset argument pointer
-- if (pos_1st_esc == (unsigned int) -1)
-+ if (pos_1st_esc == (size_t) -1)
- pos_1st_esc = strpos;
-
---- a/misc/misc.c
-+++ b/misc/misc.c
-@@ -502,5 +502,5 @@
- if (strpos == pos_1st_esc)
- setindex = 0; // reset argument pointer
-- if (pos_1st_esc == (unsigned int) -1)
-+ if (pos_1st_esc == (size_t) -1)
- pos_1st_esc = strpos;
-
diff --git a/games-util/ucon64/files/ucon64-2.2.1-respect-flags.patch b/games-util/ucon64/files/ucon64-2.2.1-respect-flags.patch
deleted file mode 100644
index c1c9ed6f78da..000000000000
--- a/games-util/ucon64/files/ucon64-2.2.1-respect-flags.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Respect *FLAGS and toolchain variables in Makefiles where missing.
---- a/Makefile
-+++ b/Makefile
-@@ -12,3 +12,3 @@
- CFLAGS+=-I. -Wall -W -Wno-implicit-fallthrough -Wno-format-truncation \
---Wno-stringop-overflow -O3 -fsigned-char
-+-Wno-stringop-overflow -fsigned-char
- # Enable -Wstringop-overflow[=type] when it is no longer a broken, partial
-@@ -19,3 +19,2 @@
- # ld: warning: option -s is obsolete and being ignored
--LDFLAGS+=-s
- endif
---- a/backup/libcd64/Makefile
-+++ b/backup/libcd64/Makefile
-@@ -1,2 +1 @@
--CC=gcc
-
-@@ -7,3 +6,2 @@
- else
--CFLAGS+=-O6 -funroll-loops -fexpensive-optimizations
- endif
-@@ -181,4 +179,4 @@
- else
-- ld -r $^ $(LIBS) -o $*.o
-- ar crs $@ $*.o
-+ $(LD) -r $^ $(LIBS) -o $*.o
-+ $(AR) crs $@ $*.o
- endif
---- a/libdiscmage/Makefile.in
-+++ b/libdiscmage/Makefile.in
-@@ -33,3 +33,2 @@
- # /usr/bin/libtool: -static not specified, -s invalid
--LDFLAGS+=-s
- endif
-
diff --git a/games-util/ucon64/files/ucon64-2.2.1-zlib.patch b/games-util/ucon64/files/ucon64-2.2.1-zlib.patch
deleted file mode 100644
index a618c3bce75a..000000000000
--- a/games-util/ucon64/files/ucon64-2.2.1-zlib.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Fix undefined macro issue when compiling with zlib.
-https://bugs.gentoo.org/753950
-
-From upstream:
-https://sourceforge.net/p/ucon64/svn/2817/
-https://sourceforge.net/p/ucon64/svn/2819/
---- a/libdiscmage/ioapi.h
-+++ b/libdiscmage/ioapi.h
-@@ -35,4 +35,7 @@
- extern "C" {
- #endif
-+#ifndef OF
-+#define OF(x) x
-+#endif
-
- typedef voidpf (ZCALLBACK *open_file_func) OF((voidpf opaque, const char* filename, int mode));
---- a/misc/ioapi.h
-+++ b/misc/ioapi.h
-@@ -35,4 +35,7 @@
- extern "C" {
- #endif
-+#ifndef OF
-+#define OF(x) x
-+#endif
-
- typedef voidpf (ZCALLBACK *open_file_func) OF((voidpf opaque, const char* filename, int mode));
diff --git a/games-util/ucon64/files/ucon64-2.2.2-respect-flags.patch b/games-util/ucon64/files/ucon64-2.2.2-respect-flags.patch
new file mode 100644
index 000000000000..9e772fe6c76a
--- /dev/null
+++ b/games-util/ucon64/files/ucon64-2.2.2-respect-flags.patch
@@ -0,0 +1,29 @@
+--- a/Makefile
++++ b/Makefile
+@@ -13,3 +13,3 @@
+
+-CFLAGS+=-I. -Wall -W -Wno-implicit-fallthrough -O3 -fsigned-char
++CFLAGS+=-I. -Wall -W -Wno-implicit-fallthrough -fsigned-char
+ ifneq ($(findstring clang,$(CC)),clang)
+@@ -21,3 +21,2 @@
+ # ld: warning: option -s is obsolete and being ignored
+-LDFLAGS+=-s
+ endif
+--- a/backup/libcd64/Makefile
++++ b/backup/libcd64/Makefile
+@@ -1,3 +1,2 @@
+ ifeq ($(CC),cc)
+-CC=gcc
+ endif
+@@ -12,5 +11,3 @@
+ else
+-CFLAGS+=-O3 -funroll-loops
+ ifneq ($(findstring clang,$(CC)),clang)
+-CFLAGS+=-fexpensive-optimizations
+ endif
+--- a/libdiscmage/Makefile.in
++++ b/libdiscmage/Makefile.in
+@@ -37,3 +37,2 @@
+ # /usr/bin/libtool: -static not specified, -s invalid
+-LDFLAGS+=-s
+ endif