summaryrefslogtreecommitdiff
path: root/games-util/sc-controller
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-14 01:43:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-14 01:43:18 +0100
commit30737dc88991519b90363c2c7bae8fd049098d13 (patch)
tree765be9d1f204022a140e3ce7307c5bee63420459 /games-util/sc-controller
parent174cda0f83caffc0ee683143e9b2c501ef589cc1 (diff)
gentoo auto-resync : 14:10:2022 - 01:43:18
Diffstat (limited to 'games-util/sc-controller')
-rw-r--r--games-util/sc-controller/Manifest2
-rw-r--r--games-util/sc-controller/sc-controller-0.4.8.9.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/games-util/sc-controller/Manifest b/games-util/sc-controller/Manifest
index 21aa6d9d4d79..6c12b992170a 100644
--- a/games-util/sc-controller/Manifest
+++ b/games-util/sc-controller/Manifest
@@ -1,4 +1,6 @@
AUX sc-controller-bluetooth-evdev.patch 1558 BLAKE2B ee5f23ce380aad0a240f341f7bf182568ecec3e826625e912999ece3eba655263022386e41599e3904ecf31bd047db6a121fe29b149c16a881e9e80d2426152f SHA512 66bcecb9d17f771c2117cb6d81b2aec3ef3c2df5b0bc533a98c1d9bb3a48298e48d4631e3489319dfdcb702824935c65ea71f9d7a62bd07dacc89f9d61e075a3
DIST sc-controller-0.4.8.6_p20211211.tar.gz 2527489 BLAKE2B e04e2a9d617b6cfb3b0709f37bbbbb7384ac0c516f1f30a23547f1132c562cafeb8972f23e9cc93967187c881fd78fe6e6d102451aa5afc4bf8fce619e86820b SHA512 9d1030ed2766b9a0984852eafc343e265768489f3d01833e6633019276c0559cb4265d72013c0bc2ecb57ac35c95791ee8e2285f8c45917695ea92826bca6dc3
+DIST sc-controller-0.4.8.9.tar.gz 2541647 BLAKE2B f4e4ebcd15f8c32f292293ea21a0c30655fedefba310991082ece3b9159b52700178a31da4b3e7a172e40fde4e718403c0945387f3781628e09fa1fc086eee93 SHA512 e0848d366f6f80c36670adcda717b792b6993e7383c01e969c0478cf187bcdb891ea9c434271f24e7f5dfc96d8f321f953f610bb8efeb6ed843b7cd069b9b18f
EBUILD sc-controller-0.4.8.6_p20211211.ebuild 1263 BLAKE2B f7f7c094ba88d932c232dba0e6de9fbc476dedd11f1226606560455e187cacf40eeecfff46a43935f7e78d7424207f6155122e6ce949566c30fc983d0a8dfad1 SHA512 ca33f8b3c52d72c051b6ca96343bf9595693a6f75fbba0468629ecb30f523989310f964523ac88806b7caede0be8bc65fd0e8342273cfba59eb3e9b1189d20a6
+EBUILD sc-controller-0.4.8.9.ebuild 1309 BLAKE2B cab9da659274b686a3cd2198fa42d28d74c182c654fff79f687212a518c28012794df1a577d3d593c7a7b3f5578ce92b54f9aa1250ace7cbd749e32b5a9f482c SHA512 a8d100de31ce939833d0d48be082fd225d2a4129e05ad89f11830ecdac97c0cea7901ad5b52a74d8ca0f20f7a00e6712ffd3a97b7140ce4855da95d0bad47cc2
MISC metadata.xml 341 BLAKE2B 8bfad400d398e07b5c8ba2c0a54c3fb3768d6748df641c4d2ad75a8032fd7f351f023acf791b9b61da0e70500cfdb1b669eaaa140f6351a851b6b2e23d3c5147 SHA512 4f17d6bd17da51eec7d7b90a3c72b9ef29bb6780dc4b67245ca4ce17a62128eb800ae1e519d2b136763c3c26cf89473fb23a7e878c1e4b19b116ed9546547f58
diff --git a/games-util/sc-controller/sc-controller-0.4.8.9.ebuild b/games-util/sc-controller/sc-controller-0.4.8.9.ebuild
new file mode 100644
index 000000000000..48016b53a7df
--- /dev/null
+++ b/games-util/sc-controller/sc-controller-0.4.8.9.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 linux-info xdg
+
+DESCRIPTION="User-mode driver and GTK-based GUI for Steam Controllers and others"
+HOMEPAGE="https://github.com/Ryochan7/sc-controller/"
+SRC_URI="https://github.com/Ryochan7/sc-controller/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 BSD CC-BY-3.0 CC0-1.0 LGPL-2.1 MIT PSF-2 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+udev wayland"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pygobject[${PYTHON_USEDEP},cairo]
+ dev-python/pylibacl[${PYTHON_USEDEP}]
+ dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/vdf[${PYTHON_USEDEP}]')
+ gnome-base/librsvg[introspection]
+ virtual/libusb
+ x11-libs/gtk+:3[introspection]
+ udev? ( games-util/game-device-udev-rules )
+ wayland? ( gui-libs/gtk-layer-shell[introspection(+)] )
+"
+
+distutils_enable_tests pytest
+
+pkg_setup() {
+ local CONFIG_CHECK="~INPUT_UINPUT"
+
+ linux-info_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # This test fails. Don't know why but seems unimportant.
+ rm -v tests/test_glade.py || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ rm -r "${ED}"/usr/lib/udev/ || die
+}