summaryrefslogtreecommitdiff
path: root/games-util/pyfa/pyfa-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /games-util/pyfa/pyfa-9999.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'games-util/pyfa/pyfa-9999.ebuild')
-rw-r--r--games-util/pyfa/pyfa-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/games-util/pyfa/pyfa-9999.ebuild b/games-util/pyfa/pyfa-9999.ebuild
index 145ca005c0d1..254447e150c8 100644
--- a/games-util/pyfa/pyfa-9999.ebuild
+++ b/games-util/pyfa/pyfa-9999.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=( python3_6 )
-PYTHON_REQ_USE="sqlite,threads"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite"
inherit desktop eutils python-single-r1 xdg-utils
@@ -18,9 +19,9 @@ if [[ ${PV} = 9999 ]]; then
else
SRC_URI="https://github.com/pyfa-org/Pyfa/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
- S=${WORKDIR}/Pyfa-${PV}
+ S="${WORKDIR}/Pyfa-${PV}"
fi
-IUSE=""
+
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="mirror bindist"
@@ -49,7 +50,7 @@ BDEPEND="app-arch/zip"
PATCHES=(
# fix import path in the main script for systemwide installation
"${FILESDIR}/${PN}-2.9.3-import-pyfa.patch"
- )
+)
src_prepare() {
# get rid of CRLF line endings introduced in 1.1.10 so patches work