summaryrefslogtreecommitdiff
path: root/games-util/lutris
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-util/lutris
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-util/lutris')
-rw-r--r--games-util/lutris/Manifest4
-rw-r--r--games-util/lutris/lutris-0.4.14.ebuild68
-rw-r--r--games-util/lutris/lutris-9999.ebuild68
-rw-r--r--games-util/lutris/metadata.xml26
4 files changed, 166 insertions, 0 deletions
diff --git a/games-util/lutris/Manifest b/games-util/lutris/Manifest
new file mode 100644
index 000000000000..3842086bdb15
--- /dev/null
+++ b/games-util/lutris/Manifest
@@ -0,0 +1,4 @@
+DIST lutris-0.4.14.tar.gz 1617493 BLAKE2B c97d0e31657252c4ae5c6718151f028d273831cdb9f21b748ada651686cf3aa51a618a007db87528d84f21dca292509399f9bb1f0c0444c57e369b13b9ae79a0 SHA512 d229d7f79b3395db22ad49abc02ca5e08db9465258be33fcefe743c0a099e1ca507b6b9c28f03d2a6857489f7f2e19fca38803f6876df88a96b060ed5f7f94bc
+EBUILD lutris-0.4.14.ebuild 1377 BLAKE2B 6228490d33bc2e502ed40995bf281813e5367300b7d189f68b287908bc4905001a4e6fb650f2d3c44aa763b1e4e28ba803d466ec8f344c62c8295133105812a7 SHA512 9894d39b9504ee331f7b171509b6cb7bafcec16e10613fe0742da169d82d3290df912bf8eecfa67cb24991d13a39f138f3dcdd59aa93123c6ed8cdf839b1be62
+EBUILD lutris-9999.ebuild 1377 BLAKE2B 6228490d33bc2e502ed40995bf281813e5367300b7d189f68b287908bc4905001a4e6fb650f2d3c44aa763b1e4e28ba803d466ec8f344c62c8295133105812a7 SHA512 9894d39b9504ee331f7b171509b6cb7bafcec16e10613fe0742da169d82d3290df912bf8eecfa67cb24991d13a39f138f3dcdd59aa93123c6ed8cdf839b1be62
+MISC metadata.xml 879 BLAKE2B 082e00a4612390060819b18444b1cb45bc2bf1506ff97306aaeb9adbf6aaa955da7babcff1e2a6841900f320406253834cebe2f2c796e86adea31c99e04b5955 SHA512 fadab7841251b491ebe8407645f10bb998ec26668f66f1ead21b11b9eead466648e49fe7f1054bc7d28bcf5a9bb2beddc0899e2047051c6c1e71f0b95408198d
diff --git a/games-util/lutris/lutris-0.4.14.ebuild b/games-util/lutris/lutris-0.4.14.ebuild
new file mode 100644
index 000000000000..960cafec846a
--- /dev/null
+++ b/games-util/lutris/lutris-0.4.14.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE="sqlite,threads"
+
+inherit distutils-r1 gnome2-utils python-r1
+
+DESCRIPTION="Lutris is an open source gaming platform for GNU/Linux."
+HOMEPAGE="https://lutris.net/"
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/lutris/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/lutris/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ net-libs/libsoup
+ x11-apps/xrandr
+ x11-apps/xgamma"
+
+python_install() {
+ distutils-r1_python_install
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_install() {
+ # README.rst contains list of optional deps
+ DOCS=( AUTHORS README.rst INSTALL.rst )
+ distutils-r1_src_install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+
+ elog "For a list of optional dependencies (runners) see:"
+ elog "/usr/share/doc/${PF}/README.rst.bz2"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
diff --git a/games-util/lutris/lutris-9999.ebuild b/games-util/lutris/lutris-9999.ebuild
new file mode 100644
index 000000000000..960cafec846a
--- /dev/null
+++ b/games-util/lutris/lutris-9999.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE="sqlite,threads"
+
+inherit distutils-r1 gnome2-utils python-r1
+
+DESCRIPTION="Lutris is an open source gaming platform for GNU/Linux."
+HOMEPAGE="https://lutris.net/"
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/lutris/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/lutris/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ net-libs/libsoup
+ x11-apps/xrandr
+ x11-apps/xgamma"
+
+python_install() {
+ distutils-r1_python_install
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_install() {
+ # README.rst contains list of optional deps
+ DOCS=( AUTHORS README.rst INSTALL.rst )
+ distutils-r1_src_install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+
+ elog "For a list of optional dependencies (runners) see:"
+ elog "/usr/share/doc/${PF}/README.rst.bz2"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
diff --git a/games-util/lutris/metadata.xml b/games-util/lutris/metadata.xml
new file mode 100644
index 000000000000..036f019d61d2
--- /dev/null
+++ b/games-util/lutris/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>fdsfgs@krutt.org</email>
+ <name>soredake</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ Lutris is a gaming platform for GNU/Linux. Its goal is to make
+ gaming on Linux as easy as possible by taking care of installing
+ and setting up the game for the user. The only thing you have to
+ do is play the game. It aims to support every game that is playable
+ on Linux.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">lutris/lutris</remote-id>
+ </upstream>
+</pkgmetadata>