summaryrefslogtreecommitdiff
path: root/games-util/lutris/lutris-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /games-util/lutris/lutris-9999.ebuild
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'games-util/lutris/lutris-9999.ebuild')
-rw-r--r--games-util/lutris/lutris-9999.ebuild70
1 files changed, 38 insertions, 32 deletions
diff --git a/games-util/lutris/lutris-9999.ebuild b/games-util/lutris/lutris-9999.ebuild
index 960cafec846a..fca79a193ebf 100644
--- a/games-util/lutris/lutris-9999.ebuild
+++ b/games-util/lutris/lutris-9999.ebuild
@@ -1,68 +1,74 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_{4,5,6} )
-PYTHON_REQ_USE="sqlite,threads"
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+PYTHON_REQ_USE="sqlite,threads(+)"
-inherit distutils-r1 gnome2-utils python-r1
+inherit distutils-r1 virtualx xdg
-DESCRIPTION="Lutris is an open source gaming platform for GNU/Linux."
+DESCRIPTION="An open source gaming platform for GNU/Linux"
HOMEPAGE="https://lutris.net/"
-if [[ "${PV}" == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/lutris/${PN}.git"
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/lutris/lutris.git"
inherit git-r3
else
- SRC_URI="https://github.com/lutris/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://lutris.net/releases/${P/-/_}.tar.xz"
KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-3"
SLOT="0"
+BDEPEND="
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
RDEPEND="
- dev-python/dbus-python[${PYTHON_USEDEP}]
+ app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unrar
+ app-arch/unzip
+ dev-python/pillow[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/python-evdev[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
+ gnome-base/gnome-desktop[introspection]
+ media-sound/fluid-soundfont
net-libs/libsoup
+ net-libs/webkit-gtk:4[introspection]
+ x11-apps/xgamma
x11-apps/xrandr
- x11-apps/xgamma"
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify
+"
-python_install() {
- distutils-r1_python_install
-}
-
-src_prepare() {
- distutils-r1_src_prepare
-}
+S="${WORKDIR}/${PN}"
-src_compile() {
- distutils-r1_src_compile
+python_install_all() {
+ local DOCS=( AUTHORS README.rst docs/installers.rst )
+ distutils-r1_python_install_all
}
-src_install() {
- # README.rst contains list of optional deps
- DOCS=( AUTHORS README.rst INSTALL.rst )
- distutils-r1_src_install
+python_test() {
+ virtx nosetests -v || die
}
pkg_preinst() {
- gnome2_icon_savelist
- gnome2_schemas_savelist
+ xdg_pkg_preinst
}
pkg_postinst() {
- gnome2_icon_cache_update
- gnome2_schemas_update
+ xdg_pkg_postinst
- elog "For a list of optional dependencies (runners) see:"
- elog "/usr/share/doc/${PF}/README.rst.bz2"
+ # Quote README.rst
+ elog "Lutris installations are fully automated through scripts, which can"
+ elog "be written in either JSON or YAML. The scripting syntax is described"
+ elog "in ${EROOT}/usr/share/doc/${PF}/installers.rst.bz2, and is also"
+ elog "available online at lutris.net."
}
pkg_postrm() {
- gnome2_icon_cache_update
- gnome2_schemas_update
+ xdg_pkg_postrm
}