summaryrefslogtreecommitdiff
path: root/games-util/lutris/lutris-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-07 14:12:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-07 14:12:01 +0100
commit32c7b79bcc8a67e6bc6516adbc729e83f957a368 (patch)
tree21df31dc0deb9c9cf559e956049f83a09bc2fa08 /games-util/lutris/lutris-9999.ebuild
parent79b62a1562ef813f413bc8facf13c063e5196c02 (diff)
gentoo auto-resync : 07:08:2022 - 14:12:00
Diffstat (limited to 'games-util/lutris/lutris-9999.ebuild')
-rw-r--r--games-util/lutris/lutris-9999.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/games-util/lutris/lutris-9999.ebuild b/games-util/lutris/lutris-9999.ebuild
index 1b9e6fc4d1db..8808cea2f845 100644
--- a/games-util/lutris/lutris-9999.ebuild
+++ b/games-util/lutris/lutris-9999.ebuild
@@ -3,11 +3,11 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
PYTHON_REQ_USE="sqlite,threads(+)"
DISTUTILS_SINGLE_IMPL="1"
-inherit distutils-r1 virtualx xdg
+inherit distutils-r1 optfeature virtualx xdg
DESCRIPTION="An open source gaming platform for GNU/Linux"
HOMEPAGE="https://lutris.net/"
@@ -26,7 +26,7 @@ else
fi
fi
-LICENSE="GPL-3"
+LICENSE="GPL-3+ CC0-1.0"
SLOT="0"
RDEPEND="
@@ -35,6 +35,7 @@ RDEPEND="
app-arch/unzip
$(python_gen_cond_dep '
dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/python-evdev[${PYTHON_USEDEP}]
@@ -50,6 +51,7 @@ RDEPEND="
x11-apps/xgamma
x11-apps/xrandr
x11-libs/gtk+:3[introspection]
+ x11-libs/gdk-pixbuf[jpeg]
x11-libs/libnotify[introspection]
"
@@ -69,7 +71,10 @@ python_install_all() {
pkg_postinst() {
xdg_pkg_postinst
+ optfeature "running windows games through wine+DXVK/proton or other Vulkan games (plus ICD for your hardware)" media-libs/vulkan-loader
+
# Quote README.rst
+ elog ""
elog "Lutris installations are fully automated through scripts, which can"
elog "be written in either JSON or YAML. The scripting syntax is described"
elog "in ${EROOT}/usr/share/doc/${PF}/installers.rst.bz2, and is also"