summaryrefslogtreecommitdiff
path: root/games-util/joystick/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-util/joystick/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-util/joystick/files')
-rw-r--r--games-util/joystick/files/joystick-1.4.8-udev.patch52
-rw-r--r--games-util/joystick/files/joystick-1.6.0-build.patch34
2 files changed, 86 insertions, 0 deletions
diff --git a/games-util/joystick/files/joystick-1.4.8-udev.patch b/games-util/joystick/files/joystick-1.4.8-udev.patch
new file mode 100644
index 000000000000..c0032493ebf7
--- /dev/null
+++ b/games-util/joystick/files/joystick-1.4.8-udev.patch
@@ -0,0 +1,52 @@
+diff -ru linuxconsoletools-1.4.8.orig/utils/jscal-restore.in linuxconsoletools-1.4.8/utils/jscal-restore.in
+--- linuxconsoletools-1.4.8.orig/utils/jscal-restore.in 2011-12-15 10:49:01.000000000 -0500
++++ linuxconsoletools-1.4.8/utils/jscal-restore.in 2015-05-16 01:54:00.799168225 -0400
+@@ -6,8 +6,13 @@
+ exit 1
+ fi
+
+-if [ ! -x /sbin/udevadm ]; then
+- echo Restoring joystick configuration requires udev! >&2
++for f in /sbin/udevadm /bin/udevadm ;
++do
++ [ -x $f ] && UDEVADM=$f
++done
++
++if [ -z "$UDEVADM" ] ; then
++ echo Storing joystick configuration requires udev! >&2
+ exit 1
+ fi
+
+@@ -30,7 +35,7 @@
+ # in the NAME value
+ IFS=$'\x0A'
+
+-for ATTRIBUTE in $( /sbin/udevadm info -a -n $1 | @@PREFIX@@/share/joystick/ident ); do
++for ATTRIBUTE in $( ${UDEVADM} info -a -n $1 | @@PREFIX@@/share/joystick/ident ); do
+ ID=$( echo "$ATTRIBUTE" | cut -f 1 -d = )
+ VALUE=$( echo "$ATTRIBUTE" | cut -f 2 -d \" )
+ case $ID in
+diff -ru linuxconsoletools-1.4.8.orig/utils/jscal-store.in linuxconsoletools-1.4.8/utils/jscal-store.in
+--- linuxconsoletools-1.4.8.orig/utils/jscal-store.in 2011-12-15 10:49:01.000000000 -0500
++++ linuxconsoletools-1.4.8/utils/jscal-store.in 2015-05-16 01:53:18.725607838 -0400
+@@ -11,14 +11,18 @@
+ echo "Stores the device's calibration for future use."
+ exit 1
+ fi
++for f in /sbin/udevadm /bin/udevadm ;
++do
++ [ -x $f ] && UDEVADM=$f
++done
+
+-if [ ! -x /sbin/udevadm ]; then
++if [ -z "$UDEVADM" ] ; then
+ echo Storing joystick configuration requires udev! >&2
+ exit 1
+ fi
+
+ ident=$(mktemp)
+-/sbin/udevadm info -a -n $1 | @@PREFIX@@/share/joystick/ident > $ident
++${UDEVADM} info -a -n $1 | @@PREFIX@@/share/joystick/ident > $ident
+ . $ident
+ rm $ident
+
diff --git a/games-util/joystick/files/joystick-1.6.0-build.patch b/games-util/joystick/files/joystick-1.6.0-build.patch
new file mode 100644
index 000000000000..fa60ec719917
--- /dev/null
+++ b/games-util/joystick/files/joystick-1.6.0-build.patch
@@ -0,0 +1,34 @@
+--- linuxconsoletools-1.6.0/docs/Makefile
++++ linuxconsoletools-1.6.0/docs/Makefile
+@@ -20,9 +20,13 @@
+ # 02110-1301 USA.
+
+ MANPAGES = inputattach.1 jstest.1 jscal.1 fftest.1 \
+- ffmvforce.1 ffset.1 ffcfstress.1 jscal-store.1 \
++ ffset.1 ffcfstress.1 jscal-store.1 \
+ jscal-restore.1 evdev-joystick.1
+
++ifneq ($(USE_SDL),no)
++MANPAGES += ffmvforce.1
++endif
++
+ PREFIX ?= /usr/local
+
+ install:
+--- linuxconsoletools-1.6.0/utils/Makefile
++++ linuxconsoletools-1.6.0/utils/Makefile
+@@ -27,9 +27,13 @@
+
+ CFLAGS ?= -g -O2 -Wall
+
+-PROGRAMS = inputattach jstest jscal fftest ffmvforce ffset \
++PROGRAMS = inputattach jstest jscal fftest ffset \
+ ffcfstress jscal-restore jscal-store evdev-joystick
+
++ifneq ($(USE_SDL),no)
++PROGRAMS += ffmvforce
++endif
++
+ PREFIX ?= /usr/local
+
+ compile: $(PROGRAMS)