summaryrefslogtreecommitdiff
path: root/games-util/gtkevemon/gtkevemon-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-util/gtkevemon/gtkevemon-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-util/gtkevemon/gtkevemon-9999.ebuild')
-rw-r--r--games-util/gtkevemon/gtkevemon-9999.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-util/gtkevemon/gtkevemon-9999.ebuild b/games-util/gtkevemon/gtkevemon-9999.ebuild
new file mode 100644
index 000000000000..3a8c5bb264d8
--- /dev/null
+++ b/games-util/gtkevemon/gtkevemon-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic git-r3
+
+DESCRIPTION="A standalone skill monitoring application for EVE Online"
+HOMEPAGE="https://github.com/gtkevemon/gtkevemon"
+EGIT_REPO_URI="https://github.com/${PN}/${PN}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="
+ dev-cpp/gtkmm:3.0
+ dev-libs/libxml2
+ net-misc/curl[ssl]
+"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ sed -e 's:Categories=Game;$:Categories=Game;RolePlaying;GTK;:' \
+ -i "icon/${PN}.desktop" \
+ || die "failed fix categories in icon/${PN}.desktop"
+
+ # Fixes a QA notice.
+ sed -i "/^Encoding/d" "icon/${PN}.desktop" \
+ || die "failed to remove the Encoding from icon/${PN}.desktop"
+
+ append-cxxflags -std=c++11
+}
+
+src_install() {
+ dobin "src/${PN}"
+ doicon "icon/${PN}.svg"
+ domenu "icon/${PN}.desktop"
+ einstalldocs
+}