summaryrefslogtreecommitdiff
path: root/games-util/gslist/gslist-0.8.11a-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-util/gslist/gslist-0.8.11a-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-util/gslist/gslist-0.8.11a-r1.ebuild')
-rw-r--r--games-util/gslist/gslist-0.8.11a-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-util/gslist/gslist-0.8.11a-r1.ebuild b/games-util/gslist/gslist-0.8.11a-r1.ebuild
new file mode 100644
index 000000000000..cbe916e10a66
--- /dev/null
+++ b/games-util/gslist/gslist-0.8.11a-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A GameSpy server browser"
+HOMEPAGE="http://aluigi.altervista.org/papers.htm#gslist"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="web"
+
+RDEPEND="dev-libs/geoip"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+)
+
+src_prepare() {
+ default
+ rm -f gslist gslistsql *.exe *.dll || die
+}
+
+src_compile() {
+ emake SQL=0 $(use web || echo GSWEB=0)
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc ${PN}.txt
+}