summaryrefslogtreecommitdiff
path: root/games-util/dfarc/dfarc-3.14-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-24 16:33:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-24 16:33:11 +0000
commitfaddeff65d652bda3291eba255955adb17f1aa19 (patch)
tree4352e6d85ce48c7c8d96159fad4d3dd90602a70a /games-util/dfarc/dfarc-3.14-r1.ebuild
parent0e7b1da874d923b9f006e0000023f5fa528140a8 (diff)
gentoo auto-resync : 24:11:2023 - 16:33:11
Diffstat (limited to 'games-util/dfarc/dfarc-3.14-r1.ebuild')
-rw-r--r--games-util/dfarc/dfarc-3.14-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-util/dfarc/dfarc-3.14-r1.ebuild b/games-util/dfarc/dfarc-3.14-r1.ebuild
new file mode 100644
index 000000000000..1f6a12e39977
--- /dev/null
+++ b/games-util/dfarc/dfarc-3.14-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+inherit wxwidgets xdg
+
+DESCRIPTION="Frontend and .dmod installer for GNU FreeDink"
+HOMEPAGE="http://www.gnu.org/software/freedink/"
+SRC_URI="mirror://gnu/freedink/${P}.tar.gz"
+
+LICENSE="GPL-3 BZIP2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ app-arch/bzip2
+ x11-misc/xdg-utils
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( dev-util/intltool )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.12-nowindres.patch
+ # From OpenSuSE
+ "${FILESDIR}"/${P}-wxString.patch
+)
+
+src_configure() {
+ setup-wxwidgets
+ econf \
+ $(use_enable nls) \
+ --disable-desktopfiles \
+ --with-wx-config="${WX_CONFIG}"
+}
+
+src_install() {
+ default
+ dodoc TRANSLATIONS.txt
+}