summaryrefslogtreecommitdiff
path: root/games-util/deutex/deutex-4.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-util/deutex/deutex-4.4.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-util/deutex/deutex-4.4.0.ebuild')
-rw-r--r--games-util/deutex/deutex-4.4.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-util/deutex/deutex-4.4.0.ebuild b/games-util/deutex/deutex-4.4.0.ebuild
new file mode 100644
index 000000000000..bad39df7b9b7
--- /dev/null
+++ b/games-util/deutex/deutex-4.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit toolchain-funcs eutils
+
+DESCRIPTION="A wad composer for Doom, Heretic, Hexen and Strife"
+HOMEPAGE="http://www.teaser.fr/~amajorel/deutex/"
+SRC_URI="http://www.teaser.fr/~amajorel/deutex/${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2+ HPND"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-makefile.patch \
+ "${FILESDIR}"/${P}-64bit.patch \
+ "${FILESDIR}"/${P}-ovflfix.patch
+ tc-export CC
+}
+
+src_install() {
+ dobin deusf deutex
+ doman deutex.6
+ dodoc CHANGES README TODO
+}