summaryrefslogtreecommitdiff
path: root/games-util/datutil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-util/datutil
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-util/datutil')
-rw-r--r--games-util/datutil/Manifest4
-rw-r--r--games-util/datutil/datutil-2.46.ebuild43
-rw-r--r--games-util/datutil/metadata.xml14
3 files changed, 61 insertions, 0 deletions
diff --git a/games-util/datutil/Manifest b/games-util/datutil/Manifest
new file mode 100644
index 000000000000..19579502bc42
--- /dev/null
+++ b/games-util/datutil/Manifest
@@ -0,0 +1,4 @@
+DIST datlib236.zip 109484 BLAKE2B 63dbaf4c70b5cd4259fbbe77a36e8608edb62d4a3663d836f237cb23ba85e2128cdb5ec055cd48913a7316c6334689e898fbd37c54a3eaae3428f6b2d54d7544 SHA512 0c601fe243c8ea4186abb6181cf70e749226a5eed871d7391b3686e7eb58195d1aab40305d498d1419c6fa49bf56c59fb74d032642822045cc7e36f8a5fe96b4
+DIST dutil246.zip 209577 BLAKE2B bd806974780bf03d89353a93dfc240dcec00aada4ffa7a3848d2b4e07cc8cb317834115b55b5074ee104db3df975bfc4c5ebbb2591cb9fda6a716bc49f2bb454 SHA512 f9e55eac41894681caaee7d6e3247d4e4d053ac6985d42708623fad415afeb8ece588dd728edc31cbd31bf6df1d9a06ec80f1b45979b0f77763c12e6627434b2
+EBUILD datutil-2.46.ebuild 1093 BLAKE2B d177170dcdc3873e3237e7d59c60be1e15983c8db64497d084e36586e74607dd05d1c94fccd83196e58abfdcde129a4a7a38733a858f1ce6f7d992ce6453aab8 SHA512 04404a03b78154810177ccce2e1b47fb43f91f4d68cc4e002f27d37f675e07d0b8cc11c32fa2b28b71fd953e6cd382affad1ddecb7a1d1bcdc33d35827e703a5
+MISC metadata.xml 577 BLAKE2B 2f3a9e5a6a73c6431efff8ddae66cbddf59b39d36ff30b6d4d243f150612d77e18887e3ab8f597b087f9cccb733b30abae69f7780f2ec636e647b98107699d3f SHA512 30770c001a7d5a072a6db5d913f010cbed6ae0cbe24b2ada950d14585fb1d5c9d4675023e491b6a43130dfcacaf24e4061c2a330d2a9e97fb4324f94e248861d
diff --git a/games-util/datutil/datutil-2.46.ebuild b/games-util/datutil/datutil-2.46.ebuild
new file mode 100644
index 000000000000..acf880241a00
--- /dev/null
+++ b/games-util/datutil/datutil-2.46.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit toolchain-funcs
+
+DL_PV=2.36
+DESCRIPTION="Converter for dat files for Rom Managers"
+HOMEPAGE="http://www.logiqx.com/Tools/DatUtil/"
+SRC_URI="http://www.logiqx.com/Tools/DatUtil/dutil${PV//.}.zip
+ http://www.logiqx.com/Tools/DatLib/datlib${DL_PV//.}.zip"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+RESTRICT="mirror bindist"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack dutil${PV//.}.zip
+ cd "${S}"
+ mkdir -p dev/datlib
+ cd dev/datlib
+ unpack datlib${DL_PV//.}.zip
+}
+
+src_compile() {
+ # Parallel make issue, see bug #244879 (so make the dirs first)
+ emake -j1 CC="$(tc-getCC)" LD="$(tc-getCC) ${CFLAGS} ${LDFLAGS}" \
+ CFLAGS="${CFLAGS} -Idev" LOGIQX=. EXT= UPX=@# dlmaketree maketree || die "emake failed"
+ emake CC="$(tc-getCC)" LD="$(tc-getCC) ${CFLAGS} ${LDFLAGS}" \
+ CFLAGS="${CFLAGS} -Idev" LOGIQX=. EXT= UPX=@# || die "emake failed"
+}
+
+src_install() {
+ dobin datutil
+ dodoc readme.txt whatsnew.txt
+}
diff --git a/games-util/datutil/metadata.xml b/games-util/datutil/metadata.xml
new file mode 100644
index 000000000000..8840fa601df7
--- /dev/null
+++ b/games-util/datutil/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription lang="en">
+DatUtil was created to aid in the creation of dat files for Rom Managers such as
+ClrMamePro and RomCenter (Roman Scherzer / Eric Bole-Feysot). It can convert
+between formats, extract individual games (and optionally their clones) and
+cleanse dats. It supports a variety of formats
+</longdescription>
+</pkgmetadata>