summaryrefslogtreecommitdiff
path: root/games-util/cartridges/cartridges-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-06 15:58:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-06 15:58:48 +0000
commit6404f9556c73d558d61c2eed022743311eb43bb9 (patch)
treecc98afde6cd3539e2dda3dae5e467992b03d2367 /games-util/cartridges/cartridges-9999.ebuild
parenta03b2fe2d845ae950995bf1c5255da420cbd92d2 (diff)
gentoo auto-resync : 06:02:2024 - 15:58:48
Diffstat (limited to 'games-util/cartridges/cartridges-9999.ebuild')
-rw-r--r--games-util/cartridges/cartridges-9999.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/games-util/cartridges/cartridges-9999.ebuild b/games-util/cartridges/cartridges-9999.ebuild
index 05c8ac27f772..9988986c70a0 100644
--- a/games-util/cartridges/cartridges-9999.ebuild
+++ b/games-util/cartridges/cartridges-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -10,41 +10,42 @@ inherit gnome2-utils meson python-single-r1 xdg
DESCRIPTION="Simple game launcher written in Python using GTK4 and Libadwaita"
HOMEPAGE="https://github.com/kra-mo/cartridges/"
-if [[ ${PV} == *9999* ]] ; then
+if [[ "${PV}" == *9999* ]] ; then
inherit git-r3
+
EGIT_REPO_URI="https://github.com/kra-mo/${PN}.git"
else
SRC_URI="https://github.com/kra-mo/${PN}/archive/v${PV}.tar.gz
-> ${P}.tar.gz"
+
KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-3+"
SLOT="0"
+RESTRICT="test" # Just appstream file validation that uses network.
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
${PYTHON_DEPS}
+ >=gui-libs/libadwaita-1.4.0:1[introspection]
gui-libs/gtk:4[introspection]
- gui-libs/libadwaita:1[introspection]
$(python_gen_cond_dep '
dev-python/pygobject:3[${PYTHON_USEDEP}]
')
"
-DEPEND="${RDEPEND}"
BDEPEND="
+ ${RDEPEND}
dev-libs/appstream-glib
dev-util/blueprint-compiler
dev-util/desktop-file-utils
"
-PATCHES=( "${FILESDIR}"/${PN}-1.5.4-dont-validate-appstream.patch )
-
src_install() {
meson_src_install
- python_fix_shebang "${ED}"/usr/bin
- python_optimize "${ED}"/usr/share/cartridges/cartridges
+ python_fix_shebang "${ED}/usr/bin"
+ python_optimize "${ED}/usr"
}
pkg_postinst() {