summaryrefslogtreecommitdiff
path: root/games-util/biounzip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-util/biounzip
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-util/biounzip')
-rw-r--r--games-util/biounzip/Manifest4
-rw-r--r--games-util/biounzip/biounzip-1.1a.ebuild32
-rw-r--r--games-util/biounzip/files/biounzip-1.1a-64bit.patch11
-rw-r--r--games-util/biounzip/metadata.xml11
4 files changed, 58 insertions, 0 deletions
diff --git a/games-util/biounzip/Manifest b/games-util/biounzip/Manifest
new file mode 100644
index 000000000000..c5868f86b8e5
--- /dev/null
+++ b/games-util/biounzip/Manifest
@@ -0,0 +1,4 @@
+AUX biounzip-1.1a-64bit.patch 462 BLAKE2B 2c762b12ad665f48657419534307319d27efbc91929bd0795ea738f5f8214cc1b2ba3df6c00e8bd8f5eee9db9ada6bd14dd71165e6eb1666d90bb766ad80f901 SHA512 751078079fb663f7f229ccfbbb8e8ea2f779f6739144a75415d73937559ef08886156c8a9ae6e354269b4e0363b34b06bd2979400d671c6c4f7c646abc2b5328
+DIST biounzip-1.1a.tar.bz2 9894 BLAKE2B 950216a1b0b994b2ec271d836c7cf86471a2eca5ac0c259885e21a4df7b20425b74ae2ffb08610ed0841caced5d8b6783c448857df3a2a9030c788ee9b88db3b SHA512 4eaea5459cf6edaf289951f9048123496a4eb83fcfc39b3efcd2a81894f877d5db843d7448e2c0e3b797b09a70f6f3c133c53525d4f83408306089bd37796a8c
+EBUILD biounzip-1.1a.ebuild 588 BLAKE2B 1f1790eda791a50f937995da2854e80c8d4838146b963152b9df016e444b406b07fe9a89eae56031aa25302ecbc9ce507a51c60774e177438f85438f1dccd8fc SHA512 19df79ea2fdaf16e6b27016fc1624c0a83739165c7770ef34a64d8b5a20ffc45d0f3d581d9f9c3df293e7179f06750733474fe52b87a887f2eed2bc4ba70dd95
+MISC metadata.xml 331 BLAKE2B 0a7243a32e0bc9b5e20d89b4b62c0199413de7c1f0c11dab9b32d925ac1dce7f65e7b74ca0d7ba78fa02a0faaf5e651fe9e6319a240189a7f934bbad8e700118 SHA512 2cb5bc86ab42d6bacdf6a1991c9c54cb3c313dd3a7dd8a2aee4d25ab899dd20d88c5db6a340e2c56e21dc1725fc6b24c55ba212e23ec2ca03230e9a6ac023b53
diff --git a/games-util/biounzip/biounzip-1.1a.ebuild b/games-util/biounzip/biounzip-1.1a.ebuild
new file mode 100644
index 000000000000..8864926d8034
--- /dev/null
+++ b/games-util/biounzip/biounzip-1.1a.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Unpacks BioZip archives"
+HOMEPAGE="http://biounzip.sourceforge.net/"
+SRC_URI="mirror://sourceforge/biounzip/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/zlib"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${P/a/}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-64bit.patch
+}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} *.c -lz || die
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc biozip.txt
+}
diff --git a/games-util/biounzip/files/biounzip-1.1a-64bit.patch b/games-util/biounzip/files/biounzip-1.1a-64bit.patch
new file mode 100644
index 000000000000..a8522189d31f
--- /dev/null
+++ b/games-util/biounzip/files/biounzip-1.1a-64bit.patch
@@ -0,0 +1,11 @@
+--- biounzip-1.1-old/biounzip.c 2007-03-08 02:06:16.000000000 +0200
++++ biounzip-1.1/biounzip.c 2007-03-08 02:06:50.000000000 +0200
+@@ -127,7 +127,7 @@
+ void writefile(bzfile *ptr, FILE *fp, char *destdir)
+ {
+ int startpos,returnval,n,debug=0;
+- unsigned long size_uncompressed,size_compressed;
++ unsigned long size_uncompressed = 0, size_compressed = 0;
+ char *fname,*dirname,*fullname,*fullpath;
+ unsigned char *srcbuffer,*dstbuffer;
+ FILE *outfile;
diff --git a/games-util/biounzip/metadata.xml b/games-util/biounzip/metadata.xml
new file mode 100644
index 000000000000..0fb77f58b247
--- /dev/null
+++ b/games-util/biounzip/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">biounzip</remote-id>
+ </upstream>
+</pkgmetadata>