summaryrefslogtreecommitdiff
path: root/games-util/biounzip/biounzip-1.1a.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-util/biounzip/biounzip-1.1a.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-util/biounzip/biounzip-1.1a.ebuild')
-rw-r--r--games-util/biounzip/biounzip-1.1a.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/games-util/biounzip/biounzip-1.1a.ebuild b/games-util/biounzip/biounzip-1.1a.ebuild
index 8864926d8034..fa6925259af0 100644
--- a/games-util/biounzip/biounzip-1.1a.ebuild
+++ b/games-util/biounzip/biounzip-1.1a.ebuild
@@ -1,29 +1,28 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="Unpacks BioZip archives"
HOMEPAGE="http://biounzip.sourceforge.net/"
SRC_URI="mirror://sourceforge/biounzip/${P}.tar.bz2"
+S="${WORKDIR}"/${P/a/}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
DEPEND="sys-libs/zlib"
-RDEPEND=${DEPEND}
-
-S=${WORKDIR}/${P/a/}
+RDEPEND="${DEPEND}"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-64bit.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-64bit.patch
+)
src_compile() {
- $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} *.c -lz || die
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -o ${PN} *.c -lz || die
}
src_install() {