summaryrefslogtreecommitdiff
path: root/games-util/acc/acc-1.58.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-util/acc/acc-1.58.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-util/acc/acc-1.58.ebuild')
-rw-r--r--games-util/acc/acc-1.58.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/games-util/acc/acc-1.58.ebuild b/games-util/acc/acc-1.58.ebuild
new file mode 100644
index 000000000000..2519c43835b7
--- /dev/null
+++ b/games-util/acc/acc-1.58.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="ACS script compiler for use with ZDoom and Hexen"
+HOMEPAGE="https://zdoom.org/wiki/ACC"
+SRC_URI="https://github.com/rheit/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Activision"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# The Activision EULA is inappropriate but this was never resolved. :(
+# https://doomwiki.org/wiki/Raven_source_code_licensing
+RESTRICT="bindist mirror"
+
+src_install() {
+ dobin "${BUILD_DIR}"/${PN}
+ dodoc readme.md
+
+ insinto /usr/share/${PN}
+ doins *.acs
+}