summaryrefslogtreecommitdiff
path: root/games-strategy/tornado/tornado-1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-strategy/tornado/tornado-1.4.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-strategy/tornado/tornado-1.4.ebuild')
-rw-r--r--games-strategy/tornado/tornado-1.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-strategy/tornado/tornado-1.4.ebuild b/games-strategy/tornado/tornado-1.4.ebuild
new file mode 100644
index 000000000000..0c6638176e97
--- /dev/null
+++ b/games-strategy/tornado/tornado-1.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Clone of a C64 game - destroy the opponent's house"
+HOMEPAGE="http://kiza.kcore.de/software/tornado/"
+SRC_URI="http://kiza.kcore.de/software/tornado/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+
+src_prepare() {
+ sed -i \
+ -e "s:PREFIX/bin:${GAMES_BINDIR}:" \
+ -e "s:PREFIX/man:/usr/man:" \
+ -e "s:/var/games:${GAMES_STATEDIR}:" \
+ -e "s:/usr/local:/usr:" \
+ doc/man/tornado.6.in \
+ || die "sed failed"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_install() {
+ dogamesbin tornado
+ doman doc/man/tornado.6
+ dodoc AUTHOR CREDITS Changelog README TODO
+ insinto "${GAMES_STATEDIR}"
+ doins tornado.scores
+ prepgamesdirs
+ fperms 664 "${GAMES_STATEDIR}/tornado.scores"
+}