summaryrefslogtreecommitdiff
path: root/games-strategy/seven-kingdoms/seven-kingdoms-2.15.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /games-strategy/seven-kingdoms/seven-kingdoms-2.15.5.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'games-strategy/seven-kingdoms/seven-kingdoms-2.15.5.ebuild')
-rw-r--r--games-strategy/seven-kingdoms/seven-kingdoms-2.15.5.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-strategy/seven-kingdoms/seven-kingdoms-2.15.5.ebuild b/games-strategy/seven-kingdoms/seven-kingdoms-2.15.5.ebuild
new file mode 100644
index 000000000000..003704713e9f
--- /dev/null
+++ b/games-strategy/seven-kingdoms/seven-kingdoms-2.15.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop toolchain-funcs
+
+MY_PN="7kaa"
+MY_PV="$(ver_rs 3- '')"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Seven Kingdoms: Ancient Adversaries"
+HOMEPAGE="https://7kfans.com/"
+SRC_URI="https://github.com/the3dfxdude/${MY_PN}/releases/download/v${MY_PV}/${MY_P}.tar.xz
+ https://dev.gentoo.org/~pinkbyte/distfiles/${MY_PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="net-libs/enet:1.3=
+ media-libs/libsdl2[X,video]
+ media-libs/openal
+ net-misc/curl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${MY_P}.tar.xz
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ doicon "${DISTDIR}/${MY_PN}.png"
+ make_desktop_entry "${MY_PN}" "Seven Kingdoms: Ancient Adversaries" "${MY_PN}" "Game;StrategyGame"
+}