summaryrefslogtreecommitdiff
path: root/games-strategy/scorched3d/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
commit0cf2f20608308acdf3cb922c3736446bbd8f3388 (patch)
tree07815070629c7c11000a7f51ceb8ccbccb49a809 /games-strategy/scorched3d/files
parent1798c4aeca70ac8d0a243684d6a798fbc65735f8 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-strategy/scorched3d/files')
-rw-r--r--games-strategy/scorched3d/files/scorched3d-44-fix-c++14.patch14
-rw-r--r--games-strategy/scorched3d/files/scorched3d-44-fixups.patch25
-rw-r--r--games-strategy/scorched3d/files/scorched3d-44-freetype.patch45
-rw-r--r--games-strategy/scorched3d/files/scorched3d-44-gcc43.patch22
-rw-r--r--games-strategy/scorched3d/files/scorched3d-44-jpeg9.patch20
-rw-r--r--games-strategy/scorched3d/files/scorched3d-44-odbc.patch16
-rw-r--r--games-strategy/scorched3d/files/scorched3d-44-win32.patch18
-rw-r--r--games-strategy/scorched3d/files/scorched3d-44-wxgtk.patch161
8 files changed, 0 insertions, 321 deletions
diff --git a/games-strategy/scorched3d/files/scorched3d-44-fix-c++14.patch b/games-strategy/scorched3d/files/scorched3d-44-fix-c++14.patch
deleted file mode 100644
index e3cba2741405..000000000000
--- a/games-strategy/scorched3d/files/scorched3d-44-fix-c++14.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-In C++14, bool -> T* implicit conversions are not allowed anymore.
-See also: https://bugs.gentoo.org/show_bug.cgi?id=601890
-
---- a/src/common/weapons/AccessoryStore.cpp
-+++ b/src/common/weapons/AccessoryStore.cpp
-@@ -156,7 +156,7 @@
- Accessory *parent, XMLNode *currentNode)
- {
- XMLNode *typeNode = 0;
-- if (!currentNode->getNamedParameter("type", typeNode)) return false;
-+ if (!currentNode->getNamedParameter("type", typeNode)) return NULL;
-
- AccessoryPart *accessoryPart =
- AccessoryMetaRegistration::getNewAccessory(typeNode->getContent(), this);
diff --git a/games-strategy/scorched3d/files/scorched3d-44-fixups.patch b/games-strategy/scorched3d/files/scorched3d-44-fixups.patch
deleted file mode 100644
index 47499d4cf307..000000000000
--- a/games-strategy/scorched3d/files/scorched3d-44-fixups.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- scorched.orig/configure.ac
-+++ scorched/configure.ac
-@@ -13,22 +13,6 @@
- AC_PROG_INSTALL
- AC_PROG_RANLIB
-
--LDFLAGS="$LDFLAGS -L/usr/X11R6/lib -L/usr/X11R6"
--CPPFLAGS="$CPPFLAGS -I/usr/X11R6/include -I/usr/X11R6"
--
--if test `uname` == Darwin; then
--LDFLAGS="$LDFLAGS -lmx"
--CPPFLAGS="$CPPFLAGS -DFFTW_USE_DOUBLE -D__DARWIN__ -D__MACOSX__"
--else
--LDFLAGS="$LDFLAGS -L/usr/local/lib"
--CPPFLAGS="$CPPFLAGS -I/usr/local/include"
--fi
--
--AC_CHECK_LIB(fridge, beer, echo "Hmm?!",[
-- echo "Warning: No beer found in fridge!";
-- echo "We highly suggest that you rectify this situation immediately."
--])
--
- AC_ARG_ENABLE(serveronly,
- [ --enable-serveronly Enable server only compilation],
- , enable_serveronly=no,
diff --git a/games-strategy/scorched3d/files/scorched3d-44-freetype.patch b/games-strategy/scorched3d/files/scorched3d-44-freetype.patch
deleted file mode 100644
index e4717972d81a..000000000000
--- a/games-strategy/scorched3d/files/scorched3d-44-freetype.patch
+++ /dev/null
@@ -1,45 +0,0 @@
---- a/acinclude.m4
-+++ b/acinclude.m4
-@@ -437,7 +437,7 @@
- if test "$FT2_CONFIG" = "no" ; then
- no_ft=yes
- else
-- FT2_CFLAGS=`$FT2_CONFIG $ft_config_args --cflags`
-+ FT2_CFLAGS="`$FT2_CONFIG $ft_config_args --cflags` `$FT2_CONFIG $ft_config_args --cflags | sed -e 's:freetype2:freetype2/freetype:'`"
- FT2_LIBS=`$FT2_CONFIG $ft_config_args --libs`
- ft_config_major_version=`$FT2_CONFIG $ft_config_args --version | \
- sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
---- a/src/client/GLEXT/GLFont2dFreeType.h
-+++ b/src/client/GLEXT/GLFont2dFreeType.h
-@@ -23,10 +23,10 @@
-
- #include <GLEXT/GLFont2dStorage.h>
- #include <ft2build.h>
--#include <freetype/freetype.h>
--#include <freetype/ftglyph.h>
--#include <freetype/ftoutln.h>
--#include <freetype/fttrigon.h>
-+#include <freetype.h>
-+#include <ftglyph.h>
-+#include <ftoutln.h>
-+#include <fttrigon.h>
- #include <string>
-
- class GLFont2dFreeType
---- a/src/launcher/wxdialogs/TrueTypeFont.h
-+++ b/src/launcher/wxdialogs/TrueTypeFont.h
-@@ -25,10 +25,10 @@
- #include <wx/image.h>
- #include <ft2build.h>
- #include <string>
--#include <freetype/freetype.h>
--#include <freetype/ftglyph.h>
--#include <freetype/ftoutln.h>
--#include <freetype/fttrigon.h>
-+#include <freetype.h>
-+#include <ftglyph.h>
-+#include <ftoutln.h>
-+#include <fttrigon.h>
-
- class TrueTypeFont
- {
diff --git a/games-strategy/scorched3d/files/scorched3d-44-gcc43.patch b/games-strategy/scorched3d/files/scorched3d-44-gcc43.patch
deleted file mode 100644
index 79f40b70e652..000000000000
--- a/games-strategy/scorched3d/files/scorched3d-44-gcc43.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- scorched.old/src/common/common/main.h
-+++ scorched/src/common/common/main.h
-@@ -40,7 +40,7 @@
- void _no_storage()
- {
- printf("Failed to allocate memory!!");
-- std::exit(1);
-+ exit(1);
- }
-
- void run_main(int argc, char *argv[], OptionsParameters &params)
---- scorched.old/src/common/porting/windows.h
-+++ scorched/src/common/porting/windows.h
-@@ -20,7 +20,7 @@
- typedef unsigned short WORD;
- typedef unsigned char BYTE;
-
--typedef int HWND;
-+// typedef int HWND;
- typedef void * HINSTANCE;
- typedef int WPARAM;
- typedef int LPARAM;
diff --git a/games-strategy/scorched3d/files/scorched3d-44-jpeg9.patch b/games-strategy/scorched3d/files/scorched3d-44-jpeg9.patch
deleted file mode 100644
index 1cebf3ebd7bc..000000000000
--- a/games-strategy/scorched3d/files/scorched3d-44-jpeg9.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/src/common/image/ImageJpgFactory.cpp.old 2014-12-03 09:52:03.306552513 +0100
-+++ b/src/common/image/ImageJpgFactory.cpp 2014-12-03 09:53:22.117786304 +0100
-@@ -79,7 +79,7 @@
- src->next_input_byte = FakeEOI;
- src->bytes_in_buffer = 2;
-
-- return TRUE;
-+ return (boolean)TRUE;
- }
-
- METHODDEF(void)
-@@ -166,7 +166,7 @@
- src->bytes_in_buffer = buffer.getBufferUsed();
- src->next_input_byte = (JOCTET *) buffer.getBuffer();
-
-- jpeg_read_header(&cinfo, TRUE);
-+ jpeg_read_header(&cinfo, (boolean)TRUE);
- jpeg_start_decompress(&cinfo);
-
- if ((cinfo.output_components == 3 && !readalpha) ||
diff --git a/games-strategy/scorched3d/files/scorched3d-44-odbc.patch b/games-strategy/scorched3d/files/scorched3d-44-odbc.patch
deleted file mode 100644
index e7f3833bf897..000000000000
--- a/games-strategy/scorched3d/files/scorched3d-44-odbc.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-When x11-libs/wxGTK is built with the odbc use flag, scorched3d fails to build.
-bug #285384 - patch from Bob Johnson
-
---- scorched/src/common/porting/windows.h
-+++ fix_scorched/src/common/porting/windows.h
-@@ -11,8 +11,8 @@
-
- typedef char * LPSTR;
- typedef const char * LPCTSTR;
--typedef unsigned int DWORD;
--typedef unsigned int * LPDWORD;
-+typedef unsigned long DWORD;
-+typedef DWORD * LPDWORD;
- typedef unsigned char * LPBYTE;
- typedef int INT;
- typedef long LONG;
diff --git a/games-strategy/scorched3d/files/scorched3d-44-win32.patch b/games-strategy/scorched3d/files/scorched3d-44-win32.patch
deleted file mode 100644
index 05f9c806b1c7..000000000000
--- a/games-strategy/scorched3d/files/scorched3d-44-win32.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- scorched.old/src/common/porting/windows.h
-+++ scorched/src/common/porting/windows.h
-@@ -9,6 +9,7 @@
- #include <ctype.h>
- #include <common/Defines.h>
-
-+#ifdef _WIN32
- typedef char * LPSTR;
- typedef const char * LPCTSTR;
- typedef unsigned int DWORD;
-@@ -27,6 +28,7 @@
- typedef int LRESULT;
- typedef void * HDC;
- typedef void * HGLRC;
-+#endif /* _WIN32 */
-
- #define _strnicmp(a,b,c) strncasecmp(a,b,c)
- #define stricmp(a,b) strcasecmp(a,b)
diff --git a/games-strategy/scorched3d/files/scorched3d-44-wxgtk.patch b/games-strategy/scorched3d/files/scorched3d-44-wxgtk.patch
deleted file mode 100644
index ee8b97554656..000000000000
--- a/games-strategy/scorched3d/files/scorched3d-44-wxgtk.patch
+++ /dev/null
@@ -1,161 +0,0 @@
-Description: Fix to build with wxWidgets 3.0
-Author: Olly Betts <olly@survex.com>
-Last-Update: 2014-05-01
-
---- a/src/launcher/wxdialogs/Display.cpp
-+++ b/src/launcher/wxdialogs/Display.cpp
-@@ -26,7 +26,7 @@
- // Display settings
- wxStaticBox *displayBox = new wxStaticBox(parent, -1, wxT("&Display"));
- wxStaticBoxSizer *displaySizer = new wxStaticBoxSizer(displayBox, wxVERTICAL);
-- wxFlexGridSizer *displaySizer2 = new wxFlexGridSizer(2, 3, 5, 5);
-+ wxFlexGridSizer *displaySizer2 = new wxFlexGridSizer(0, 3, 5, 5);
- wxStaticText *resText = new wxStaticText(parent, -1, wxT("&Resolution :"));
- IDC_DISPLAY_CTRL =
- new wxComboBox(parent, -1,
-@@ -88,7 +88,7 @@
- // Sound settings
- wxStaticBox *soundBox = new wxStaticBox(parent, -1, wxT("&Sound"));
- wxStaticBoxSizer *soundSizerMain = new wxStaticBoxSizer(soundBox, wxVERTICAL);
-- wxFlexGridSizer *soundSizer1 = new wxFlexGridSizer(4, 2);
-+ wxFlexGridSizer *soundSizer1 = new wxFlexGridSizer(0, 4, 2, 0);
- wxStaticText *volumeText = new wxStaticText(parent, -1, wxT("Sound Volume :"));
- wxStaticText *musicVolumeText = new wxStaticText(parent, -1, wxT("Music Volume :"));
- wxStaticText *ambientVolumeText = new wxStaticText(parent, -1, wxT("Ambient Volume :"));
-@@ -137,7 +137,7 @@
- wxT("Game Detail Options"));
- wxStaticBoxSizer *speedSizer = new wxStaticBoxSizer(speedBox, wxHORIZONTAL);
-
-- wxGridSizer *loadSizer = new wxFlexGridSizer(2, 2);
-+ wxGridSizer *loadSizer = new wxFlexGridSizer(0, 2, 2, 0);
- IDC_LOADULTRA_CTRL = new wxButton(parent, ID_LOADULTRA, wxT("&Ultra Detail"), wxDefaultPosition, wxSize(120,-1));
- IDC_LOADDEFAULTS_CTRL = new wxButton(parent, ID_LOADDEFAULTS, wxT("&Normal Detail"), wxDefaultPosition, wxSize(120,-1));
- IDC_LOADMEDIUM_CTRL = new wxButton(parent, ID_LOADMEDIUM, wxT("Faster Detail"), wxDefaultPosition, wxSize(120,-1));
-@@ -256,7 +256,7 @@
- wxStaticBox *waterDetailBox = new wxStaticBox(parent, -1,
- wxT("Graphics Detail"));
- wxStaticBoxSizer *waterDetailSizer = new wxStaticBoxSizer(waterDetailBox, wxHORIZONTAL);
-- wxGridSizer *waterDetailSizer2 = new wxGridSizer(3, 1, 10, 10);
-+ wxGridSizer *waterDetailSizer2 = new wxGridSizer(0, 1, 10, 10);
-
- IDC_NOWATERREF_CTRL =
- new wxCheckBox(parent, -1, wxT("Don't draw water reflections - Large Framerate Improvement"));
-@@ -471,7 +471,7 @@
- {
- wxScrolledWindow *scrolledWindow = new wxScrolledWindow(parent, -1,
- wxDefaultPosition, wxSize(480, 250));
-- wxSizer *sizer = new wxFlexGridSizer(5, 1);
-+ wxSizer *sizer = new wxFlexGridSizer(0, 5, 1, 0);
-
- keyboardKeyList.clear();
- if (!Keyboard::instance()->loadKeyFile())
---- a/src/launcher/wxdialogs/SettingsDialog.cpp
-+++ b/src/launcher/wxdialogs/SettingsDialog.cpp
-@@ -105,7 +105,7 @@
- mainPanel_ = new wxPanel(book_, -1);
- book_->AddPage(mainPanel_, wxT("Main"));
- wxSizer *mainPanelSizer = new wxBoxSizer(wxVERTICAL);
-- wxSizer *sizer = new wxFlexGridSizer(2, 2);
-+ wxSizer *sizer = new wxFlexGridSizer(0, 2, 2, 0);
- mainPanelSizer->Add(sizer, 0, wxALL | wxALIGN_CENTER, 10);
-
- setters_.push_back(
-@@ -166,7 +166,7 @@
- {
- moneyPanel_ = new wxPanel(book_, -1);
- wxSizer *ecoPanelSizer = new wxBoxSizer(wxVERTICAL);
-- wxSizer *sizer = new wxFlexGridSizer(2, 2);
-+ wxSizer *sizer = new wxFlexGridSizer(0, 2, 2, 0);
- ecoPanelSizer->Add(sizer, 0, wxALL | wxALIGN_CENTER, 10);
-
- setters_.push_back(
-@@ -215,7 +215,7 @@
- {
- scorePanel_ = new wxPanel(book_, -1);
- wxSizer *ecoPanelSizer = new wxBoxSizer(wxVERTICAL);
-- wxSizer *sizer = new wxFlexGridSizer(2, 2);
-+ wxSizer *sizer = new wxFlexGridSizer(0, 2, 2, 0);
- ecoPanelSizer->Add(sizer, 0, wxALL | wxALIGN_CENTER, 10);
-
- setters_.push_back(
-@@ -249,7 +249,7 @@
- {
- weaponsPanel_ = new wxPanel(book_, -1);
- wxSizer *ecoPanelSizer = new wxBoxSizer(wxVERTICAL);
-- wxSizer *sizer = new wxFlexGridSizer(2, 2);
-+ wxSizer *sizer = new wxFlexGridSizer(0, 2, 2, 0);
- ecoPanelSizer->Add(sizer, 0, wxALL | wxALIGN_CENTER, 10);
-
- setters_.push_back(
-@@ -286,7 +286,7 @@
- {
- envPanel_ = new wxPanel(book_, -1);
- wxSizer *envPanelSizer = new wxBoxSizer(wxVERTICAL);
-- wxSizer *sizer = new wxFlexGridSizer(2, 2);
-+ wxSizer *sizer = new wxFlexGridSizer(0, 2, 2, 0);
- envPanelSizer->Add(sizer, 0, wxALL | wxALIGN_CENTER, 10);
-
- setters_.push_back(
-@@ -337,7 +337,7 @@
- wxScrolledWindow *scrolledWindow = new wxScrolledWindow(landPanel_, -1,
- wxDefaultPosition, wxSize(225, 200));
-
-- wxSizer *sizer = new wxFlexGridSizer(3, 3);
-+ wxSizer *sizer = new wxFlexGridSizer(0, 3, 3, 0);
- int i = 0;
- std::list<LandscapeDefinitionsEntry> &defns =
- landscapeDefinitions.getAllLandscapes();
-@@ -438,7 +438,7 @@
- wxT("Players are persistent for game"));
- playersPanelSizer->Add(IDC_SERVER_RESIDUAL_CTRL, 0, wxALIGN_CENTER | wxTOP, 10);
-
-- wxSizer *sizer = new wxGridSizer(3, 3);
-+ wxSizer *sizer = new wxGridSizer(0, 3, 3, 0);
- playersPanelSizer->Add(sizer, 0, wxALL | wxALIGN_CENTER, 10);
-
- for (int i=0; i<24; i++)
---- a/src/launcher/wxdialogs/DisplayDialog.cpp
-+++ b/src/launcher/wxdialogs/DisplayDialog.cpp
-@@ -449,15 +449,15 @@
- IDC_SLIDER1_CTRL->SetValue(OptionsDisplay::instance()->getBrightness());
- IDC_SLIDER1_CTRL->SetToolTip(wxString(OptionsDisplay::instance()->getBrightnessEntry().getDescription(), wxConvUTF8));
- IDC_VOLUME_CTRL->SetRange(0, 128);
-- IDC_VOLUME_CTRL->SetTickFreq(4, 0);
-+ IDC_VOLUME_CTRL->SetTickFreq(4);
- IDC_VOLUME_CTRL->SetValue(OptionsDisplay::instance()->getSoundVolume());
- IDC_VOLUME_CTRL->SetToolTip(wxString(OptionsDisplay::instance()->getSoundVolumeEntry().getDescription(), wxConvUTF8));
- IDC_MUSICVOLUME_CTRL->SetRange(0, 128);
-- IDC_MUSICVOLUME_CTRL->SetTickFreq(4, 0);
-+ IDC_MUSICVOLUME_CTRL->SetTickFreq(4);
- IDC_MUSICVOLUME_CTRL->SetValue(OptionsDisplay::instance()->getMusicVolume());
- IDC_MUSICVOLUME_CTRL->SetToolTip(wxString(OptionsDisplay::instance()->getMusicVolumeEntry().getDescription(), wxConvUTF8));
- IDC_AMBIENTVOLUME_CTRL->SetRange(0, 128);
-- IDC_AMBIENTVOLUME_CTRL->SetTickFreq(4, 0);
-+ IDC_AMBIENTVOLUME_CTRL->SetTickFreq(4);
- IDC_AMBIENTVOLUME_CTRL->SetValue(OptionsDisplay::instance()->getAmbientSoundVolume());
- IDC_AMBIENTVOLUME_CTRL->SetToolTip(wxString(OptionsDisplay::instance()->getAmbientSoundVolumeEntry().getDescription(), wxConvUTF8));
- IDC_USERNAME_CTRL->SetValue(wxString(OptionsDisplay::instance()->getOnlineUserName(), wxConvUTF8));
-@@ -733,11 +733,7 @@
- convertString(S3D::formatStringBuffer("%s.s3m", (const char *) (selection.mb_str(wxConvUTF8)))), // default filename
- wxT(""), // default extension
- wxT("*.s3m"),
--#if wxCHECK_VERSION(2, 8, 0)
- wxFD_SAVE);
--#else
-- wxSAVE);
--#endif
- if (file.empty()) return;
- ModFiles files;
- if (!files.loadModFiles(std::string(selection.mb_str(wxConvUTF8)), false))
-@@ -761,11 +757,7 @@
- wxT(""), // default filename
- wxT(""), // default extension
- wxT("*.s3m"),
--#if wxCHECK_VERSION(2, 8, 0)
- wxFD_OPEN | wxFD_FILE_MUST_EXIST);
--#else
-- wxOPEN | wxFILE_MUST_EXIST);
--#endif
- if (file.empty()) return;
- ModFiles files;
- std::string mod;