summaryrefslogtreecommitdiff
path: root/games-strategy/openra/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-26 20:41:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-26 20:41:49 +0100
commit12795ed0561fe52503d6aa3a1c60888553a03bd2 (patch)
treebebc6554f117bd11f5e1c3503ed66966afcb5f3f /games-strategy/openra/files
parent7e8f2c69a019131eaeb989242d022260ea5a84ff (diff)
gentoo auto-resync : 26:10:2023 - 20:41:49
Diffstat (limited to 'games-strategy/openra/files')
-rw-r--r--games-strategy/openra/files/openra-20231010-configure-system-libraries.patch11
-rw-r--r--games-strategy/openra/files/openra-20231010-makefile.patch31
-rw-r--r--games-strategy/openra/files/openra-20231010-packaging-functions.patch11
3 files changed, 53 insertions, 0 deletions
diff --git a/games-strategy/openra/files/openra-20231010-configure-system-libraries.patch b/games-strategy/openra/files/openra-20231010-configure-system-libraries.patch
new file mode 100644
index 000000000000..c5b373cac2ad
--- /dev/null
+++ b/games-strategy/openra/files/openra-20231010-configure-system-libraries.patch
@@ -0,0 +1,11 @@
+--- a/configure-system-libraries.sh
++++ b/configure-system-libraries.sh
+@@ -43,7 +43,7 @@ patch_config()
+ for LIB in ${SEARCH}; do
+ if [ -f "${DIR}/${LIB}" ]; then
+ echo "${LIB}"
+- ln -s "${DIR}/${LIB}" "bin/${REPLACE}"
++ ln -f -s "${DIR}/${LIB}" "bin/${REPLACE}"
+ return 0
+ fi
+ done
diff --git a/games-strategy/openra/files/openra-20231010-makefile.patch b/games-strategy/openra/files/openra-20231010-makefile.patch
new file mode 100644
index 000000000000..ad8afa3bdf3e
--- /dev/null
+++ b/games-strategy/openra/files/openra-20231010-makefile.patch
@@ -0,0 +1,31 @@
+--- a/Makefile
++++ b/Makefile
+@@ -97,10 +97,7 @@ ifeq ($(RUNTIME), mono)
+ else
+ @$(DOTNET) build -c ${CONFIGURATION} -nologo -p:TargetPlatform=$(TARGETPLATFORM)
+ endif
+-ifeq ($(TARGETPLATFORM), unix-generic)
+ @./configure-system-libraries.sh
+-endif
+- @./fetch-geoip.sh
+
+ # dotnet clean and msbuild -t:Clean leave files that cause problems when switching between mono/dotnet
+ # Deleting the intermediate / output directories ensures the build directory is actually clean
+@@ -117,9 +114,7 @@ else
+ @$(DOTNET) clean -c Debug --nologo --verbosity minimal
+ @$(DOTNET) build -c Debug -nologo -warnaserror -p:TargetPlatform=$(TARGETPLATFORM)
+ endif
+-ifeq ($(TARGETPLATFORM), unix-generic)
+ @./configure-system-libraries.sh
+-endif
+ @echo
+ @echo "Checking for explicit interface violations..."
+ @./utility.sh all --check-explicit-interfaces
+@@ -161,7 +156,6 @@ endif
+ @sh -c '. ./packaging/functions.sh; set_mod_version "$(VERSION)" mods/ra/mod.yaml mods/cnc/mod.yaml mods/d2k/mod.yaml mods/ts/mod.yaml mods/modcontent/mod.yaml mods/all/mod.yaml'
+
+ install:
+- @sh -c '. ./packaging/functions.sh; install_assemblies $(CWD) $(DESTDIR)$(gameinstalldir) $(TARGETPLATFORM) $(RUNTIME) True True True'
+ @sh -c '. ./packaging/functions.sh; install_data $(CWD) $(DESTDIR)$(gameinstalldir) cnc d2k ra'
+
+ install-linux-shortcuts:
diff --git a/games-strategy/openra/files/openra-20231010-packaging-functions.patch b/games-strategy/openra/files/openra-20231010-packaging-functions.patch
new file mode 100644
index 000000000000..f932cc3e3616
--- /dev/null
+++ b/games-strategy/openra/files/openra-20231010-packaging-functions.patch
@@ -0,0 +1,11 @@
+--- a/packaging/functions.sh
++++ b/packaging/functions.sh
+@@ -108,7 +108,7 @@ install_data() (
+ "${SRC_PATH}"/fetch-geoip.sh
+
+ echo "Installing engine files to ${DEST_PATH}"
+- for FILE in VERSION AUTHORS COPYING IP2LOCATION-LITE-DB1.IPV6.BIN.ZIP "global mix database.dat"; do
++ for FILE in VERSION AUTHORS COPYING "global mix database.dat"; do
+ install -m644 "${SRC_PATH}/${FILE}" "${DEST_PATH}"
+ done
+