summaryrefslogtreecommitdiff
path: root/games-strategy/maxr/maxr-0.2.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /games-strategy/maxr/maxr-0.2.9.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'games-strategy/maxr/maxr-0.2.9.ebuild')
-rw-r--r--games-strategy/maxr/maxr-0.2.9.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/games-strategy/maxr/maxr-0.2.9.ebuild b/games-strategy/maxr/maxr-0.2.9.ebuild
index 4e1287280ad5..ad76a5a4f645 100644
--- a/games-strategy/maxr/maxr-0.2.9.ebuild
+++ b/games-strategy/maxr/maxr-0.2.9.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils desktop gnome2-utils
+inherit cmake desktop xdg-utils
DESCRIPTION="Mechanized Assault and Exploration Reloaded"
-HOMEPAGE="https://www.maxr.org"
+HOMEPAGE="https://www.maxr.org/"
SRC_URI="https://www.maxr.org/downloads/${P}.tar.gz"
LICENSE="GPL-2 FDL-1.2+"
@@ -14,26 +14,25 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="dedicated"
-RDEPEND="media-libs/libsdl2[video]
+RDEPEND="
+ media-libs/libsdl2[video]
media-libs/sdl2-mixer[vorbis]
media-libs/sdl2-net"
DEPEND="${RDEPEND}"
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DMAXR_BUILD_DEDICATED_SERVER=$(usex dedicated)
-DCMAKE_BUILD_TYPE=Release
)
-
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
doicon -s 128 data/${PN}.png
make_desktop_entry ${PN} "Mechanized Assault and Exploration Reloaded"
}
-pkg_preinst() { gnome2_icon_savelist; }
-pkg_postinst() { gnome2_icon_cache_update; }
-pkg_postrm() { gnome2_icon_cache_update; }
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }