summaryrefslogtreecommitdiff
path: root/games-strategy/liquidwar/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-strategy/liquidwar/files
reinit the tree, so we can have metadata
Diffstat (limited to 'games-strategy/liquidwar/files')
-rw-r--r--games-strategy/liquidwar/files/liquidwar-5.6.4-exec-stack.patch27
-rw-r--r--games-strategy/liquidwar/files/liquidwar-5.6.4-ovflfix.patch18
-rw-r--r--games-strategy/liquidwar/files/liquidwar-5.6.4-underlink.patch11
3 files changed, 56 insertions, 0 deletions
diff --git a/games-strategy/liquidwar/files/liquidwar-5.6.4-exec-stack.patch b/games-strategy/liquidwar/files/liquidwar-5.6.4-exec-stack.patch
new file mode 100644
index 000000000000..83e733b28a05
--- /dev/null
+++ b/games-strategy/liquidwar/files/liquidwar-5.6.4-exec-stack.patch
@@ -0,0 +1,27 @@
+--- src/glouglou.s
++++ src/glouglou.s
+@@ -240,3 +240,6 @@
+
+ ret
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/monster.s
++++ src/monster.s
+@@ -972,3 +972,6 @@
+ ret # retour au c
+
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/spread.s
++++ src/spread.s
+@@ -957,3 +957,6 @@
+
+
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
diff --git a/games-strategy/liquidwar/files/liquidwar-5.6.4-ovflfix.patch b/games-strategy/liquidwar/files/liquidwar-5.6.4-ovflfix.patch
new file mode 100644
index 000000000000..446385624cfa
--- /dev/null
+++ b/games-strategy/liquidwar/files/liquidwar-5.6.4-ovflfix.patch
@@ -0,0 +1,18 @@
+--- src/wwwsrv.c.old 2010-10-26 14:16:31.000000000 +0200
++++ src/wwwsrv.c 2010-10-26 14:17:35.000000000 +0200
+@@ -100,12 +100,12 @@
+
+ data->privacy = privacy;
+ data->log = log;
+- strncpy (data->metaserver, metaserver, URL_SIZE);
++ strncpy (data->metaserver, metaserver, sizeof(data->metaserver));
+ data->port = port;
+ data->busy_players = busy_players;
+ data->max_players = max_players;
+- strncpy (data->password, password, URL_SIZE);
+- strncpy (data->comment, comment, URL_SIZE);
++ strncpy (data->password, password, sizeof(data->password));
++ strncpy (data->comment, comment, sizeof(data->comment));
+ }
+
+ /*------------------------------------------------------------------*/
diff --git a/games-strategy/liquidwar/files/liquidwar-5.6.4-underlink.patch b/games-strategy/liquidwar/files/liquidwar-5.6.4-underlink.patch
new file mode 100644
index 000000000000..2bc53e0caccb
--- /dev/null
+++ b/games-strategy/liquidwar/files/liquidwar-5.6.4-underlink.patch
@@ -0,0 +1,11 @@
+--- src/Makefile.in.old 2011-06-22 07:45:05.756127862 +0200
++++ src/Makefile.in 2011-06-22 07:46:00.681613957 +0200
+@@ -223,7 +223,7 @@
+ EXTERN_LIBS = `allegro-config --static $(ALLEGRO_LIBRARY)` $(EFENCE_LIBRARY)
+ else
+ LINK_OPTIONS =
+- EXTERN_LIBS = `allegro-config --libs $(ALLEGRO_LIBRARY)` $(EFENCE_LIBRARY)
++ EXTERN_LIBS = `allegro-config --libs $(ALLEGRO_LIBRARY)` $(EFENCE_LIBRARY) -lm
+ endif
+
+ CONFIG_OPTIONS = \