summaryrefslogtreecommitdiff
path: root/games-strategy/lightyears
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-strategy/lightyears
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-strategy/lightyears')
-rw-r--r--games-strategy/lightyears/Manifest4
-rw-r--r--games-strategy/lightyears/files/lightyears-1.4-gentoo.patch45
-rw-r--r--games-strategy/lightyears/lightyears-1.4-r2.ebuild50
-rw-r--r--games-strategy/lightyears/metadata.xml13
4 files changed, 112 insertions, 0 deletions
diff --git a/games-strategy/lightyears/Manifest b/games-strategy/lightyears/Manifest
new file mode 100644
index 000000000000..7cf7cebecb57
--- /dev/null
+++ b/games-strategy/lightyears/Manifest
@@ -0,0 +1,4 @@
+AUX lightyears-1.4-gentoo.patch 1280 BLAKE2B fd247d049fe7e32264a0d86ffa06f37ca8a8ffb4fd7b5651adce2008f089b1b83758286b46e33555c61b4a62fb79e6ed93475bf51aff599117fc5eedbfe70680 SHA512 4a8770b29c7aa8b489a8afaac7ba3ec9a2efc1466f6263f35ee531a8e4498a1490080bd390a87309983d62ac0d3a722421058d671c32c7cda91bcc6a94d81be3
+DIST lightyears-1.4.tar.bz2 693877 BLAKE2B 871b8f66088c3a947de50e7b47a8aeef4d06f9c7919f4f361a6719ff0dfa6b48acabb759dca6969d09255e2c89c158caa0cd560ef02567df6e46bbcda2eb9417 SHA512 68f576d820d54b353adbc504f8aa3341547e2e56474717cc59aecc2368fc0eb533458e09876b3cd2a9062914a8a58d39a35ce944256372bb9e15830210924597
+EBUILD lightyears-1.4-r2.ebuild 1020 BLAKE2B d692c8e1087689b67a62a8785869d5c66511bdfd8114e9b27378ab0c3b35418b733eb8c4d37bfcfa25a2943a035207648d0e39eb39b3ec3b318f4c3197491e9e SHA512 1721d4023d7a275d67f691e867d857200d7c9e71b871b4b7fec34302707324ebf8d88c47d03d0331e149ca9ace89daceece333415c45225f690220574cdae087
+MISC metadata.xml 457 BLAKE2B 7f250bdb961fe6d994ebc983f8dfaf3cbe7c4763b766fbcbc199b2db3f33ca273136e827adece324f4c00b611521882b932a1750a372258e0d52daf691a2c1bb SHA512 354fad5eed1305fc7e5ed69de92f7033b651371a1993ccd90d3d6fd9f49975e30e8b5b4c8cfcf8bb6f1284b5ef0df790adf863f76f580945ff3699ff275d5c13
diff --git a/games-strategy/lightyears/files/lightyears-1.4-gentoo.patch b/games-strategy/lightyears/files/lightyears-1.4-gentoo.patch
new file mode 100644
index 000000000000..325c4365ded4
--- /dev/null
+++ b/games-strategy/lightyears/files/lightyears-1.4-gentoo.patch
@@ -0,0 +1,45 @@
+--- a/lightyears
++++ b/lightyears
+@@ -1,7 +1,6 @@
+ #!/usr/bin/python
+
+ # Set the location of the LightYears files here:
+-LIGHTYEARS_DIR = "."
+ # LIGHTYEARS_DIR = "/usr/share/games/lightyears" # (for Debian)
+
+ # Save games and configuration files are stored in the user's
+@@ -10,31 +9,6 @@
+ import sys, os
+
+ if __name__ == "__main__":
+- # Path to data/code dir can be overridden by environment variable
+- LIGHTYEARS_DIR = os.environ.get("LIGHTYEARS_DIR", LIGHTYEARS_DIR)
+-
+- # Path does not exist? Try current directory.
+- if ((LIGHTYEARS_DIR == None)
+- or (not os.path.isdir(LIGHTYEARS_DIR))
+- or (not os.path.isfile(os.path.join(LIGHTYEARS_DIR,
+- 'code', 'startup.py')))):
+- LIGHTYEARS_DIR = os.getcwd()
+-
+- # Paths obtained
+- sys.path.insert(0, os.path.join(LIGHTYEARS_DIR, 'code'))
+- data_dir = os.path.join(LIGHTYEARS_DIR, 'data')
+-
+- # Go
+- try:
+- import startup
+- assert os.path.isdir(data_dir)
+- except:
+- print "Unable to find LightYears code & data in:"
+- for p in sys.path:
+- print ' ', p
+-
+- sys.exit(1)
+-
+- startup.Main(data_dir)
+-
+-
++ sys.path.insert(0, "@GENTOO_LIBDIR@")
++ import startup
++ startup.Main("@GENTOO_DATADIR@/data")
diff --git a/games-strategy/lightyears/lightyears-1.4-r2.ebuild b/games-strategy/lightyears/lightyears-1.4-r2.ebuild
new file mode 100644
index 000000000000..7e7344951fc2
--- /dev/null
+++ b/games-strategy/lightyears/lightyears-1.4-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit desktop python-single-r1
+
+DESCRIPTION="A single-player game with a science-fiction theme"
+HOMEPAGE="http://www.jwhitham.org/20kly/"
+SRC_URI="http://www.jwhitham.org/20kly/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygame[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}/${P}"-gentoo.patch
+ sed -i \
+ -e "s:@GENTOO_LIBDIR@:/usr/$(get_libdir)/${PN}:" \
+ -e "s:@GENTOO_DATADIR@:/usr/share/${PN}:" \
+ ${PN} || die
+ python_fix_shebang .
+}
+
+src_install() {
+ dobin ${PN}
+
+ insinto /usr/"$(get_libdir)/${PN}"
+ doins code/*.py
+
+ einstalldocs
+
+ insinto "/usr/share/${PN}"
+ doins -r audio data manual
+
+ python_optimize "${ED}/usr/$(get_libdir)/${PN}"
+
+ newicon data/32.png ${PN}.png
+ make_desktop_entry ${PN} "Light Years Into Space"
+}
diff --git a/games-strategy/lightyears/metadata.xml b/games-strategy/lightyears/metadata.xml
new file mode 100644
index 000000000000..c314eef5e089
--- /dev/null
+++ b/games-strategy/lightyears/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription lang="en">
+"20,000 Light Years Into Space" was written for Pyweek (March 2006) by Jack
+Whitham. It is a single-player real-time strategy game with a science-fiction
+theme.
+</longdescription>
+</pkgmetadata>