summaryrefslogtreecommitdiff
path: root/games-strategy/julius
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /games-strategy/julius
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'games-strategy/julius')
-rw-r--r--games-strategy/julius/Manifest4
-rw-r--r--games-strategy/julius/files/90julius.sh2
-rw-r--r--games-strategy/julius/julius-1.4.1.ebuild49
-rw-r--r--games-strategy/julius/metadata.xml25
4 files changed, 80 insertions, 0 deletions
diff --git a/games-strategy/julius/Manifest b/games-strategy/julius/Manifest
new file mode 100644
index 000000000000..0ed82ae3ad04
--- /dev/null
+++ b/games-strategy/julius/Manifest
@@ -0,0 +1,4 @@
+AUX 90julius.sh 72 BLAKE2B d07d935037fa998174fffd1c786ffe2dab8d6af4eb9b71f0c30e1ad2e528ddda09232c4009573935f64eccf3c99b23041441579b99110a96f31a003b7db87ba6 SHA512 39ad3849f341a0817623cd3daf3d0ce255784c33538a9b1f9e25fa6655c59e8c3f56cc2f4bca23692e64118c78900c8dede656e9a1af5a043904b02fdf0e84dc
+DIST julius-1.4.1.tar.gz 8592785 BLAKE2B 8eb91522fccdee33600b02de766727beb19f138c0f695eb92aaa77ea2f25ec293906d0c75d31d42159097a12317ba38b22c01e7edf722670f51fe56d625d9ae7 SHA512 8488cee4a229299fd771f7ebddf076888b2e11458b2edbb6058b29b1f7e79d372ec2f913df3afacd8191551ba692a900508e64661ead1029916e28f356f79f7b
+EBUILD julius-1.4.1.ebuild 1450 BLAKE2B aa8530a01ac3246f04bffb3762268325496e8c50eedcca72ea0d100508eea7bb607fc776c9c5c46a732024c1309fd4c1c70fd2b7a1c065887c09f8d5c78ee84e SHA512 ec2afdc6bd8b85d9e799ba79a80057f6479bbbc1ed6489a310322c239ca77278f3733718e4409082a3685e58f10a8cecf3758df3f7d5814dc64d62d656335aee
+MISC metadata.xml 967 BLAKE2B 1bbe893da1d8326518e5ad1ec1e2bd238080db0cb9e022df84209f4a593ea94eb08066b44ec9bcba6e7acb2ba9d01b042e32d153a117b40c77a3aa08ebe33c12 SHA512 0b7d07bd6b945918856b0339db7695d361ce2e0e62137ede757dbdd8b544d5fb3ac81099308a8751f2dba07bdc5f3e5a417334622ab4578e9865c091259463dc
diff --git a/games-strategy/julius/files/90julius.sh b/games-strategy/julius/files/90julius.sh
new file mode 100644
index 000000000000..e88111f8994b
--- /dev/null
+++ b/games-strategy/julius/files/90julius.sh
@@ -0,0 +1,2 @@
+#!/usr/bin/env bash
+alias julius-game='julius-game ~/.cache/julius/app'
diff --git a/games-strategy/julius/julius-1.4.1.ebuild b/games-strategy/julius/julius-1.4.1.ebuild
new file mode 100644
index 000000000000..811dfaebf3f6
--- /dev/null
+++ b/games-strategy/julius/julius-1.4.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg
+
+DESCRIPTION="Feature-faithful open source re-implementation of Caesar III"
+HOMEPAGE="https://github.com/bvschaik/julius"
+SRC_URI="https://github.com/bvschaik/julius/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ media-libs/libpng:0=
+ media-libs/libsdl2[joystick,video,sound]
+ media-libs/sdl2-mixer
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cmake_src_prepare
+ xdg_src_prepare
+}
+
+src_install() {
+ insinto /etc/profile.d
+ doins "${FILESDIR}"/90julius.sh
+ cmake_src_install
+ mv "${ED}"/usr/bin/julius "${ED}"/usr/bin/julius-game ||
+ die "Failed to rename executable (required as per conflict with app-accessibility/julius)"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ ewarn "Julius requires you to download the original Caesar 3 resources."
+ ewarn
+ ewarn "You need to obtain these files from a vendor of the proprietary software."
+ ewarn "You will then need to copy the 'app' directory into '~/.cache/julius/'."
+ ewarn "One way to obtain this directory is to download the GOG Cesar 3 edition."
+ ewarn "You can then produce this directory by running:"
+ ewarn " innoextract -m setup_caesar3_2.0.0.9.exe"
+ ewarn
+ ewarn "Lastly, run 'source /etc/profile' to refresh your environment and be able"
+ ewarn "to start the game directly by running 'julius-game' in the command line."
+}
diff --git a/games-strategy/julius/metadata.xml b/games-strategy/julius/metadata.xml
new file mode 100644
index 000000000000..88f523bf415c
--- /dev/null
+++ b/games-strategy/julius/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>chr@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <longdescription lang="en">
+ The aim of this project is to create an open-source version of
+ Caesar 3, with the same logic as the original, but with some UI
+ enhancements, that is able to be played on multiple platforms.
+ The same logic means that the saved games are 100% compatible,
+ and any gameplay bugs present in the original Caesar 3 game will
+ also be present in Julius. It is meant as a drop-in replacement
+ for Caesar 3, with the same look and feel, so there will be no
+ major UI changes.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">bvschaik/julius</remote-id>
+ </upstream>
+</pkgmetadata>