summaryrefslogtreecommitdiff
path: root/games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild')
-rw-r--r--games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild b/games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild
new file mode 100644
index 000000000000..17c62c2450c1
--- /dev/null
+++ b/games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A port of Jagged Alliance 2 to SDL"
+HOMEPAGE="https://ja2-stracciatella.github.io/"
+SRC_URI="https://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz
+ http://tron.homeunix.org/ja2/editor.slf.gz"
+
+LICENSE="SFI-SCLA"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="cdinstall editor zlib"
+
+DEPEND="media-libs/libsdl[X,sound,video]
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}
+ cdinstall? ( games-strategy/ja2-stracciatella-data )"
+
+LANGS="linguas_de +linguas_en linguas_fr linguas_it linguas_nl linguas_pl linguas_ru linguas_ru_gold"
+IUSE="$IUSE $LANGS"
+REQUIRED_USE="^^ ( ${LANGS//+/} )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${P}-gcc6.patch
+
+ sed \
+ -e "s:/some/place/where/the/data/is:${GAMES_DATADIR}/ja2:" \
+ -i sgp/FileMan.cc || die
+
+ sed \
+ -e "s:@GAMES_DATADIR@:${GAMES_DATADIR}/ja2/data:" \
+ "${FILESDIR}"/ja2-convert.sh > "${T}"/ja2-convert || die
+}
+
+src_compile() {
+ local myconf
+
+ case ${LINGUAS} in
+ de) myconf="LNG=GERMAN" ;;
+ nl) myconf="LNG=DUTCH" ;;
+ fr) myconf="LNG=FRENCH" ;;
+ it) myconf="LNG=ITALIAN" ;;
+ pl) myconf="LNG=POLISH" ;;
+ ru) myconf="LNG=RUSSIAN" ;;
+ ru_gold) myconf="LNG=RUSSIAN_GOLD" ;;
+ en) myconf="LNG=ENGLISH" ;;
+ *) die "wat" ;;
+ esac
+ elog "Chosen language is ${myconf#LNG=}"
+
+ use editor && myconf+=" JA2EDITOR=yes JA2BETAVERSION=yes"
+ use zlib && myconf+=" WITH_ZLIB=yes"
+
+ emake ${myconf}
+}
+
+src_install() {
+ dogamesbin ja2 "${T}"/ja2-convert
+
+ if use editor; then
+ insinto "${GAMES_DATADIR}"/ja2/data
+ doins "${WORKDIR}"/editor.slf
+ fi
+
+ make_desktop_entry ja2 ${PN}
+ doman ja2.6
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ elog "You need ja2 in the chosen language, otherwise set it in package.use!"
+
+ if ! use cdinstall ; then
+ elog "You need to copy all files from the Data directory of"
+ elog "Jagged Alliance 2 installation to"
+ elog "${GAMES_DATADIR}/ja2/data "
+ elog "Make sure the filenames are lowercase. You may want to run the"
+ elog "script":
+ elog "${GAMES_BINDIR}/ja2-convert"
+ fi
+}