summaryrefslogtreecommitdiff
path: root/games-strategy/ja2-stracciatella/files/ja2-stracciatella-0.20.0-lua-cmake.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-08 06:15:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-08 06:15:27 +0000
commit268f9f01921ccb921b794d43092c5f29c1e96c56 (patch)
tree07329b3a8cb5d315182a2ec2b2f4a4b36374724d /games-strategy/ja2-stracciatella/files/ja2-stracciatella-0.20.0-lua-cmake.patch
parente3a48e635527f3e2d2254e9631f7a5758df9c3fb (diff)
gentoo auto-resync : 08:01:2023 - 06:15:27
Diffstat (limited to 'games-strategy/ja2-stracciatella/files/ja2-stracciatella-0.20.0-lua-cmake.patch')
-rw-r--r--games-strategy/ja2-stracciatella/files/ja2-stracciatella-0.20.0-lua-cmake.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/games-strategy/ja2-stracciatella/files/ja2-stracciatella-0.20.0-lua-cmake.patch b/games-strategy/ja2-stracciatella/files/ja2-stracciatella-0.20.0-lua-cmake.patch
new file mode 100644
index 000000000000..d09ac895119b
--- /dev/null
+++ b/games-strategy/ja2-stracciatella/files/ja2-stracciatella-0.20.0-lua-cmake.patch
@@ -0,0 +1,14 @@
+--- a/dependencies/lib-lua/CMakeLists.txt
++++ b/dependencies/lib-lua/CMakeLists.txt
+@@ -3,9 +3,9 @@
+ option(LOCAL_LUA_LIB "Download and build Lua instead of searching the system" ON)
+ if (NOT LOCAL_LUA_LIB)
+ message(STATUS "Using system Lua")
+- find_package(Lua "5.3" REQUIRED)
++ find_package(Lua "${LUA_VERSION}" REQUIRED EXACT)
+ if (NOT LUA_FOUND)
+- message(FATAL_ERROR "Lua 5.3 not found")
++ message(FATAL_ERROR "Lua ${LUA_VERSION} not found")
+ endif()
+
+ set(LUA_INCLUDE_DIRS "${LUA_INCLUDE_DIR}" PARENT_SCOPE)