summaryrefslogtreecommitdiff
path: root/games-strategy/ja2-stracciatella-data
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-strategy/ja2-stracciatella-data
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-strategy/ja2-stracciatella-data')
-rw-r--r--games-strategy/ja2-stracciatella-data/Manifest2
-rw-r--r--games-strategy/ja2-stracciatella-data/ja2-stracciatella-data-1.ebuild57
-rw-r--r--games-strategy/ja2-stracciatella-data/metadata.xml8
3 files changed, 67 insertions, 0 deletions
diff --git a/games-strategy/ja2-stracciatella-data/Manifest b/games-strategy/ja2-stracciatella-data/Manifest
new file mode 100644
index 000000000000..df17ad7cc8a7
--- /dev/null
+++ b/games-strategy/ja2-stracciatella-data/Manifest
@@ -0,0 +1,2 @@
+EBUILD ja2-stracciatella-data-1.ebuild 1313 BLAKE2B cecb581bcd57959652149938e091f4baf50923b22587fe27718d8350cd2288f316b20dcb7303fb9dcced26210d2680483f17aafec019af243b263c5801a16bcc SHA512 3718d75c55421e216a72d4a04d296b6ebb7567d7532fd189e7da0a125a8ae1947f132ac3779088ce2778e3878321d4921241917048b34ed53b7eda1d9e7ee6f0
+MISC metadata.xml 253 BLAKE2B 443ca9c8d4f6801169382e87a0ecd1385c56e65229209e7200f9d313ef380e92ae8d7dc3c38e5989a4166289f22607a20b1e13bb960fff6b3d9f78629d8ab020 SHA512 61c4689cbc649d84a00be211b7b5b98dd03e1d3f813eff370df549f2998cd4343f391c18b57cf20e4a8f4dd2311e3bfa04eb60f356f2bbac78f0b68f5091f254
diff --git a/games-strategy/ja2-stracciatella-data/ja2-stracciatella-data-1.ebuild b/games-strategy/ja2-stracciatella-data/ja2-stracciatella-data-1.ebuild
new file mode 100644
index 000000000000..f25285d68939
--- /dev/null
+++ b/games-strategy/ja2-stracciatella-data/ja2-stracciatella-data-1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit cdrom check-reqs games
+
+DESCRIPTION="A port of Jagged Alliance 2 to SDL (data files)"
+HOMEPAGE="http://tron.homeunix.org/ja2/"
+SRC_URI=""
+
+LICENSE="SIR-TECH"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unshield"
+
+S=${WORKDIR}
+
+CHECKREQS_DISK_BUILD="3G"
+CHECKREQS_DISK_USR="1G"
+
+src_unpack() {
+ export CDROM_NAME="INSTALL_CD"
+
+ cdrom_get_cds INSTALL/data1.cab
+
+ # this makes some serious overhead
+ unshield x "${CDROM_ROOT}"/INSTALL/data1.cab || die "unpacking failed"
+}
+
+src_prepare() {
+ cd "${S}"/Ja2_Files/Data || die
+ local lower i
+
+ # convert to lowercase
+ find . \( -iname "*.jsd" -o -iname "*.wav" -o -iname "*.sti" -o -iname "*.slf" \) \
+ -exec sh -c 'echo "${1}"
+ lower="`echo "${1}" | tr [:upper:] [:lower:]`"
+ [ -d `dirname "${lower}"` ] || mkdir `dirname ${lower}`
+ [ "${1}" = "${lower}" ] || mv "${1}" "${lower}"' - {} \;
+
+ # remove possible leftover
+ rm -r ./TILECACHE ./STSOUNDS
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/ja2/data
+ doins -r "${S}"/Ja2_Files/Data/*
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "This is just the data portion of the game. You will need to install"
+ elog "games-strategy/ja2-stracciatella to play the game."
+}
diff --git a/games-strategy/ja2-stracciatella-data/metadata.xml b/games-strategy/ja2-stracciatella-data/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-strategy/ja2-stracciatella-data/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>