summaryrefslogtreecommitdiff
path: root/games-strategy/ja2-stracciatella-data/ja2-stracciatella-data-1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-strategy/ja2-stracciatella-data/ja2-stracciatella-data-1-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-strategy/ja2-stracciatella-data/ja2-stracciatella-data-1-r1.ebuild')
-rw-r--r--games-strategy/ja2-stracciatella-data/ja2-stracciatella-data-1-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/games-strategy/ja2-stracciatella-data/ja2-stracciatella-data-1-r1.ebuild b/games-strategy/ja2-stracciatella-data/ja2-stracciatella-data-1-r1.ebuild
new file mode 100644
index 000000000000..ccf6a75a48a4
--- /dev/null
+++ b/games-strategy/ja2-stracciatella-data/ja2-stracciatella-data-1-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CHECKREQS_DISK_BUILD="3G"
+CHECKREQS_DISK_USR="1G"
+inherit cdrom check-reqs
+
+DESCRIPTION="A port of Jagged Alliance 2 to SDL (data files)"
+HOMEPAGE="http://tron.homeunix.org/ja2/"
+S="${WORKDIR}"
+
+LICENSE="SIR-TECH"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="app-arch/unshield"
+
+src_unpack() {
+ export CDROM_NAME="INSTALL_CD"
+
+ cdrom_get_cds INSTALL/data1.cab
+
+ # this makes some serious overhead
+ unshield x "${CDROM_ROOT}"/INSTALL/data1.cab || die "unpacking failed"
+}
+
+src_prepare() {
+ cd "${S}"/Ja2_Files/Data || die
+
+ default
+
+ local lower i
+ # convert to lowercase
+ find . \( -iname "*.jsd" -o -iname "*.wav" -o -iname "*.sti" -o -iname "*.slf" \) \
+ -exec sh -c 'echo "${1}"
+ lower="`echo "${1}" | tr [:upper:] [:lower:]`"
+ [ -d `dirname "${lower}"` ] || mkdir `dirname ${lower}`
+ [ "${1}" = "${lower}" ] || mv "${1}" "${lower}"' - {} \;
+
+ # remove possible leftover
+ rm -r ./TILECACHE ./STSOUNDS || die
+}
+
+src_install() {
+ insinto /usr/share/ja2/data
+ doins -r "${S}"/Ja2_Files/Data/*
+}
+
+pkg_postinst() {
+ elog "This is just the data portion of the game. You will need to install"
+ elog "games-strategy/ja2-stracciatella to play the game."
+}