summaryrefslogtreecommitdiff
path: root/games-strategy/heroes3-demo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-strategy/heroes3-demo
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-strategy/heroes3-demo')
-rw-r--r--games-strategy/heroes3-demo/Manifest3
-rw-r--r--games-strategy/heroes3-demo/heroes3-demo-1.3.1a.ebuild65
-rw-r--r--games-strategy/heroes3-demo/metadata.xml8
3 files changed, 76 insertions, 0 deletions
diff --git a/games-strategy/heroes3-demo/Manifest b/games-strategy/heroes3-demo/Manifest
new file mode 100644
index 000000000000..fefb12231eec
--- /dev/null
+++ b/games-strategy/heroes3-demo/Manifest
@@ -0,0 +1,3 @@
+DIST heroes3-demo.run 99026773 BLAKE2B 48963111c1f076acc2eb3f34a3b86d64943777ea76e8fba09f883bdfe4b89c4daa07e9e5dc584f2a11adda957869728c0806726ef21c6ff82843605e32e34ab7 SHA512 a3f60f12f7ce8ea0f160ec211e1f077693ff2f5e4b8b85ae0e31f1230a910b4df7c8c6a340762d4f09c9845d6141d235307f933305557a75fc63f409e077ac71
+EBUILD heroes3-demo-1.3.1a.ebuild 1438 BLAKE2B bfa532c2791435d8ce9be9f2cf92d68e770c512f1fd8c3da49c13fb80c4f776f2b63a7e7a6af7f139959821c954a1256773232ca1b43951d6ebf0bf360f7329b SHA512 a5dd6d09ba5d48b505bf610fdddcefd537c1263d33f5de8d7076529c841910711bbdfd5579c7bfa0574a9d8c23afd4bf2decf0d349ac9a33903f635ed11ee00c
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-strategy/heroes3-demo/heroes3-demo-1.3.1a.ebuild b/games-strategy/heroes3-demo/heroes3-demo-1.3.1a.ebuild
new file mode 100644
index 000000000000..d20f909b2cb3
--- /dev/null
+++ b/games-strategy/heroes3-demo/heroes3-demo-1.3.1a.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils unpacker games
+
+MY_PN=${PN%-demo}
+
+DESCRIPTION="turn-based 2D medieval combat"
+HOMEPAGE="http://www.lokigames.com/products/heroes3/"
+SRC_URI="mirror://lokigames/loki_demos/${PN}.run"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+# Should also work on ppc
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror bindist strip"
+
+DEPEND="games-util/loki_patch"
+RDEPEND=">=sys-libs/lib-compat-loki-0.2
+ || (
+ ppc? (
+ x11-libs/libX11
+ )
+ !ppc? (
+ x11-libs/libX11[abi_x86_32(-)]
+ )
+ )"
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${dir:1}/*"
+
+S=${WORKDIR}
+
+src_install() {
+ # Apply patch
+ loki_patch patch.dat data/ || die
+
+ local demo="data/demos/${MY_PN}_demo"
+
+ local exe_stub="${MY_PN}_demo"
+ if use ppc ; then
+ exe="${exe_stub}.ppc"
+ else
+ exe="${exe_stub}.x86"
+ fi
+
+ insinto "${dir}"
+ exeinto "${dir}"
+ doins -r "${demo}"/*
+ rm "${D}/${dir}"/{${exe_stub}*,*.sh} || die
+ doexe "${demo}/${exe}"
+
+ einfo "Linking libs provided by 'sys-libs/lib-compat-loki' to '${dir}'."
+ dosym /lib/loki_ld-linux.so.2 "${dir}"/ld-linux.so.2
+ dosym /usr/lib/loki_libc.so.6 "${dir}"/libc.so.6
+ dosym /usr/lib/loki_libnss_files.so.2 "${dir}"/libnss_files.so.2
+
+ games_make_wrapper ${PN} "./${exe}" "${dir}"
+ newicon "${demo}/icon.xpm" ${PN}.png
+ make_desktop_entry ${PN} "Heroes of Might and Magic III (Demo)" ${PN}
+
+ prepgamesdirs
+}
diff --git a/games-strategy/heroes3-demo/metadata.xml b/games-strategy/heroes3-demo/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-strategy/heroes3-demo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>