summaryrefslogtreecommitdiff
path: root/games-strategy/gwp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-strategy/gwp
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-strategy/gwp')
-rw-r--r--games-strategy/gwp/Manifest5
-rw-r--r--games-strategy/gwp/files/gwp-0.4.0-exec-stack.patch89
-rw-r--r--games-strategy/gwp/files/gwp-0.4.0-gcc41.patch107
-rw-r--r--games-strategy/gwp/gwp-0.4.0-r3.ebuild60
-rw-r--r--games-strategy/gwp/metadata.xml8
5 files changed, 269 insertions, 0 deletions
diff --git a/games-strategy/gwp/Manifest b/games-strategy/gwp/Manifest
new file mode 100644
index 000000000000..e00be7db2e04
--- /dev/null
+++ b/games-strategy/gwp/Manifest
@@ -0,0 +1,5 @@
+AUX gwp-0.4.0-exec-stack.patch 2842 BLAKE2B 7ab54e843e6b19768f433cae2898e7d9df7380996dc1e2afab8d9d3cf3ce081beef247d12234622e23fe6508aef21f3aecda5f4bc9744be6e9051eabc2aa8751 SHA512 b6845071c5639e4d240742e7470de4723e534814b670e8b98b1971c6e1ae2a64a8d4b8ffaf86ef28bdf3ad6d861dfeee5e2c5e46c43ea955614999fbed46da96
+AUX gwp-0.4.0-gcc41.patch 4100 BLAKE2B 656a9a6b514bd78e61b48a0f43e4230e8164107939c790d599398a0be213383f4f367e9c109cb3935b4a6a150034306f453a72356a2ea408e15e70ffc96ca16b SHA512 0e3acd8978f3a6f1585ad45c2d04c97282daa9173b6d67807d473d79bbc665be4a3471537139e9d710832afeff5e6aa4a3064c3cc36cfe3beba012f330530f31
+DIST gwp-0.4.0.tar.gz 2294453 BLAKE2B 75a688a00b3411c577e6eaae500d15963efb1c96edd82a50863239225fba2d653b52becda8ae71dbe5b88910382d1c64456fc13899e559d3aefefb6bed1e7da5 SHA512 dcb23bb49929bc01129ab5f02b56edb7f775feb0c37bd7613277af8aa0f4b47667f95413725f74a2b83b60159555a50fcabdc8736094aad0684b03cd150b4957
+EBUILD gwp-0.4.0-r3.ebuild 1312 BLAKE2B 7d64a2d61eb2e6359710ea46d8a9e43f08892407cdf9ee8ac6d62681ee29e7d66b11b0aaf0c4c7a78857a6c0e6e46cf16448b7c57f8043246d68d2f084f65cb4 SHA512 6df424a66ea2d011eeeb4b80373f0aeb343f1a12ae56c3a1896d33e16ee4861516ddbf6861878587edf274570bed0555044a6126cf3620e6063571ceab2d24e1
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-strategy/gwp/files/gwp-0.4.0-exec-stack.patch b/games-strategy/gwp/files/gwp-0.4.0-exec-stack.patch
new file mode 100644
index 000000000000..1458b7ba1dfd
--- /dev/null
+++ b/games-strategy/gwp/files/gwp-0.4.0-exec-stack.patch
@@ -0,0 +1,89 @@
+--- src/starchart.c
++++ src/starchart.c
+@@ -3187,10 +3187,16 @@
+ /**
+ * Initializes starchart constellations.
+ */
++static GSList *planets;
++
++static void add_item (gpointer key, gpointer value, gpointer user_data) {
++ /* GSList *p_list = (GSList *)user_data; */
++ planets = g_slist_append (planets, value);
++}
++
+ static void
+ init_starchart_constellations (void)
+ {
+- GSList *planets = NULL;
+ GSList *ppq[TOTAL_QUADS];
+ GSList *list_nearby = NULL;
+ GwpPlanet *planet_a, *planet_b;
+@@ -3199,10 +3205,6 @@
+ gdouble wx, wy;
+ gdouble ax, ay, bx, by, zoom;
+
+- static void add_item (gpointer key, gpointer value, gpointer user_data) {
+- /* GSList *p_list = (GSList *)user_data; */
+- planets = g_slist_append (planets, value);
+- }
+
+ g_hash_table_foreach (planet_list, (GHFunc)add_item, NULL);
+
+--- src/vcr.c
++++ src/vcr.c
+@@ -2687,12 +2687,29 @@
+ return( retval );
+ }
+
++static gchar *name;
++
++static void foreach_func( gpointer key, gpointer value, gpointer user_data )
++{
++ GwpShip *ship = GWP_SHIP( value );
++ GtkComboBox *box = GTK_COMBO_BOX( lookup_widget( "vcr_comboboxentry_sel_ext_shp_a" ) );
++ gint *idlist = (gint *)g_object_get_data(G_OBJECT(lookup_widget("vcr_comboboxentry_sel_ext_shp_a")), "shipidlist");
++ gint curr = idlist[0];
++
++ if( gwp_ship_is_mine( ship ) )
++ {
++ curr++;
++ idlist[curr] = gwp_object_get_id( GWP_OBJECT(ship) );
++ idlist[0]++;
++ g_sprintf( name, "%03d: ", idlist[curr] );
++ strncat( name, gwp_object_get_name (GWP_OBJECT(ship)), 50 );
++ gtk_combo_box_append_text( box, name );
++ }
++}
+
+ void vcr_populate_ship_a_list( GtkWidget *widget, gpointer user_data )
+ {
+- gchar *name;
+ gint *idlist;
+- static void foreach_func( gpointer key, gpointer value, gpointer user_data );
+
+ /* test if list is already populated */
+ idlist = (gint *)g_object_get_data(G_OBJECT(lookup_widget("vcr_comboboxentry_sel_ext_shp_a")), "shipidlist");
+@@ -2708,23 +2725,7 @@
+ GtkWidget *combox = lookup_widget("vcr_comboboxentry_sel_ext_shp_a");
+ g_object_set_data(G_OBJECT(combox), "shipidlist", idlist );
+
+- void foreach_func( gpointer key, gpointer value, gpointer user_data )
+- {
+- GwpShip *ship = GWP_SHIP( value );
+- GtkComboBox *box = GTK_COMBO_BOX( lookup_widget( "vcr_comboboxentry_sel_ext_shp_a" ) );
+- gint *idlist = (gint *)g_object_get_data(G_OBJECT(lookup_widget("vcr_comboboxentry_sel_ext_shp_a")), "shipidlist");
+- gint curr = idlist[0];
+
+- if( gwp_ship_is_mine( ship ) )
+- {
+- curr++;
+- idlist[curr] = gwp_object_get_id( GWP_OBJECT(ship) );
+- idlist[0]++;
+- g_sprintf( name, "%03d: ", idlist[curr] );
+- strncat( name, gwp_object_get_name (GWP_OBJECT(ship)), 50 );
+- gtk_combo_box_append_text( box, name );
+- }
+- }
+
+ g_hash_table_foreach( ship_list, (GHFunc) foreach_func, user_data );
+
diff --git a/games-strategy/gwp/files/gwp-0.4.0-gcc41.patch b/games-strategy/gwp/files/gwp-0.4.0-gcc41.patch
new file mode 100644
index 000000000000..fa7ee5c5443c
--- /dev/null
+++ b/games-strategy/gwp/files/gwp-0.4.0-gcc41.patch
@@ -0,0 +1,107 @@
+--- src/gwp-game-state.c.old 2006-03-05 00:56:48.000000000 +0900
++++ src/gwp-game-state.c 2006-03-05 00:57:38.000000000 +0900
+@@ -749,7 +749,7 @@
+ /* Connect to interesting signals */
+ /**********************************/
+ /* Selected planets */
+- static void planet_conn (gpointer key, gpointer value, gpointer self) {
++ void planet_conn (gpointer key, gpointer value, gpointer self) {
+ g_signal_connect (GWP_PLANET(value),
+ "selected",
+ G_CALLBACK(selected_planet_notification),
+@@ -757,7 +757,7 @@
+ }
+ g_hash_table_foreach (planet_list, (GHFunc) planet_conn, self);
+ /* Selected ships */
+- static void ship_conn (gpointer key, gpointer value, gpointer self) {
++ void ship_conn (gpointer key, gpointer value, gpointer self) {
+ g_signal_connect (GWP_SHIP(value),
+ "selected",
+ G_CALLBACK(selected_ship_notification),
+--- src/starchart.c.old 2006-03-05 01:13:39.000000000 +0900
++++ src/starchart.c 2006-03-05 01:18:04.000000000 +0900
+@@ -2111,7 +2111,7 @@
+ /*******************/
+ /* Planets signals */
+ /*******************/
+- static void planet_conn (gpointer key, gpointer value, gpointer data) {
++ void planet_conn (gpointer key, gpointer value, gpointer data) {
+ g_signal_connect (GWP_PLANET(value),
+ "property-changed",
+ G_CALLBACK(update_planet_notification),
+--- src/vp_utils.c.old 2006-03-05 01:18:14.000000000 +0900
++++ src/vp_utils.c 2006-03-05 01:18:52.000000000 +0900
+@@ -2590,7 +2590,7 @@
+ gwp_planet_set_colonists (planet, atoi(p_clans));
+
+ /* Compare func */
+- static gint compare_race (gconstpointer race, gconstpointer adj) {
++ gint compare_race (gconstpointer race, gconstpointer adj) {
+ gchar *race_str = gwp_race_get_adjective(GWP_RACE(race));
+ if (strncmp(race_str, adj, strlen(adj)) == 0)
+ return 0;
+@@ -2639,7 +2639,7 @@
+ /* Assign known planet values */
+ gwp_planet_set_is_known (planet, TRUE);
+ /* Compare func */
+- static gint compare_race (gconstpointer race, gconstpointer adj) {
++ gint compare_race (gconstpointer race, gconstpointer adj) {
+ gchar *race_str = gwp_race_get_adjective(GWP_RACE(race));
+ if (strncmp(race_str, adj, strlen(adj)) == 0)
+ return 0;
+--- src/gwp-py-mappings.c.old 2006-03-05 01:28:39.000000000 +0900
++++ src/gwp-py-mappings.c 2006-03-05 01:29:30.000000000 +0900
+@@ -8657,7 +8657,7 @@
+ {
+ PyObject *ret = PyDict_New();
+
+- static void add_ship (gpointer key, gpointer value, gpointer user_data) {
++ void add_ship (gpointer key, gpointer value, gpointer user_data) {
+ PyObject *dict = (PyObject *)user_data;
+ GwpShip *ship = GWP_SHIP(value);
+
+@@ -8679,7 +8679,7 @@
+ {
+ PyObject *ret = PyDict_New();
+
+- static void add_planet (gpointer key, gpointer value, gpointer user_data) {
++ void add_planet (gpointer key, gpointer value, gpointer user_data) {
+ PyObject *dict = (PyObject *)user_data;
+ GwpPlanet *planet = GWP_PLANET(value);
+
+@@ -8701,7 +8701,7 @@
+ {
+ PyObject *ret = PyDict_New();
+
+- static void add_hullspec (gpointer value, gpointer user_data) {
++ void add_hullspec (gpointer value, gpointer user_data) {
+ PyObject *dict = (PyObject *)user_data;
+ GwpHullSpec *hullspec = GWP_HULLSPEC(value);
+
+@@ -8723,7 +8723,7 @@
+ {
+ PyObject *ret = PyDict_New();
+
+- static void add_engspec (gpointer value, gpointer user_data) {
++ void add_engspec (gpointer value, gpointer user_data) {
+ PyObject *dict = (PyObject *)user_data;
+ GwpEngSpec *engspec = GWP_ENGSPEC(value);
+
+@@ -8745,7 +8745,7 @@
+ {
+ PyObject *ret = PyDict_New();
+
+- static void add_beamspec (gpointer value, gpointer user_data) {
++ void add_beamspec (gpointer value, gpointer user_data) {
+ PyObject *dict = (PyObject *)user_data;
+ GwpBeamSpec *beamspec = GWP_BEAMSPEC(value);
+
+@@ -8767,7 +8767,7 @@
+ {
+ PyObject *ret = PyDict_New();
+
+- static void add_torpspec (gpointer value, gpointer user_data) {
++ void add_torpspec (gpointer value, gpointer user_data) {
+ PyObject *dict = (PyObject *)user_data;
+ GwpTorpSpec *torpspec = GWP_TORPSPEC(value);
+
diff --git a/games-strategy/gwp/gwp-0.4.0-r3.ebuild b/games-strategy/gwp/gwp-0.4.0-r3.ebuild
new file mode 100644
index 000000000000..f9a4fa227439
--- /dev/null
+++ b/games-strategy/gwp/gwp-0.4.0-r3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+GCONF_DEBUG="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils flag-o-matic gnome2 python-single-r1
+
+DESCRIPTION="GNOME client for the classic PBEM strategy game VGA Planets 3"
+HOMEPAGE="http://gwp.lunix.com.ar/"
+SRC_URI="http://gwp.lunix.com.ar/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls opengl python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="x11-libs/gtk+:2
+ gnome-base/libgnomeui
+ gnome-base/libglade
+ app-text/rarian
+ dev-libs/libpcre
+ nls? ( virtual/libintl )
+ opengl? ( x11-libs/gtkglext )
+ python? ( ${PYTHON_DEPS}
+ dev-python/pygtk[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ append-libs -lm
+ epatch \
+ "${FILESDIR}"/${P}-gcc41.patch \
+ "${FILESDIR}"/${P}-exec-stack.patch
+ sed -i \
+ -e '/ -O1/d' \
+ -e '/ -g$/d' \
+ src/Makefile.in || die
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable nls) \
+ $(use_enable opengl gtkglext) \
+ $(use_enable python)
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog CHANGES README TODO" \
+ gnome2_src_install
+ rm -rf "${D}"/usr/share/doc/gwp
+}
diff --git a/games-strategy/gwp/metadata.xml b/games-strategy/gwp/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-strategy/gwp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>