summaryrefslogtreecommitdiff
path: root/games-strategy/freesynd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-strategy/freesynd
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-strategy/freesynd')
-rw-r--r--games-strategy/freesynd/Manifest4
-rw-r--r--games-strategy/freesynd/files/freesynd-0.7.1-cmake.patch28
-rw-r--r--games-strategy/freesynd/freesynd-0.7.1-r1.ebuild76
-rw-r--r--games-strategy/freesynd/metadata.xml14
4 files changed, 122 insertions, 0 deletions
diff --git a/games-strategy/freesynd/Manifest b/games-strategy/freesynd/Manifest
new file mode 100644
index 000000000000..389db704dbdd
--- /dev/null
+++ b/games-strategy/freesynd/Manifest
@@ -0,0 +1,4 @@
+AUX freesynd-0.7.1-cmake.patch 931 BLAKE2B 0ad1994ad923355fdcae7c472a1440c88a848c409d5cc17b43d4d42e6307eb5c9f362efae5d81227d6ed6a7a4ecd5a7ec3492086e11f2208473190f2713fdd89 SHA512 994d12a2f079582bda03a600888c2d7ed2043468d69ce752e64deb45d156de5a7556edabd00d2635acc2c39882a8074193dc559e423e8e0181e9d4ea9d8b8b6f
+DIST freesynd-0.7.1.tar.gz 2576695 BLAKE2B 11b8f1d25768cdef6cf6894e8141cd13562a133a3253aa5b19034f0c54f114081dd97d41d230c74b5b1aaf66d84ad45d0c09ca5cdc72fb1de00a39ff23ad1272 SHA512 b87e6adaf71206532b4f90cd230ca6be00438fe26f000c5a0bfebf2839fea80d78d98ddc27331a2224874338c3e14ffbfa58b8c5bdbdc53c93bba8d6a9e6b7b4
+EBUILD freesynd-0.7.1-r1.ebuild 1597 BLAKE2B 3d7fadee4f1f1c9c8574b7477972cd781afab7c1f321137bfef5ae84cbb80c6b595ac1b73b165e4878f7a03995899c9a79fd90faddd035c3d10f0fd477f6da03 SHA512 29892a155a86b4a3eda85c5d1e8f987a85f7b63a70ef2b9adc981b509e804bcf2ae4b4b5c28bc19f4fe9499504f8d4a7d6c1e204ce7e9d32cd778394a525c718
+MISC metadata.xml 401 BLAKE2B e83ee7425bd7de156c4ce45903a7fe00a12ad94f9e8bfe8ab0547458d2cf3f883fbbb319494a40bdabbadf2d85e74d0a929c43973d27550a7198bfd2c0e7add7 SHA512 5750ad5bed978d8a906a3cea47f3602257b5390bb87096c1e005d0c2bd1921b9033bdfb87f14506e88e8929268a9c9bb0003c9b343d0a0040b30df2058726152
diff --git a/games-strategy/freesynd/files/freesynd-0.7.1-cmake.patch b/games-strategy/freesynd/files/freesynd-0.7.1-cmake.patch
new file mode 100644
index 000000000000..817cd39dcb4f
--- /dev/null
+++ b/games-strategy/freesynd/files/freesynd-0.7.1-cmake.patch
@@ -0,0 +1,28 @@
+--- freesynd-0.7.1/CMakeLists.txt
++++ freesynd-0.7.1/CMakeLists.txt
+@@ -34,6 +34,13 @@
+ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${EXTRA_C_FLAGS}")
+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${EXTRA_CXX_FLAGS}")
+
++option(BUILD_DEV_TOOLS "Build development tools")
++option(WITH_DEBUG "Enable debug definitions")
++
++if(WITH_DEBUG)
++ add_definitions (-D_DEBUG)
++endif()
++
+ # Set standard definitions for all platforms.
+ add_definitions (-DSYSTEM_SDL)
+ add_definitions (-DPREFIX=\"${CMAKE_INSTALL_PREFIX}\")
+@@ -59,10 +66,7 @@
+ message (FATAL_ERROR "Unable to locate PNG")
+ endif ()
+
+-if (NOT CMAKE_BUILD_TYPE OR CMAKE_BUILD_TYPE STREQUAL "debug")
+- set (BUILD_DEV_TOOLS TRUE)
+-else ()
+- set (BUILD_DEV_TOOLS FALSE)
++if (CMAKE_BUILD_TYPE AND NOT CMAKE_BUILD_TYPE STREQUAL "debug")
+ # We only define an install target if we're doing a release build.
+ # Furthermore, on Mac, the data folder is a part of the app bundle.
+ if (NOT APPLE)
diff --git a/games-strategy/freesynd/freesynd-0.7.1-r1.ebuild b/games-strategy/freesynd/freesynd-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..08cdeb54329a
--- /dev/null
+++ b/games-strategy/freesynd/freesynd-0.7.1-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+CMAKE_IN_SOURCE_BUILD=1
+inherit cmake-utils desktop gnome2-utils readme.gentoo-r1
+
+DESCRIPTION="Portable reimplementation of engine for the classic Bullfrog game, Syndicate"
+HOMEPAGE="http://freesynd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug devtools"
+
+RDEPEND="
+ media-libs/libogg
+ media-libs/libpng:0=
+ media-libs/libsdl[X,sound,video]
+ media-libs/libvorbis
+ media-libs/sdl-mixer[mp3,vorbis]
+ media-libs/sdl-image[png]
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( NEWS README INSTALL AUTHORS )
+
+PATCHES=( "${FILESDIR}"/${P}-cmake.patch )
+
+DOC_CONTENTS="
+ You have to set \"data_dir = /my/path/to/synd-data\"
+ in \"~/.${PN}/${PN}.ini\".
+"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ sed \
+ -e "s:#freesynd_data_dir = /usr/share/freesynd/data:freesynd_data_dir = /usr/share/${PN}/data:" \
+ -i ${PN}.ini || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_DEBUG=$(usex debug)
+ -DBUILD_DEV_TOOLS=$(usex devtools)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ dobin src/${PN}
+ use devtools && newbin src/dump ${PN}-dump
+ insinto /usr/share/${PN}
+ doins -r data
+ newicon -s 128 icon/sword.png ${PN}.png
+ make_desktop_entry ${PN}
+ einstalldocs
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ if use debug ; then
+ ewarn "Debug build is not meant for regular playing,"
+ ewarn "game speed is higher."
+ fi
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-strategy/freesynd/metadata.xml b/games-strategy/freesynd/metadata.xml
new file mode 100644
index 000000000000..2ba784f8d996
--- /dev/null
+++ b/games-strategy/freesynd/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="devtools">Build development tools</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">freesynd</remote-id>
+ </upstream>
+</pkgmetadata>