summaryrefslogtreecommitdiff
path: root/games-strategy/freeorion/freeorion-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /games-strategy/freeorion/freeorion-9999.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'games-strategy/freeorion/freeorion-9999.ebuild')
-rw-r--r--games-strategy/freeorion/freeorion-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/games-strategy/freeorion/freeorion-9999.ebuild b/games-strategy/freeorion/freeorion-9999.ebuild
index 048d1b8bf695..0b5fba26ee50 100644
--- a/games-strategy/freeorion/freeorion-9999.ebuild
+++ b/games-strategy/freeorion/freeorion-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-inherit cmake-utils python-single-r1 xdg
+inherit cmake python-single-r1 xdg
DESCRIPTION="A free turn-based space empire and galactic conquest game"
HOMEPAGE="https://www.freeorion.org"
@@ -15,7 +15,7 @@ if [[ ${PV} == 9999 ]]; then
else
KEYWORDS="~amd64"
if [[ ${PV} = *_p* ]]; then
- COMMIT="1570afb475763b13f5d2f434037ec907da812bb4"
+ COMMIT=""
SRC_URI="https://github.com/${PN}/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${COMMIT}"
else
@@ -35,7 +35,7 @@ BDEPEND="
"
RDEPEND="
$(python_gen_cond_dep '
- >=dev-libs/boost-1.67:=[python,threads,${PYTHON_MULTI_USEDEP}]
+ >=dev-libs/boost-1.60:=[nls,python,threads,${PYTHON_MULTI_USEDEP}]
')
!dedicated? (
media-libs/freealut
@@ -57,7 +57,7 @@ DEPEND="${RDEPEND}"
src_prepare() {
sed -e "s/-O3//" -i CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -67,11 +67,11 @@ src_configure() {
-DBUILD_HEADLESS="$(usex dedicated)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
newenvd "${FILESDIR}/${PN}.envd" 99${PN}
}