summaryrefslogtreecommitdiff
path: root/games-strategy/freeorion/freeorion-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /games-strategy/freeorion/freeorion-9999.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'games-strategy/freeorion/freeorion-9999.ebuild')
-rw-r--r--games-strategy/freeorion/freeorion-9999.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/games-strategy/freeorion/freeorion-9999.ebuild b/games-strategy/freeorion/freeorion-9999.ebuild
index 8d750687b353..578e570e2ffd 100644
--- a/games-strategy/freeorion/freeorion-9999.ebuild
+++ b/games-strategy/freeorion/freeorion-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils python-single-r1 gnome2-utils
+inherit cmake-utils python-single-r1 xdg
DESCRIPTION="A free turn-based space empire and galactic conquest game"
HOMEPAGE="http://www.freeorion.org"
@@ -40,7 +40,8 @@ RDEPEND="
!dev-games/gigi"
# Use bundled gigi as of freeorion-0.4.3
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
${PYTHON_DEPS}
virtual/pkgconfig"
@@ -57,12 +58,11 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
- -DCMAKE_BUILD_TYPEE=Release
- -DRELEASE_COMPILE_FLAGS=""
+ -DCMAKE_BUILD_TYPE=Release
-DCMAKE_SKIP_RPATH=ON
)
- append-cppflags -DBOOST_OPTIONAL_CONFIG_USE_OLD_IMPLEMENTATION_OF_OPTIONAL
+ #append-cppflags -DBOOST_OPTIONAL_CONFIG_USE_OLD_IMPLEMENTATION_OF_OPTIONAL
cmake-utils_src_configure
}
@@ -74,10 +74,14 @@ src_install() {
newenvd "${FILESDIR}/${PN}.envd" 99${PN}
}
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
pkg_postinst() {
- gnome2_icon_cache_update
+ xdg_pkg_postinst
}
pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_pkg_postrm
}