summaryrefslogtreecommitdiff
path: root/games-strategy/freeorion/freeorion-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /games-strategy/freeorion/freeorion-9999.ebuild
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'games-strategy/freeorion/freeorion-9999.ebuild')
-rw-r--r--games-strategy/freeorion/freeorion-9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/games-strategy/freeorion/freeorion-9999.ebuild b/games-strategy/freeorion/freeorion-9999.ebuild
index d95c1dfd5b18..7445d5c039df 100644
--- a/games-strategy/freeorion/freeorion-9999.ebuild
+++ b/games-strategy/freeorion/freeorion-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit check-reqs cmake multiprocessing python-single-r1 xdg
if [[ ${PV} == 9999 ]]; then
@@ -94,6 +94,11 @@ src_compile() {
src_test() {
cmake_src_test -j1 # avoid running 2 conflicting servers
+ local EPYTEST_DESELECT=(
+ # broken with 3.11 but is not known to cause issues, just skip for now
+ tests/AI/save_game_codec/test_savegame_manager.py::test_setstate_call
+ )
+
epytest -o cache_dir="${T}"/pytest_cache default/python/tests
}