summaryrefslogtreecommitdiff
path: root/games-strategy/dunelegacy/dunelegacy-0.96.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-strategy/dunelegacy/dunelegacy-0.96.3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-strategy/dunelegacy/dunelegacy-0.96.3.ebuild')
-rw-r--r--games-strategy/dunelegacy/dunelegacy-0.96.3.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/games-strategy/dunelegacy/dunelegacy-0.96.3.ebuild b/games-strategy/dunelegacy/dunelegacy-0.96.3.ebuild
new file mode 100644
index 000000000000..ee94d40caa60
--- /dev/null
+++ b/games-strategy/dunelegacy/dunelegacy-0.96.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# do not use autotools related stuff in stable ebuilds
+# unless you like random breakage: 469796, 469798, 424041
+
+EAPI=5
+inherit eutils gnome2-utils games # STABLE ARCH
+#inherit autotools eutils gnome2-utils games # UNSTABLE ARCH
+
+DESCRIPTION="Updated clone of Westood Studios' Dune2"
+HOMEPAGE="http://dunelegacy.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.bz2"
+SRC_URI="${SRC_URI} https://dev.gentoo.org/~hasufell/distfiles/${P}-no-autoreconf.patch.xz" # STABLE ARCH
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+alsa pulseaudio"
+
+RDEPEND="media-libs/libsdl[X,alsa?,sound,pulseaudio?,video]
+ media-libs/sdl-mixer[midi,mp3,vorbis]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+# exits on start without libsdl[alsa] or libsdl[pulseaudio]
+REQUIRED_USE="|| ( alsa pulseaudio )"
+
+src_prepare() {
+ epatch "${DISTDIR}"/${P}-no-autoreconf.patch.xz # STABLE ARCH
+# epatch "${FILESDIR}"/${P}-build.patch # UNSTABLE ARCH
+# eautoreconf # UNSTABLE ARCH
+}
+
+src_install() {
+ default
+
+ doicon -s scalable ${PN}.svg
+ doicon -s 48 ${PN}.png
+ make_desktop_entry ${PN} "Dune Legacy"
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}