summaryrefslogtreecommitdiff
path: root/games-strategy/crimson
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-strategy/crimson
reinit the tree, so we can have metadata
Diffstat (limited to 'games-strategy/crimson')
-rw-r--r--games-strategy/crimson/Manifest5
-rw-r--r--games-strategy/crimson/crimson-0.5.3.ebuild58
-rw-r--r--games-strategy/crimson/metadata.xml8
3 files changed, 71 insertions, 0 deletions
diff --git a/games-strategy/crimson/Manifest b/games-strategy/crimson/Manifest
new file mode 100644
index 000000000000..6f7891b22720
--- /dev/null
+++ b/games-strategy/crimson/Manifest
@@ -0,0 +1,5 @@
+DIST crimson-0.5.3.tar.bz2 882366 SHA256 d59858c05e340367c61c8ca1dd00c36642a0c56d10d1d9a1626c5ba7d88b40d6 SHA512 9632317c4b258ed5e501ad1d058706ed654fc621b07099f65d93e29fe92e53fc8f6bbffa13c70fc2129f30695d3f10e85174234dc96cc171631b3465d2b7cffc WHIRLPOOL 89ddb776b86de245004f69af3421803a8bceb30499b416612a52f3203eaeb98013cf1fe8af027f24756d77a05d3fa23a20a2c361cded41c19279f402498022f3
+EBUILD crimson-0.5.3.ebuild 1298 SHA256 82f27bcf84c84caee137c49afad503a4d8ab3740a55932358826442e1a8b4e21 SHA512 cc92584bbececce34b36bc3f2985171730cbb6bf9657bf0ea47a98cabee41e8e36a9280a416775a5521d248dd2ce45f71c27b180b3a7984be44f59a58609aaed WHIRLPOOL d6af8e225ca8af0d0b24c44f88ebcc9ea163c03d0655a673e116d3f2a1ff1df4b54ba3c5edc3277d077a6de1a7de0db8de46f834b8055b0b87aab9296da0c316
+MISC ChangeLog 2433 SHA256 e8e57693bd68e8caee08f709883dd0a97afe5ff01b3a5afd565983b15d8e3039 SHA512 25ae5ca71f43560402f4d1d27de902d586b69b050bd6d9ee1b156f92b8d192d9d886ffa67da955011a952527f6153671c55c7735e43fe2c333821834b94e8b1d WHIRLPOOL 8df3b64d8ad8a61cb54740334fbfebef35107b8a3892b2465ae93d95a6717875d2e7f1339e0fa90310e578c0972223271987182a1dd7983d05a0f0dd27d15ee4
+MISC ChangeLog-2015 4055 SHA256 a4a441a04255cf2d802e1de148e37fcbddb9d81089e9e42aeeff9bf1a8377e68 SHA512 c0c90b2b8e2528f9a213fa4d5590c23aa2956e0dd44101c86e6f2d33c1fbab209cdbd655db28f2398f6090c58a4b4aec2ad09cd3a974c53d2e798d9c19f8c6d4 WHIRLPOOL f85d32df07cd244e46fd4115d497df69474565d7a8b9dc8e8da4136227c87becb36e3a4c8fcf4408e690b7f52eacfdb8f8bc76e1a92b8e6a48d3c97f47d3be6f
+MISC metadata.xml 249 SHA256 943b9ce0cd072229b43569ab668dd7ec741d9dfefd942c8921dabd4490b27b0c SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118 WHIRLPOOL b10e21575c78e201a652c8582cd16e3f7c86b13dd20a30f4cea44066fb139440b3c186147dbaae83478f11a20b6f457a99c8b29ee1239a4caaa21eee01250088
diff --git a/games-strategy/crimson/crimson-0.5.3.ebuild b/games-strategy/crimson/crimson-0.5.3.ebuild
new file mode 100644
index 000000000000..2099e319409a
--- /dev/null
+++ b/games-strategy/crimson/crimson-0.5.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Tactical war game in the tradition of Battle Isle"
+HOMEPAGE="http://crimson.seul.org/"
+SRC_URI="http://crimson.seul.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test zlib"
+
+RDEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ media-libs/sdl-net
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ test? (
+ =app-text/docbook-xml-dtd-4.2*
+ dev-libs/libxml2
+ )"
+
+src_configure() {
+ egamesconf \
+ --enable-sound \
+ --enable-network \
+ $(use_with zlib) \
+ --enable-cfed \
+ --enable-bi2cf \
+ --enable-comet \
+ --enable-cf2bmp
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ pixmapsdir="/usr/share/pixmaps" \
+ install
+ dodoc NEWS README* THANKS TODO
+ rm -rf "${D}/${GAMES_DATADIR}/applications"
+ make_desktop_entry crimson "Crimson Fields"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ ewarn "Crimson Fields ${PV} is not necessarily save-game compatible with previous versions."
+ echo
+ elog "If you have older save files and you wish to continue those games,"
+ elog "you'll need to remerge the version with which you started"
+ elog "those save-games."
+}
diff --git a/games-strategy/crimson/metadata.xml b/games-strategy/crimson/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-strategy/crimson/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>