summaryrefslogtreecommitdiff
path: root/games-strategy/0ad
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-13 01:41:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-13 01:41:21 +0100
commitb89a664f266dab3b9b5ddac2cb874f8869142370 (patch)
tree21d127b0b99c1505ba548bc05975b9fcecda871e /games-strategy/0ad
parent7e662ec84fc13cef513542e4030f47017d030187 (diff)
gentoo auto-resync : 13:10:2022 - 01:41:21
Diffstat (limited to 'games-strategy/0ad')
-rw-r--r--games-strategy/0ad/0ad-0.0.26_alpha.ebuild (renamed from games-strategy/0ad/0ad-0.0.25b_alpha-r1.ebuild)24
-rw-r--r--games-strategy/0ad/Manifest12
-rw-r--r--games-strategy/0ad/files/0ad-0.0.25b_alpha-fix-name-collision-glibc.patch131
-rw-r--r--games-strategy/0ad/files/0ad-0.0.25b_alpha-python3.10.patch156
4 files changed, 19 insertions, 304 deletions
diff --git a/games-strategy/0ad/0ad-0.0.25b_alpha-r1.ebuild b/games-strategy/0ad/0ad-0.0.26_alpha.ebuild
index 0939933bda9d..c440f50e1334 100644
--- a/games-strategy/0ad/0ad-0.0.25b_alpha-r1.ebuild
+++ b/games-strategy/0ad/0ad-0.0.26_alpha.ebuild
@@ -4,14 +4,21 @@
EAPI=8
WX_GTK_VER="3.0-gtk3"
-PYTHON_COMPAT=( python3_{8..10} )
+# In alpha26 bundled spidermonkey-78.6.0 does not build with python 3.11.
+PYTHON_COMPAT=( python3_10 )
inherit desktop toolchain-funcs multiprocessing python-any-r1 wxwidgets xdg
DESCRIPTION="A free, real-time strategy game"
HOMEPAGE="https://play0ad.com/"
LICENSE="BitstreamVera CC-BY-SA-3.0 GPL-2 LGPL-2.1 LPPL-1.3c MIT ZLIB"
-# Upstream signs releases (and only them) with app-crypt/minisign.
-# The (public) key can be found on https://play0ad.com/download/source.
+# Upstream signs releases with app-crypt/minisign which is not supported
+# by IUSE="verify-sig", bug #783066. As a workaround the minisign key
+# is hardcoded and verifed manually in this ebuild.
+#
+# The public key can be found upstream - last update was w/ alpha 26:
+# https://trac.wildfiregames.com/wiki/VerifyingYourDownloads
+MINISIGN_KEY="RWTWLbO12+ig3lUExIor3xd6DdZaYFEozn8Bu8nIzY3ImuRYQszIQyyy"
+
if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/0ad/0ad"
@@ -23,7 +30,6 @@ elif [[ ${PV} == *_pre* ]]; then
else
# Trailing whitespace for IUSE append below
IUSE="verify-sig "
- MINISIGN_KEY="RWT0hFWv57I2RFoJwLVjxEr44JOq/RkEx1oT0IA3PPPICnSF7HFKW1CT"
MY_P="0ad-${PV/_/-}"
SRC_URI="
http://releases.wildfiregames.com/${MY_P}-unix-build.tar.xz
@@ -40,8 +46,8 @@ KEYWORDS="~amd64 ~arm64 ~x86"
IUSE+="editor +lobby nvtt pch test"
RESTRICT="test"
-CHECKREQS_DISK_BUILD="9000M" # 8769732 KiB (8.3 GiB) for alpha 25
-CHECKREQS_DISK_USR="3500M" # 3545972 KiB (3.3 GiB)
+CHECKREQS_DISK_BUILD="9000M" # 8795916 KiB (8.3 GiB) for alpha 26
+CHECKREQS_DISK_USR="3500M" # 3555340 KiB (3.3 GiB)
# Premake adds '-s' to some LDFLAGS. Simply sed'ing it out leads to
# build and/or startup issues.
@@ -56,8 +62,8 @@ BDEPEND="
virtual/rust
test? ( dev-lang/perl )
"
-# Upstream uses minisign which is not supported by verify-sign, bug #783066.
-# Signatures are only provided for releases.
+
+# For IUSE="verify-sig", see note about SRC_URI block.
if [[ ( ${PV} != *9999 ) && ( ${PV} != *_p* ) ]]; then
BDEPEND+=" app-crypt/minisign"
fi
@@ -91,8 +97,6 @@ RDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-0.0.24b_alpha-respect-tc.patch
"${FILESDIR}"/${PN}-0.0.25b_alpha-fix-setuptools.patch
- "${FILESDIR}"/${PN}-0.0.25b_alpha-python3.10.patch
- "${FILESDIR}"/${PN}-0.0.25b_alpha-fix-name-collision-glibc.patch
)
pkg_setup() {
diff --git a/games-strategy/0ad/Manifest b/games-strategy/0ad/Manifest
index 39de708357ff..2284cbec3e0e 100644
--- a/games-strategy/0ad/Manifest
+++ b/games-strategy/0ad/Manifest
@@ -1,10 +1,8 @@
AUX 0ad-0.0.24b_alpha-respect-tc.patch 1095 BLAKE2B c7f2747ae832de76da3711687ce8e6d52039e23cbe31ca1114d27e93ec2b3ef150f4b241a0d869ec393c9f73e702f35ce5610f9b383bbe43e958989bbcfa0c17 SHA512 00c439a086da6553b09230cf57e76c9abcf8c13093a4d439ccb5724d6dee5474c46f924c5a0c5b43cdc8572445347dcf2a77eba3fcff17b16d492ca4bef90594
-AUX 0ad-0.0.25b_alpha-fix-name-collision-glibc.patch 9330 BLAKE2B be2c57a5932a79b1e858c56beebe4f7778fcef1efddcbdc75ff92f9050bf2071704aaf1e3c3c2c37cc1ca8e69f573f05bbd2852fdfd8f0e37aa347748179bd60 SHA512 b31952973103232b77ef1b4a142bb572e576034af20a65d88b8f969a5cf9b1e47398df1a8e03c0e3312e167321c0b30eb3a0fa53dcddd87b945b58dcf521e59a
AUX 0ad-0.0.25b_alpha-fix-setuptools.patch 8270 BLAKE2B 65ec2d7be8602427a39b3b426dea0b4aa5741385d8416ae4db94f0f94d73b3c7ae2b3a851fbb5afe4e8d07d9d65739b5323d3f40e239fcb0d3d39e479419c3cf SHA512 b08424de3685c87901b3caeb39c415f0814f5a5a0a5df6890cf1fe829a822f4d52711c4219b230414c9144ecd1a6ff2b68973f91be415cff350df6f5b5f91fc9
-AUX 0ad-0.0.25b_alpha-python3.10.patch 5768 BLAKE2B f4327a856c71033c77f676e79e4fb11f16f70e733dbc302d07cf64ab96a56b28ae567823ef9e08203165746f29554d1bdc0841108805ee2be0afc4e769426004 SHA512 25cb7306ce843c46c609e0ae584ce57675e7838d161e4276a4dca40483c2acdaa364223d30443a3224e540caccc8ffcf0e58f343121762ac29feaa34ff0c77f5
-DIST 0ad-0.0.25b-alpha-unix-build.tar.xz 75579956 BLAKE2B 674d69d625137709a186f9273607dc353fc99aea68ef3f2ea5031dbe2f684176910d757c3f03c7fbdac475d30708be448b71f5020d27a65c346bf147223bcb9d SHA512 e8069897b97b381099ab5ec5868d27e96c699105b3307054d1bc7bf9236a537f02625ba9034892d91f3e951b4f95c9ce5fb75ed0a7c14b8a294882482fd9c1b4
-DIST 0ad-0.0.25b-alpha-unix-build.tar.xz.minisig 327 BLAKE2B 547a7a1c8a83167fa40976efb2efaf691fc5434eb1be227b481a70d308381b20dcdc90bb4652e190f8e329fb33cc19ebbaab43977329f8971e49436f7f1ce636 SHA512 9d6a235ea50183e1db16f4bf2dc59af9042a52e4e18ccd0c34c481a7e9021f19e2bc370e594aa97911bb7ca33bcc5ebe23a4b206cd74357060371ca06b6010d2
-DIST 0ad-0.0.25b-alpha-unix-data.tar.xz 1249684600 BLAKE2B d77546ba9d21b512f106645c07fa92ecc343e0a01d9a70a83f2a2b3ade912e72d095982f7d4c4cd64e18fb71a67a01c419763744dd4cad1e8c081e5f77ec17c9 SHA512 d6bbe484acb7fbd507d303f5c75f8a2ccbaf8fe9dd30ff408b082f170bfd96eb9235db1b710c15656ef465b44fa5597679a694515e0c153a35fe24c0915f29f1
-DIST 0ad-0.0.25b-alpha-unix-data.tar.xz.minisig 326 BLAKE2B 41975d4c4369780bd36edef448ab928c91ece0d60ddad04fbccd1da0ed5068b56c86fd57708c6158277c5db9faadc768f5e455d97fe5ae3c30a7522005c374e6 SHA512 ad3ef78b785db9eb37d547a86d2bf274e0b6635118a9c512d013adc45e4a0f071b86f0fb5bf696631596e0713b2de153b0ad245cbba86beb3ea153036178b07e
-EBUILD 0ad-0.0.25b_alpha-r1.ebuild 7941 BLAKE2B 045929660f56562edfb71e24d33b9b9c5c44ee87868c73a778838a94577885fd03a983f9c6ead899353fac1ee1761a85e6e88b0b6443cb30b60d777080014d58 SHA512 63c0ce51960713200ee54203c62b245f648cdf5687657c87c087a7e6b53579e843a358ebc9443a1e781d55eaddd14271d035999bf3f8c16de89eae2a89b6922d
+DIST 0ad-0.0.26-alpha-unix-build.tar.xz 75599800 BLAKE2B ddd589840b0dacee2377ff4e5624f69646b92da4217015d788c6abec097578e44aee6641b6a6945d15f50d8e50673a1d44587c2faf02278d981a0ed30c950214 SHA512 aaf647d5d8454c244015d2a198beeaaebc571a5bc96446f3acff8dbd05f9843029c500bf4162651a5e1fcdb42bd5fb5b4f5c512c78372479fbd8565dd093f272
+DIST 0ad-0.0.26-alpha-unix-build.tar.xz.minisig 333 BLAKE2B 9f3146abda592fe6ab9433f6ee30060bcd4c5b594e00cb3fccc0aebb74652f3bc2ddd7b19a296da7ca13126ea9cc0337750f859e24f46adfcb84272bd2cce452 SHA512 eda542c1c363c7c0e6b235e6d8dfbd96d1c1e7cfca408b7215cf247b96c9f42b8bc206bbb4dd48dc41ee373db17d4a76cba940e454840dc41638dd572c580850
+DIST 0ad-0.0.26-alpha-unix-data.tar.xz 1351511480 BLAKE2B 2f483593b79a6ae87d7582625e89c890cfcf4ad7116348b184dae6c47a814d95a7b9f3018cb79e8f024a61c647abd39d6faf5ad3d3fcbb0c7a0583d0479d9b18 SHA512 8fe29fce68737d5b7001c8c2a7198766583b22556129cd2d927823da9b2c58f224fb1207f35bd03abea9380cf24d00ab6257b0dba86ce3ad1f357d7006f051d6
+DIST 0ad-0.0.26-alpha-unix-data.tar.xz.minisig 332 BLAKE2B fb4ec1bcabad79052a5e391557623ad61234d4948ec919d9a79011037855b6c7c94445d8f1667f1725bf80d15d66d1aa32c4e2b259831fbe088fe79e800515b3 SHA512 6dd55dda4e6cd52642b331aa571bc4ccfe30a33ad12a5d3ccf51c708d05dd74bf3234ca722c2a6501ba797bc1f8fa7c7aeb4d836dc4792bfd0c6bbccdc2c1237
+EBUILD 0ad-0.0.26_alpha.ebuild 8015 BLAKE2B 1707cca4755ca2afea2212e557c0e9557710b2685b14f95a190aabdbfa0e3286b7725edfa3d3e6aacc0e067ff9dfa0e1df0b00a013f119dfcf9a7e11b171fec3 SHA512 d9bf0456b4cb41bb8ded12a34c7bf8f46012e9878d30871bfed34f6a6a5abb6d654d8fc908a4caa2c0660c771e7ee8444ea26f63a0e0e09e210460b8dfb185fb
MISC metadata.xml 667 BLAKE2B 3460d1e769fd9bab7f44c1387b9ccb6acb8b6030e5e307311aca479a0857a3719c22352e3b496dff2569536675e449f98aeccc62999283d2ebd3b3feefe444ee SHA512 65134f211aa3509589f9d333c0b2ceb7cb2dcfe394d3eb84323f5cafb43d8ec6d65738a38552d3c955eab5e7fcb5b71da575df5a1e21e0cbd49dcc4b89fc0f39
diff --git a/games-strategy/0ad/files/0ad-0.0.25b_alpha-fix-name-collision-glibc.patch b/games-strategy/0ad/files/0ad-0.0.25b_alpha-fix-name-collision-glibc.patch
deleted file mode 100644
index e8d88e794c90..000000000000
--- a/games-strategy/0ad/files/0ad-0.0.25b_alpha-fix-name-collision-glibc.patch
+++ /dev/null
@@ -1,131 +0,0 @@
-https://bugs.gentoo.org/834578
-https://trac.wildfiregames.com/changeset/26536/
-​https://gcc.gnu.org/bugzilla/show_bug.cgi?id=103735
-​https://sourceware.org/bugzilla/show_bug.cgi?id=28713
---- a/source/tools/atlas/AtlasUI/ScenarioEditor/Sections/Environment/Environment.cpp
-+++ b/source/tools/atlas/AtlasUI/ScenarioEditor/Sections/Environment/Environment.cpp
-@@ -1,3 +1,3 @@
--/* Copyright (C) 2021 Wildfire Games.
-+/* Copyright (C) 2022 Wildfire Games.
- * This file is part of 0 A.D.
- *
-@@ -30,6 +30,4 @@
- static Observable<AtlasMessage::sEnvironmentSettings> g_EnvironmentSettings;
-
--const float M_PIf = 3.14159265f;
--
- //////////////////////////////////////////////////////////////////////////
-
-@@ -86,10 +84,13 @@
- m_Var(var)
- {
-- m_Conn = g_EnvironmentSettings.RegisterObserver(0, &VariableListBox::OnSettingsChange, this);
-+ m_Conn = g_EnvironmentSettings.RegisterObserver(
-+ 0, &VariableListBox::OnSettingsChange, this);
-
- m_Sizer = new wxStaticBoxSizer(wxVERTICAL, this, label);
- SetSizer(m_Sizer);
-
-- m_Combo = new wxComboBox(this, -1, wxEmptyString, wxDefaultPosition, wxDefaultSize, wxArrayString(), wxCB_READONLY),
-+ m_Combo = new wxComboBox(
-+ this, -1, wxEmptyString, wxDefaultPosition, wxDefaultSize,
-+ wxArrayString(), wxCB_READONLY),
- m_Sizer->Add(m_Combo, wxSizerFlags().Expand());
- }
-@@ -207,6 +208,7 @@
- }
-
--EnvironmentSidebar::EnvironmentSidebar(ScenarioEditor& scenarioEditor, wxWindow* sidebarContainer, wxWindow* bottomBarContainer)
--: Sidebar(scenarioEditor, sidebarContainer, bottomBarContainer)
-+EnvironmentSidebar::EnvironmentSidebar(
-+ ScenarioEditor& scenarioEditor, wxWindow* sidebarContainer, wxWindow* bottomBarContainer)
-+ : Sidebar(scenarioEditor, sidebarContainer, bottomBarContainer)
- {
- wxSizer* scrollSizer = new wxBoxSizer(wxVERTICAL);
-@@ -218,13 +220,22 @@
- wxSizer* waterSizer = new wxStaticBoxSizer(wxVERTICAL, scrolledWindow, _T("Water settings"));
- scrollSizer->Add(waterSizer, wxSizerFlags().Expand());
-- waterSizer->Add(new wxButton(scrolledWindow, ID_RecomputeWaterData, _("Reset Water Data")), wxSizerFlags().Expand());
-- waterSizer->Add(m_WaterTypeList = new VariableListBox(scrolledWindow, _("Water Type"), g_EnvironmentSettings.watertype), wxSizerFlags().Expand());
-- waterSizer->Add(new VariableSliderBox(scrolledWindow, _("Water height"), g_EnvironmentSettings.waterheight, 0.f, 1.2f), wxSizerFlags().Expand());
-- waterSizer->Add(new wxButton(scrolledWindow, ID_PickWaterHeight, _("Pick Water Height")), wxSizerFlags().Expand());
-- waterSizer->Add(new VariableSliderBox(scrolledWindow, _("Water waviness"), g_EnvironmentSettings.waterwaviness, 0.f, 10.f), wxSizerFlags().Expand());
-- waterSizer->Add(new VariableSliderBox(scrolledWindow, _("Water murkiness"), g_EnvironmentSettings.watermurkiness, 0.f, 1.f), wxSizerFlags().Expand());
-- waterSizer->Add(new VariableSliderBox(scrolledWindow, _("Wind angle"), g_EnvironmentSettings.windangle, -M_PIf, M_PIf), wxSizerFlags().Expand());
-- waterSizer->Add(new VariableColorBox(scrolledWindow, _("Water color"), g_EnvironmentSettings.watercolor), wxSizerFlags().Expand());
-- waterSizer->Add(new VariableColorBox(scrolledWindow, _("Water tint"), g_EnvironmentSettings.watertint), wxSizerFlags().Expand());
-+ waterSizer->Add(new wxButton(
-+ scrolledWindow, ID_RecomputeWaterData, _("Reset Water Data")), wxSizerFlags().Expand());
-+ waterSizer->Add(m_WaterTypeList = new VariableListBox(
-+ scrolledWindow, _("Water Type"), g_EnvironmentSettings.watertype), wxSizerFlags().Expand());
-+ waterSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Water height"), g_EnvironmentSettings.waterheight, 0.f, 1.2f), wxSizerFlags().Expand());
-+ waterSizer->Add(new wxButton(
-+ scrolledWindow, ID_PickWaterHeight, _("Pick Water Height")), wxSizerFlags().Expand());
-+ waterSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Water waviness"), g_EnvironmentSettings.waterwaviness, 0.f, 10.f), wxSizerFlags().Expand());
-+ waterSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Water murkiness"), g_EnvironmentSettings.watermurkiness, 0.f, 1.f), wxSizerFlags().Expand());
-+ waterSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Wind angle"), g_EnvironmentSettings.windangle, -static_cast<float>(M_PI), static_cast<float>(M_PI)), wxSizerFlags().Expand());
-+ waterSizer->Add(new VariableColorBox(
-+ scrolledWindow, _("Water color"), g_EnvironmentSettings.watercolor), wxSizerFlags().Expand());
-+ waterSizer->Add(new VariableColorBox(
-+ scrolledWindow, _("Water tint"), g_EnvironmentSettings.watertint), wxSizerFlags().Expand());
-
- std::vector<std::wstring> list;
-@@ -236,23 +247,38 @@
- scrollSizer->Add(sunSizer, wxSizerFlags().Expand().Border(wxTOP, 8));
-
-- sunSizer->Add(new VariableSliderBox(scrolledWindow, _("Sun rotation"), g_EnvironmentSettings.sunrotation, -M_PIf, M_PIf), wxSizerFlags().Expand());
-- sunSizer->Add(new VariableSliderBox(scrolledWindow, _("Sun elevation"), g_EnvironmentSettings.sunelevation, -M_PIf/2, M_PIf/2), wxSizerFlags().Expand());
-- sunSizer->Add(new VariableSliderBox(scrolledWindow, _("Sun overbrightness"), g_EnvironmentSettings.sunoverbrightness, 1.0f, 3.0f), wxSizerFlags().Expand());
-- sunSizer->Add(new LightControl(scrolledWindow, wxSize(150, 150), g_EnvironmentSettings));
-- sunSizer->Add(new VariableColorBox(scrolledWindow, _("Sun color"), g_EnvironmentSettings.suncolor), wxSizerFlags().Expand());
-- sunSizer->Add(m_SkyList = new VariableListBox(scrolledWindow, _("Sky set"), g_EnvironmentSettings.skyset), wxSizerFlags().Expand());
-- sunSizer->Add(new VariableSliderBox(scrolledWindow, _("Fog Factor"), g_EnvironmentSettings.fogfactor, 0.0f, 0.01f), wxSizerFlags().Expand());
-- sunSizer->Add(new VariableSliderBox(scrolledWindow, _("Fog Thickness"), g_EnvironmentSettings.fogmax, 0.5f, 0.0f), wxSizerFlags().Expand());
-- sunSizer->Add(new VariableColorBox(scrolledWindow, _("Fog color"), g_EnvironmentSettings.fogcolor), wxSizerFlags().Expand());
-- sunSizer->Add(new VariableColorBox(scrolledWindow, _("Ambient color"), g_EnvironmentSettings.ambientcolor), wxSizerFlags().Expand());
-+ sunSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Sun rotation"), g_EnvironmentSettings.sunrotation, -static_cast<float>(M_PI), static_cast<float>(M_PI)), wxSizerFlags().Expand());
-+ sunSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Sun elevation"), g_EnvironmentSettings.sunelevation, -static_cast<float>(M_PI) / 2.0f, static_cast<float>(M_PI) / 2.0f), wxSizerFlags().Expand());
-+ sunSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Sun overbrightness"), g_EnvironmentSettings.sunoverbrightness, 1.0f, 3.0f), wxSizerFlags().Expand());
-+ sunSizer->Add(new LightControl(
-+ scrolledWindow, wxSize(150, 150), g_EnvironmentSettings));
-+ sunSizer->Add(new VariableColorBox(
-+ scrolledWindow, _("Sun color"), g_EnvironmentSettings.suncolor), wxSizerFlags().Expand());
-+ sunSizer->Add(m_SkyList = new VariableListBox(
-+ scrolledWindow, _("Sky set"), g_EnvironmentSettings.skyset), wxSizerFlags().Expand());
-+ sunSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Fog Factor"), g_EnvironmentSettings.fogfactor, 0.0f, 0.01f), wxSizerFlags().Expand());
-+ sunSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Fog Thickness"), g_EnvironmentSettings.fogmax, 0.5f, 0.0f), wxSizerFlags().Expand());
-+ sunSizer->Add(new VariableColorBox(
-+ scrolledWindow, _("Fog color"), g_EnvironmentSettings.fogcolor), wxSizerFlags().Expand());
-+ sunSizer->Add(new VariableColorBox(
-+ scrolledWindow, _("Ambient color"), g_EnvironmentSettings.ambientcolor), wxSizerFlags().Expand());
-
- wxSizer* postProcSizer = new wxStaticBoxSizer(wxVERTICAL, scrolledWindow, _T("Post-processing settings"));
- scrollSizer->Add(postProcSizer, wxSizerFlags().Expand().Border(wxTOP, 8));
-
-- postProcSizer->Add(m_PostEffectList = new VariableListBox(scrolledWindow, _("Post Effect"), g_EnvironmentSettings.posteffect), wxSizerFlags().Expand());
-- postProcSizer->Add(new VariableSliderBox(scrolledWindow, _("Brightness"), g_EnvironmentSettings.brightness, -0.5f, 0.5f), wxSizerFlags().Expand());
-- postProcSizer->Add(new VariableSliderBox(scrolledWindow, _("Contrast (HDR)"), g_EnvironmentSettings.contrast, 0.5f, 1.5f), wxSizerFlags().Expand());
-- postProcSizer->Add(new VariableSliderBox(scrolledWindow, _("Saturation"), g_EnvironmentSettings.saturation, 0.0f, 2.0f), wxSizerFlags().Expand());
-- postProcSizer->Add(new VariableSliderBox(scrolledWindow, _("Bloom"), g_EnvironmentSettings.bloom, 0.2f, 0.0f), wxSizerFlags().Expand());
-+ postProcSizer->Add(m_PostEffectList = new VariableListBox(
-+ scrolledWindow, _("Post Effect"), g_EnvironmentSettings.posteffect), wxSizerFlags().Expand());
-+ postProcSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Brightness"), g_EnvironmentSettings.brightness, -0.5f, 0.5f), wxSizerFlags().Expand());
-+ postProcSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Contrast (HDR)"), g_EnvironmentSettings.contrast, 0.5f, 1.5f), wxSizerFlags().Expand());
-+ postProcSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Saturation"), g_EnvironmentSettings.saturation, 0.0f, 2.0f), wxSizerFlags().Expand());
-+ postProcSizer->Add(new VariableSliderBox(
-+ scrolledWindow, _("Bloom"), g_EnvironmentSettings.bloom, 0.2f, 0.0f), wxSizerFlags().Expand());
-
- m_Conn = g_EnvironmentSettings.RegisterObserver(0, &SendToGame);
-
diff --git a/games-strategy/0ad/files/0ad-0.0.25b_alpha-python3.10.patch b/games-strategy/0ad/files/0ad-0.0.25b_alpha-python3.10.patch
deleted file mode 100644
index 80991e3c7a6e..000000000000
--- a/games-strategy/0ad/files/0ad-0.0.25b_alpha-python3.10.patch
+++ /dev/null
@@ -1,156 +0,0 @@
-https://github.com/0ad/0ad/commit/c2ec217eea6952c4877095969e11900b70c7cda3
-https://bugs.gentoo.org/845987
-
-From: s0600204 <s0600204@3db68df2-c116-0410-a063-a993310a9797>
-Date: Wed, 23 Feb 2022 20:30:38 +0000
-Subject: [PATCH] Fix building spidermonkey on systems with python 3.10
-
-Tested by:
-* Langbart - macOS 10.15.7: `homebrew`ed python 3.9.9 & 3.10.1
-* andy5995 - Manjaro 21.2.3: python 3.10.2
-* s0600204 - ArchLinux: python 3.10.2
-
-Differential Revision: https://code.wildfiregames.com/D4437
-
-
-
-git-svn-id: https://svn.wildfiregames.com/public/ps/trunk@26475 3db68df2-c116-0410-a063-a993310a9797
---- /dev/null
-+++ b/libraries/source/spidermonkey/FixPythonCollectionABC.diff
-@@ -0,0 +1,87 @@
-+--- a/python/mach/mach/config.py
-++++ b/python/mach/mach/config.py
-+@@ -144,7 +144,7 @@
-+ return _
-+
-+
-+-class ConfigSettings(collections.Mapping):
-++class ConfigSettings(collections.abc.Mapping):
-+ """Interface for configuration settings.
-+
-+ This is the main interface to the configuration.
-+@@ -190,7 +190,7 @@
-+ will result in exceptions being raised.
-+ """
-+
-+- class ConfigSection(collections.MutableMapping, object):
-++ class ConfigSection(collections.abc.MutableMapping, object):
-+ """Represents an individual config section."""
-+ def __init__(self, config, name, settings):
-+ object.__setattr__(self, '_config', config)
-+--- a/python/mach/mach/decorators.py
-++++ b/python/mach/mach/decorators.py
-+@@ -159,7 +159,7 @@
-+ 'Conditions argument must take a list ' + \
-+ 'of functions. Found %s instead.'
-+
-+- if not isinstance(command.conditions, collections.Iterable):
-++ if not isinstance(command.conditions, collections.abc.Iterable):
-+ msg = msg % (command.name, type(command.conditions))
-+ raise MachError(msg)
-+
-+--- a/python/mach/mach/main.py
-++++ b/python/mach/mach/main.py
-+@@ -16,7 +16,7 @@
-+ import sys
-+ import traceback
-+ import uuid
-+-from collections import Iterable
-++from collections.abc import Iterable
-+
-+ from six import string_types
-+
-+--- a/python/mozbuild/mozbuild/backend/configenvironment.py
-++++ b/python/mozbuild/mozbuild/backend/configenvironment.py
-+@@ -9,7 +9,8 @@
-+ import sys
-+ import json
-+
-+-from collections import Iterable, OrderedDict
-++from collections import OrderedDict
-++from collections.abc import Iterable
-+ from types import ModuleType
-+
-+ import mozpack.path as mozpath
-+--- a/python/mozbuild/mozbuild/makeutil.py
-++++ b/python/mozbuild/mozbuild/makeutil.py
-+@@ -7,7 +7,7 @@
-+ import os
-+ import re
-+ import six
-+-from collections import Iterable
-++from collections.abc import Iterable
-+
-+
-+ class Makefile(object):
-+--- a/python/mozbuild/mozbuild/util.py
-++++ b/python/mozbuild/mozbuild/util.py
-+@@ -782,7 +782,7 @@
-+ self._strings = StrictOrderingOnAppendList()
-+ self._children = {}
-+
-+- class StringListAdaptor(collections.Sequence):
-++ class StringListAdaptor(collections.abc.Sequence):
-+ def __init__(self, hsl):
-+ self._hsl = hsl
-+
-+--- a/testing/mozbase/manifestparser/manifestparser/filters.py
-++++ b/testing/mozbase/manifestparser/manifestparser/filters.py
-+@@ -15,1 +15,2 @@
-+-from collections import defaultdict, MutableSequence
-++from collections import defaultdict
-++from collections.abc import MutableSequence
-+--- a/third_party/python/pipenv/pipenv/vendor/jinja2/sandbox.py
-++++ b/third_party/python/pipenv/pipenv/vendor/jinja2/sandbox.py
-+@@ -82,1 +82,1 @@
-+-from collections import MutableSet, MutableMapping, MutableSequence
-++from collections.abc import MutableSet, MutableMapping, MutableSequence
---- /dev/null
-+++ b/libraries/source/spidermonkey/FixVirtualenvForPython310.diff
-@@ -0,0 +1,15 @@
-+--- a/third_party/python/virtualenv/virtualenv.py
-++++ b/third_party/python/virtualenv/virtualenv.py
-+@@ -1804,7 +1804,11 @@
-+ pass
-+ else:
-+ # noinspection PyProtectedMember
-+- if sysconfig._get_default_scheme() == "posix_local":
-++ try: # Python >= 3.10
-++ default_scheme = sysconfig.get_default_scheme()
-++ except: # Python < 3.10
-++ default_scheme = sysconfig._get_default_scheme()
-++ if default_scheme == "posix_local":
-+ local_path = os.path.join(home_dir, "local")
-+ if not os.path.exists(local_path):
-+ os.mkdir(local_path)
---- a/libraries/source/spidermonkey/patch.sh
-+++ b/libraries/source/spidermonkey/patch.sh
-@@ -52,6 +60,11 @@ patch -p1 < ../FixMSVCRootedVoid.diff
- # so this patches it to an arbitrarily high Mac OS 11
- patch -p1 < ../FixMacBuild.diff
-
-+# In python 3.3, the Collections' Abstract Base Classes were moved from `collections` to
-+# `collections.abc`, and aliases were set up for backwards compatibility.
-+# In python 3.10, these aliases were removed, requiring all code that used them to update.
-+patch -p1 < ../FixPythonCollectionABC.diff
-+
- # Fix FP access breaking compilation on RPI3+
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1526653
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1536491
-
-diff --git a/libraries/source/spidermonkey/patch.sh b/libraries/source/spidermonkey/patch.sh
-index 2a3e165..5dde46f 100644
---- a/libraries/source/spidermonkey/patch.sh
-+++ b/libraries/source/spidermonkey/patch.sh
-@@ -2,6 +2,11 @@
- # Apply patches if needed
- # This script gets called from build.sh.
-
-+# In python 3.10 `sysconfig._get_default_scheme()` was renamed to
-+# `sysconfig.get_default_scheme()`. This breaks the version of
-+# `virtualenv` bundled with the spidermonkey source code.
-+patch -p1 < ../FixVirtualenvForPython310.diff
-+
- # Mozglue symbols need to be linked against static builds.
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1588340
- patch -p1 < ../FixMozglue.diff