summaryrefslogtreecommitdiff
path: root/games-sports/foobillard/foobillard-3.0a-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-sports/foobillard/foobillard-3.0a-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-sports/foobillard/foobillard-3.0a-r1.ebuild')
-rw-r--r--games-sports/foobillard/foobillard-3.0a-r1.ebuild26
1 files changed, 16 insertions, 10 deletions
diff --git a/games-sports/foobillard/foobillard-3.0a-r1.ebuild b/games-sports/foobillard/foobillard-3.0a-r1.ebuild
index 1e0053bfc696..365d327eec0c 100644
--- a/games-sports/foobillard/foobillard-3.0a-r1.ebuild
+++ b/games-sports/foobillard/foobillard-3.0a-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit autotools desktop flag-o-matic toolchain-funcs
DESCRIPTION="8ball, 9ball, snooker and carambol game"
@@ -22,20 +23,25 @@ RDEPEND="x11-libs/libXaw
sdl? ( media-libs/libsdl[video] )
!sdl? ( media-libs/freeglut )
"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-no_nvidia.patch
+ "${FILESDIR}"/${P}-freetype_pkgconfig.patch
+ "${FILESDIR}"/${P}-fbsd.patch
+ "${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${P}-gl-clamp.patch
+)
src_prepare() {
default
- eapply \
- "${FILESDIR}"/${P}-no_nvidia.patch \
- "${FILESDIR}"/${P}-freetype_pkgconfig.patch \
- "${FILESDIR}"/${P}-fbsd.patch \
- "${FILESDIR}"/${P}-as-needed.patch \
- "${FILESDIR}"/${P}-gl-clamp.patch
+
mv configure.{in,ac} || die
rm aclocal.m4
+ tc-export PKG_CONFIG
+
eautoreconf
}