summaryrefslogtreecommitdiff
path: root/games-simulation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-10 18:45:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-10 18:45:26 +0000
commitf50d60b8eb707b56133e594376e993b98e726b5d (patch)
treebe9f0c658e4e0ace79af92f89becddd06c01c772 /games-simulation
parent84e395ce722d1f39cf3ef1467b23eda9c2462017 (diff)
gentoo auto-resync : 10:03:2024 - 18:45:26
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/Manifest.gzbin3932 -> 3934 bytes
-rw-r--r--games-simulation/micropolis/Manifest3
-rw-r--r--games-simulation/micropolis/files/micropolis-fix-clang15.diff104
-rw-r--r--games-simulation/micropolis/micropolis-1.0_p20220604.ebuild57
-rw-r--r--games-simulation/openrct2/Manifest2
-rw-r--r--games-simulation/openrct2/openrct2-0.4.8.ebuild2
6 files changed, 166 insertions, 2 deletions
diff --git a/games-simulation/Manifest.gz b/games-simulation/Manifest.gz
index aed76107d201..e519cba57c7e 100644
--- a/games-simulation/Manifest.gz
+++ b/games-simulation/Manifest.gz
Binary files differ
diff --git a/games-simulation/micropolis/Manifest b/games-simulation/micropolis/Manifest
index 6046baec5925..f3a4acdbefd3 100644
--- a/games-simulation/micropolis/Manifest
+++ b/games-simulation/micropolis/Manifest
@@ -1,3 +1,6 @@
+AUX micropolis-fix-clang15.diff 3446 BLAKE2B a1688913bccd3afe038c2829ff1f9a7a433bb9570445b8ddfc42b5f019e526590adf4b73e79bacb72fc3c863bdfa888e701f2b2b9773c27aca374c196aa295f8 SHA512 83051852327ab8d119c36e51dc1e099948ab83f6d5be51d0580360cb5eabd966177f44697453cf8bdb86e8a22ccb1a696f6aec6f49310f41c3d0a03004e2b4fc
+DIST micropolis-6f873e16d6a1a8f6f59c1e5a75ec5f52ce5c89b6.tar.bz2 6725237 BLAKE2B 0ab99ecc3e418f6df3e35aacfd99c1077aeab877ab446d788b42c8ebc95a704e37ba3cdf8fa2d1a54ad182da08f18a15dfc6baeacdf5a6216054fe6b5a162b37 SHA512 ae399d530b9ddbf5da76d6b6b2bec9b9156e0941e7106cc5b393f4758891fdce4b6b5e25fbf0ecddc4d02f346a4b03bfe9bf91e60bea7d667c1005df9f53b5db
DIST micropolis-cc31822e4ebe54c0109623ac0c5cdf0e3acad755.tar.bz2 6725746 BLAKE2B a916389a1ccf63e1a13b5b6ea533939fdb14d814480c9e528c8b1bb89cbefbbad9ad067821c1de199f337692e226d35b3219354dc32612486d013cc20f21c5bc SHA512 1b5f644f6d7d7cb78965d0e0edcfcc0bdab7a103dd5dc3ce97a0048da9fa29d8757063d6681febab3d03182433cfe8a7bf1b8145a21e067a4c754af3b5af8e00
EBUILD micropolis-1.0_p20180313.ebuild 1172 BLAKE2B 51b95de32d5726bfbcda804edb4dddaae33a9b9df3fc11246b2afb1f0a958f0c1daf5a73e22eca95a5fa30f704869085661cb36d6670bb71622e20053777e24d SHA512 c71ab28cfb9bafac42ac2857e5ca01e1a4064d0fe56fd1b1ffafd02b561f63904cfc6c767042c688451532dcd755e47f4b62e3886f5ac25ba30159ff511aee14
+EBUILD micropolis-1.0_p20220604.ebuild 1362 BLAKE2B 2a40c66437af1b59793dd308e56f5882f00b4a012c9bd095e17388002f8faf510349bd92b0971dffb7115e4a08ade3fe73841bf369f3c9120931a34873b4376c SHA512 70cfbeb57cd9f15ef525358d18570bb817de68a5b5a7dea0fb29ee3107e59a8c1d9e614845c395b4e637b95d5b6e760bd9525dcecc0ea9de8106d3bc863fa70d
MISC metadata.xml 413 BLAKE2B 8286aa718a875b3c2ab654127de9b467cc4732abf8289f28fc85bf9b1da363e92cf70a4254cbe8e78fb64c2f484689180bdc7d727bdb2d3a667ca0e6a37e69a5 SHA512 3f28dd2d429278c1d98bd20e739383caa9cd015f09b2678bd7ca3ba53bc76e6c1a39758461513ee5d5ae186cc190473c5a5c96391f95cea17ede472087c5e5a7
diff --git a/games-simulation/micropolis/files/micropolis-fix-clang15.diff b/games-simulation/micropolis/files/micropolis-fix-clang15.diff
new file mode 100644
index 000000000000..20454a844162
--- /dev/null
+++ b/games-simulation/micropolis/files/micropolis-fix-clang15.diff
@@ -0,0 +1,104 @@
+diff --git a/src/tclx/src/tclxgdat.y b/src/tclx/src/tclxgdat.y
+index aea9f3d49ced8818421c6aca538df0f1a08b17b3..2439a2fc8cfd4a90be7f51216ed4bae1b9feb7e2 100644
+--- a/src/tclx/src/tclxgdat.y
++++ b/src/tclx/src/tclxgdat.y
+@@ -46,11 +46,11 @@
+ #if 0
+ static time_t timeconv(int hh, int mm, int ss, int mer);
+ static time_t daylcorr(time_t future, time_t now);
+- static lookup(char *id);
++ static int lookup(char *id);
+ #else
+ static time_t timeconv();
+ static time_t daylcorr();
+- static lookup();
++ static int lookup();
+ #endif
+
+ #define AM 1
+@@ -463,7 +463,7 @@ struct table milzone[] = {
+ {0, 0, 0}};
+
+ static
+-lookup(id) char *id;
++int lookup(id) char *id;
+ {
+ #define gotit (yylval=i->value, i->type)
+ #define getid for(j=idvar, k=id; *j++ = *k++; )
+diff --git a/src/tclx/src/tclxmath.c b/src/tclx/src/tclxmath.c
+index 9f967bf4f2402c7f61f0f2b8f03ef835c7ceb70d..bf5a52a76f3eca59260299096436aebaf8ba2818 100644
+--- a/src/tclx/src/tclxmath.c
++++ b/src/tclx/src/tclxmath.c
+@@ -16,6 +16,7 @@
+ *-----------------------------------------------------------------------------
+ */
+
++#include <time.h>
+ #include "tclxint.h"
+
+ extern int rand();
+diff --git a/src/tk/tkbitmap.c b/src/tk/tkbitmap.c
+index cc81cd02c477b6289a25b76909b3b46f8db212a6..c7693e84a71953b340ee3b37044ec65be6050dc7 100644
+--- a/src/tk/tkbitmap.c
++++ b/src/tk/tkbitmap.c
+@@ -434,7 +434,7 @@ Tk_GetBitmapFromData(interp, tkwin, source, width, height)
+ Tk_Uid name = NULL; /* Initialization need only to prevent
+ * compiler warning. */
+ int new;
+- static autoNumber = 0;
++ static int autoNumber = 0;
+ char string[20];
+
+ if (!initialized) {
+diff --git a/src/tk/tkerror.c b/src/tk/tkerror.c
+index a58814c4599d4a8111cdf03cf67054009c7a626f..b6fdb17c41853f9fb5dbd33274d314d5ca8a723f 100644
+--- a/src/tk/tkerror.c
++++ b/src/tk/tkerror.c
+@@ -23,7 +23,7 @@ static char rcsid[] = "$Header: /user6/ouster/wish/RCS/tkError.c,v 1.10 92/04/12
+ #include "tkconfig.h"
+ #include "tkint.h"
+
+-static initialized = 0;
++static int initialized = 0;
+
+ /*
+ * Forward references to procedures declared later in this file:
+diff --git a/src/tk/tkpack.c b/src/tk/tkpack.c
+index f065bd5d20d6cfa81c4ce37104a9764a99816287..a998017fcfd308595aed170ad3915817a85ec9f7 100644
+--- a/src/tk/tkpack.c
++++ b/src/tk/tkpack.c
+@@ -95,7 +95,7 @@ static Tcl_HashTable packerHashTable;
+ * Have statics in this module been initialized?
+ */
+
+-static initialized = 0;
++static int initialized = 0;
+
+ /*
+ * Forward declarations for procedures defined later in this file:
+diff --git a/src/tk/tkpixmap.c b/src/tk/tkpixmap.c
+index 753bbe190caa3e585b82a0757e77184f1ec68b20..8d23daded56264edd6d3dbc333014f253568592a 100644
+--- a/src/tk/tkpixmap.c
++++ b/src/tk/tkpixmap.c
+@@ -516,7 +516,7 @@ Tk_GetPixmapFromData(interp, tkwin, source, width, height)
+ Tk_Uid name = NULL; /* Initialization need only to prevent
+ * compiler warning. */
+ int new;
+- static autoNumber = 0;
++ static int autoNumber = 0;
+ char string[20];
+
+ if (!initialized) {
+diff --git a/src/tk/tkwindow.c b/src/tk/tkwindow.c
+index 05029aa38b11e2e189010736c69c74113616d581..eb6b7fe22bc66cebfae99a0fe663a9089a7c5b2a 100644
+--- a/src/tk/tkwindow.c
++++ b/src/tk/tkwindow.c
+@@ -55,7 +55,7 @@ TkDisplay *tkDisplayList = NULL;
+ * Have statics in this module been initialized?
+ */
+
+-static initialized = 0;
++static int initialized = 0;
+
+ /*
+ * Context information used to map from X window id's to
diff --git a/games-simulation/micropolis/micropolis-1.0_p20220604.ebuild b/games-simulation/micropolis/micropolis-1.0_p20220604.ebuild
new file mode 100644
index 000000000000..bee00da41495
--- /dev/null
+++ b/games-simulation/micropolis/micropolis-1.0_p20220604.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop toolchain-funcs wrapper
+
+COMMIT="6f873e16d6a1a8f6f59c1e5a75ec5f52ce5c89b6"
+DESCRIPTION="Free version of the well-known city building simulation"
+HOMEPAGE="https://www.donhopkins.com/home/micropolis/"
+SRC_URI="https://gitlab.com/stargo/micropolis/-/archive/${COMMIT}/micropolis-${COMMIT}.tar.bz2"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ x11-libs/libX11
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}"
+BDEPEND="app-alternatives/yacc"
+
+# parallel build is broken
+MAKEOPTS="-j1"
+
+# clang fixes, submitted upstream:
+# https://gitlab.com/stargo/micropolis/-/merge_requests/1
+PATCHES=( "${FILESDIR}/micropolis-fix-clang15.diff" )
+
+src_prepare() {
+ default
+
+ sed -i -e "s|-O3|${CFLAGS}|" \
+ src/tclx/config.mk src/{sim,tcl,tk}/makefile || die
+ sed -i -e "s|XLDFLAGS=|&${LDFLAGS}|" \
+ src/tclx/config.mk || die
+}
+
+src_compile() {
+ emake -C src LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ local dir=/usr/share/${PN}
+
+ exeinto "${dir}/res"
+ doexe src/sim/sim
+ insinto "${dir}"
+ doins -r activity cities images manual res
+
+ make_wrapper micropolis res/sim "${dir}"
+ doicon Micropolis.png
+ make_desktop_entry micropolis "Micropolis" Micropolis
+}
diff --git a/games-simulation/openrct2/Manifest b/games-simulation/openrct2/Manifest
index 798844a796f4..be7123de3628 100644
--- a/games-simulation/openrct2/Manifest
+++ b/games-simulation/openrct2/Manifest
@@ -16,7 +16,7 @@ DIST openrct2-replays-0.0.78.zip 1829988 BLAKE2B cf11a05f6ba5a2808cd4c016ac3c753
DIST openrct2-replays-0.0.79.zip 1934633 BLAKE2B 4b5c4d96be91055ceff8f5f5f1a894cc2544659983e61ac2f42d655229357b6a368553c1ee45d147cb360c8d54bb0ca78b61a9716efa8d1d7f37cd7c5ba50fa7 SHA512 04acde4d60c8fa949b298dd15e38fe0421659357fa214dffb0577574e0b0ac218a01ce998f4e12e3ab13a88fbbba8096392462fda29c68a6215bc0875aaae9b2
DIST openrct2-title-sequences-0.4.6.zip 2547725 BLAKE2B 5f7b36cd1372106923000775307ea7ff8c142c3b1d026d84b86f255a629b0a2ac16a682300999789229a8833d4c7327c858c04710ecddfb97af1858ff121a5c4 SHA512 bd7d0f25047540572be75a4a8886e8dabdceb7a3e11fdeb5473b66fe804d829acdb763d34ec7cfa656df9bc527268a3e0e7ca09c699995804b22ff2a529ad5da
EBUILD openrct2-0.4.7.ebuild 4608 BLAKE2B b7d3b73081a63f74b7b67f8f6fd8e3313ca2b3cadd4f0499a708b5364ebb1fc1a036133ae6cfc47007b81f41a8418f3bf9a62983704e5dd4d10cb5efadd50541 SHA512 a63ae01738783096ec03f9ac5fe7b6dfd0d517e6bd4ac566251299e1164741a558fcfe9ae85ef5b548bf13c8e7afc310ef58f64627c3dda5359ccc7398355596
-EBUILD openrct2-0.4.8.ebuild 4574 BLAKE2B 0e5cceff965bf149736310c43e534e5d4410a7b9380918d634333440f1147a391a5d76f67d66e79c63d415a9396fa9680b34a86386127cc521475f6b93d30d61 SHA512 b649127201e511eb057cbb72dbee25bae34bea82a6ae2359ca85281635791db57702a44b5b3ad70409271d35e9d1b7b44d38188cc252d4f40d41d19a1771510a
+EBUILD openrct2-0.4.8.ebuild 4570 BLAKE2B 8702b9cbe8c7b9c3b7f005e285d9aa0fc28f293d8e1195f3327ff6b0f70693fc3849a8be0f7ed6fb13bd9037fc26394d6bca99337c3b4909ea66b44da36656ef SHA512 fe13349e133f3e7a786b853cd409b7acb9755365bc2f0fea873572e2c6e37a5c2c9372a86ed880bb53557dc8d55dd8ab7beeafb60af4235ed1691ecadfafcc74
EBUILD openrct2-0.4.9.ebuild 4573 BLAKE2B e7d0475e49ae9f85f2429d3a27ac5030435f2a0532733eff53e2dd58803fd9659a835800fad36d354d832500985ac7272300afaadf444542f56f90b5832e30bf SHA512 68a37acc8289c4cfd9bc81e503bcbb165fa5d6694c82fe38841cc367c9555472d0b4a8e3f35c80f89ce00b8085a756db7251cdf36e9ab0bf04dfb1e3a498620a
EBUILD openrct2-9999.ebuild 4497 BLAKE2B 80fe565bb0108d6f7ed3fed97382f243a159eb6ea759d9093de1a5a951b5d10aad43918a5617381af889c65403a86b5b3cd3d2652374a157904bf7344150661a SHA512 b56f28dc871e4758b3167c712a7c3c97b7ee64c6aaeb1a676e3f996fd300a4bb2063137c01441f9a39d99a5190570dcf2f7b43b4ba0a71ae5da5895601a2fda5
MISC metadata.xml 1200 BLAKE2B 7a2ca04e6e757efd12cbf00558372a19d10833fbd11d105f14bf68662ea6c64cbac3b01b4f5abba1473c4c184cceeadc26b38ef91e9edc3a40ee94415f868ff6 SHA512 97c181f7f3d97bf8ef90c1666497397c8ad87b23b536d1be6af7133e85e1e331813ee2247b3e0dfe887c0328f0b35184f1e9738ba7a7bb53b80813c23565c61e
diff --git a/games-simulation/openrct2/openrct2-0.4.8.ebuild b/games-simulation/openrct2/openrct2-0.4.8.ebuild
index 6881879d0816..d0e1fc764439 100644
--- a/games-simulation/openrct2/openrct2-0.4.8.ebuild
+++ b/games-simulation/openrct2/openrct2-0.4.8.ebuild
@@ -31,7 +31,7 @@ S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+KEYWORDS="amd64 ~arm arm64 ppc64 x86"
IUSE="dedicated +flac +opengl scripting test +truetype +vorbis"
RESTRICT="!test? ( test )"