summaryrefslogtreecommitdiff
path: root/games-simulation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-16 14:04:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-16 14:04:41 +0000
commitb18dbdc69b2be6f0ac0db668b0bc57fb6f766afc (patch)
treee77939b82c93b9689bc1bb0bc8a55132c509cb44 /games-simulation
parent97f40b36b1afa9726e32962d11f3ac2d0bc5792e (diff)
gentoo auto-resync : 16:02:2023 - 14:04:41
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/EmptyEpsilon/EmptyEpsilon-2022.10.28.ebuild (renamed from games-simulation/EmptyEpsilon/EmptyEpsilon-2021.06.23-r1.ebuild)58
-rw-r--r--games-simulation/EmptyEpsilon/Manifest8
-rw-r--r--games-simulation/EmptyEpsilon/metadata.xml3
-rw-r--r--games-simulation/Manifest.gzbin3937 -> 3935 bytes
4 files changed, 47 insertions, 22 deletions
diff --git a/games-simulation/EmptyEpsilon/EmptyEpsilon-2021.06.23-r1.ebuild b/games-simulation/EmptyEpsilon/EmptyEpsilon-2022.10.28.ebuild
index c1ff6c877b43..d25e36d666ad 100644
--- a/games-simulation/EmptyEpsilon/EmptyEpsilon-2021.06.23-r1.ebuild
+++ b/games-simulation/EmptyEpsilon/EmptyEpsilon-2022.10.28.ebuild
@@ -1,38 +1,49 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit cmake toolchain-funcs
+# basis_universal version
+MY_BU_VER="1_15_update2"
+# meshoptimizer version
+MY_MO_VER="0.16"
+
DESCRIPTION="A spaceship bridge simulator game"
HOMEPAGE="https://daid.github.io/EmptyEpsilon/"
# This bundles SeriousProton as the build system does not support using
# a separate SeriousProton instance (and currently EmptyEpsilon seems to
# be the only consumer).
-SRC_URI="https://github.com/daid/EmptyEpsilon/archive/EE-${PV}.tar.gz -> EmptyEpsilon-${PV}.tar.gz
- https://github.com/daid/SeriousProton/archive/EE-${PV}.tar.gz -> SeriousProton-${PV}.tar.gz"
+SRC_URI="
+ https://github.com/daid/EmptyEpsilon/archive/EE-${PV}.tar.gz -> EmptyEpsilon-${PV}.tar.gz
+ https://github.com/daid/SeriousProton/archive/EE-${PV}.tar.gz -> SeriousProton-${PV}.tar.gz
+ https://github.com/BinomialLLC/basis_universal/archive/refs/tags/v${MY_BU_VER}.tar.gz -> basis_universal_${MY_BU_VER}.tar.gz
+ https://github.com/zeux/meshoptimizer/archive/refs/tags/v${MY_MO_VER}.tar.gz -> meshoptimizer-${MY_MO_VER}.tar.gz
+"
# EmptyEpsilon is mostly licensed under GPL, however the art ressources
# use Creative Commons and the bundled SeriousProton is MIT-licensed.
-LICENSE="GPL-2 CC-BY-SA-3.0 MIT"
+LICENSE="Apache-2.0 GPL-2 CC-BY-SA-3.0 MIT"
SLOT="0"
-KEYWORDS="amd64"
+KEYWORDS="~amd64"
RDEPEND="
- >=dev-cpp/json11-1.0.0
- media-libs/libglvnd
- media-libs/libsfml
+ dev-cpp/nlohmann_json
+ media-libs/freetype
+ media-libs/libsdl2
>=media-libs/glm-0.9.9.8
"
DEPEND="${RDEPEND}"
S="${WORKDIR}/EmptyEpsilon-EE-${PV}"
+PATCHES=(
+ "${FILESDIR}/${PN}-cmake-meshoptimizer.patch"
+)
+
pkg_pretend() {
- if [[ ${MERGE_TYPE} == "binary" ]]; then
- return
- fi
+ [[ ${MERGE_TYPE} == "binary" ]] && return
if tc-is-gcc; then
if [[ $(gcc-major-version) -lt 11 ]]; then
@@ -44,21 +55,32 @@ pkg_pretend() {
}
src_prepare() {
- eapply "${FILESDIR}/${PN}-Install-EmptyEpsilon.desktop.patch"
- eapply "${FILESDIR}/${PN}-Make-CMake-call-find_package-glm.patch"
- eapply --directory="${WORKDIR}/SeriousProton-EE-${PV}" \
- "${FILESDIR}/SeriousProton-Unbundle-json11.patch"
+ cmake_src_prepare
- eapply_user
+ local -A externals=()
+ externals["${BUILD_DIR}/SeriousProton/externals/basis"]="${WORKDIR}/basis_universal-${MY_BU_VER}"
+ externals["${BUILD_DIR}/externals/meshoptimizer"]="${WORKDIR}/meshoptimizer-${MY_MO_VER}"
+ local link
+ for link in "${!externals[@]}"; do
+ local external_dir=$(dirname "${link}")
+ if [[ ! -d "${external_dir}" ]]; then
+ mkdir -p "${external_dir}" || die
+ fi
+ local target="${externals[${link}]}"
+ ln -rs "${target}" "${link}" || die
+ done
- cmake_src_prepare
+ local serious_proton_patches=(
+ "${FILESDIR}/SeriousProton-cmake.patch"
+ )
+ eapply --directory="${WORKDIR}/SeriousProton-EE-${PV}" \
+ "${serious_proton_patches[@]}"
}
src_configure() {
local version=( $(ver_rs 1- ' ') )
local mycmakeargs=(
-DSERIOUS_PROTON_DIR="${WORKDIR}/SeriousProton-EE-${PV}/"
- -DOpenGL_GL_PREFERENCE=GLVND
-DCPACK_PACKAGE_VERSION="${PV}"
-DCPACK_PACKAGE_VERSION_MAJOR="${version[0]}"
-DCPACK_PACKAGE_VERSION_MINOR="${version[1]}"
diff --git a/games-simulation/EmptyEpsilon/Manifest b/games-simulation/EmptyEpsilon/Manifest
index cd6a03fe7027..4332afb6efaf 100644
--- a/games-simulation/EmptyEpsilon/Manifest
+++ b/games-simulation/EmptyEpsilon/Manifest
@@ -4,12 +4,12 @@ AUX EmptyEpsilon-cmake-meshoptimizer.patch 457 BLAKE2B fcef3984e5154ea1819109b89
AUX SeriousProton-Add-missing-include-memory-to-websocket.h.patch 706 BLAKE2B 12129f7eca18439840bbbf53968ec0f950158dd01659bf7923a126b1176678613c704e9b00f7817b281095d5ecf859d29832295ab19b8fc63526882f565aa31f SHA512 3be656fa7c883e91df93085d8b5cc296d4912723b785472c187abff3e51562d5f0b82a2fea6bcd47c58dc00294b9302cfb6a97256456e990f246ba60bad6f725
AUX SeriousProton-Unbundle-json11.patch 722 BLAKE2B ab12cf044d38bc78eac3d4fdd7f3c9db062784177e848ca62135b356fec88be9876fa98f23d1195e3c3a2ef791166cb3c0fe220bce9c53a667b628a2e3602eb4 SHA512 da912f148738a409dd1eee4a8a926930ed31220c9b6477eb8a89da797dd659e2a576ca44875410cbc46c86f7d5b6e44037ed3f44c8d7ecd5a4680f12f626f013
AUX SeriousProton-cmake.patch 450 BLAKE2B 1f1585eda5dcf7980d4439e1485edf4363dba5378c968f387c3b978eee9a9c5d7bdd406dcdc207dbe1e93f1efdf88285995cc3a5a414e1dc4566123e7685388f SHA512 bc09fa1047f1cc33c5d27ffd640d6e06623f83bb49263786bdab25e3fa353fbddef4d15203197ecf58eac696f92f27b47b9eae67a872a49bda2c11579741dbcd
-DIST EmptyEpsilon-2021.06.23.tar.gz 285211647 BLAKE2B 813b7e02ff7f046b7f28139063441eb421861b720c7b55d25930d3a418211fefdce7ac0e6ab705b4afe52df58f85a9298ff3e6be883a841e6eb9f7037eca297b SHA512 209ea68d99ef5ef53f1e3484d6471cafc01d4cb6505609a5b41d468387147127b4b4bbc20af75404d2cdef3d3cfb37bbb7f6fb3ae336d2f7e264e9c470ad7764
DIST EmptyEpsilon-2022.03.16.tar.gz 258014053 BLAKE2B d447518c6887b5969bce48abc042a259733a6845a49ba767b274d17c1b0e28a025443d073563e269365837191439f7963f3a3775c58b143e97cef7b7c0cef336 SHA512 63f351be1af792be0ce8b1171ea14dd9f3ab75825ca9df48f7a7bfbc3cedfe05183f59896a51cd4e1f4e977aa5c9386159716dcc206afd7a1adab1df7c35e062
-DIST SeriousProton-2021.06.23.tar.gz 1181117 BLAKE2B 433280b7f6994bed0b86ffc4135a1e91bd9521c508b875332d17dc041da6b77a4260de784b6b75e79aab072d6bc68108a8b6b4949d674670f1d13ed1abe90d7e SHA512 4519801c30cd87436704023090ce39299573b02637a86b0d5c6ac0f4e99b4bddc6724b2b660edfd29d33a908b67268409a8c47dab7b5d59958a5abd52d5610bf
+DIST EmptyEpsilon-2022.10.28.tar.gz 258148673 BLAKE2B dcc2cdd6f02afef4fee00939145c4c98461ea5403ad45949ffc99758b0575f56504b610249231969f63751d8a2f746913a004d88d7287876a5b448a4b90d8162 SHA512 6af0522cb9f07f0b0cf3ac287ce57b156206b27b4d17de237acf50c46928782c49a4af397c9cad4be30603e0ee04bd6979404e11d0b2c5472cf0c278124df140
DIST SeriousProton-2022.03.16.tar.gz 2671635 BLAKE2B 9fdb58d50e7f3522678efe14b753016c4d2e3341f2e3b78ede00815e4f6a6361eb635016c9cdf0ce235a0bb35fb813b61790a5b0d1522a1e8afe2f3594674341 SHA512 74a06c69a3f49789b35a6e5795a7b1de1b7e79d36c956a92e1383f9983489319060c62f3ee6349e26ac985a5121b4e60cf7a3546ec78b3a830e30c0c99ccd023
+DIST SeriousProton-2022.10.28.tar.gz 2668713 BLAKE2B 9f200881bfa812904cd37428eb2bb2f8e04c46a134e8b3fceb0e02e87fe4bd7e529e1fbaf18cb4e284ec7ee4d1c6e8606f35e7ec3e61efa66816a7b354d446b9 SHA512 7955ed78529c0f69d6fd3ef6fac5537009548cdfe1cf8e47dc1fac8919fc3532e03453869968369f027c40dd4da513cfd84e58ffedaddd4b9d9fe67d28406be7
DIST basis_universal_1_15_update2.tar.gz 13283133 BLAKE2B 5400d23f86dd581da1bc96c1b95eae58f3c97b5412ad1d09d7f4ffd2ae7cae6cb14330795380e253579cc17f1ee16c91555229268219c300905da1420c0d8717 SHA512 a898a057b57ac64f6c0bf5fce0b599e23421ccdd015ea7bb668bce8b9292ef55b098f3d05854a2fb5363959932b75cd0a842664ae7d4f71f3537dc11301c1b32
DIST meshoptimizer-0.16.tar.gz 342571 BLAKE2B 2b4e244ea3676f109c904261d47bd0e7b2ad440f23d65325d34281ed13ac09657116c96b5a56860a0107479773b58c21018c8825b314f87a05bce38341fd75c1 SHA512 cc6d28359fb99a615e1046a4af1b247cbc6ea0266d9e7f41ea0516c1fc09fa1e67376071daf138a126c77bca3baf9d565636ed0e3adf045f1a08498c38b7a7e7
-EBUILD EmptyEpsilon-2021.06.23-r1.ebuild 2018 BLAKE2B 61ada37ae1aa034376f7cc1a1c602563a52174662e27ba30299460d781e3a47c1e744efad668125731708ab2cb0b4ba2da44b3de2c7ec62193acb93c51993e1c SHA512 59af1a09e6b7fec6c089cee6e3d01d57c5fbfd71d78aa1e78101052b7fa6deaf272f2e5c6786fcc5ad0c602e54577de346ab357ec7791ce1c3824911000b6124
EBUILD EmptyEpsilon-2022.03.16.ebuild 2844 BLAKE2B 475c559eb8741d6aafaf315dd837ca71d3cd82990c149a018cb2107390aa5542b899dc8fc1a6a10844dc281ac53d6aae99e0856889963b9d4fe8f510553dae32 SHA512 038c54763a17e43c7ff334fe5de2e748609064729f0cb66dbc53d1cd95cf8c7906d32c5f7eff80c3f2aeffebdccd10a998d4fabf1d2b209854bc9ae1015b1aa5
-MISC metadata.xml 247 BLAKE2B f18c471812d5b8c75f2e05c4fb556108fb93554b59ee61a8215803f2654854a7401fcd62964192c228bfebfb52ae4573cfd24b29a944630c8c733d154d2b0d9a SHA512 cea16f7db3110bd4629b9265d5acdec6d70877330664f8e83f726002eb69aec7f822e9cde9c7da900451cdef60f1ceba373dfe73c73f82173bbf1d2f9f7338b7
+EBUILD EmptyEpsilon-2022.10.28.ebuild 2766 BLAKE2B 2616a6fcc4c145a7df47b82c6b6d70037c202aee3f1d719c3de28769313bdb7c33156b8dcfff8041fa8f2785e75b1fd6ce7363cc084c0eaeb73fd76cb07363bf SHA512 044114fb5aecd83bfef501ef667c127e0c52174c6b0b9ac2d88a6ed000942556fce0f08b7aa8946e6566a075171be7750247c71b502c940cf8188b1bc197b4f4
+MISC metadata.xml 329 BLAKE2B 8473231ca386ac0a49c270619d7dbe528f578e6dafda3aff92309e947fdae58e6a09b8895e9f051dcf4f70854351756188463e2a987b03939eb41d3cc9346893 SHA512 75c1304961cb113e7957b9f40e091f343af41f7ab74ce59ad20840a883179e8123cc571f6cf45f77ca15bebadecee5e0ed945dc7eae614770b1f943fc195e7b2
diff --git a/games-simulation/EmptyEpsilon/metadata.xml b/games-simulation/EmptyEpsilon/metadata.xml
index a7fa285c7476..c700facfe383 100644
--- a/games-simulation/EmptyEpsilon/metadata.xml
+++ b/games-simulation/EmptyEpsilon/metadata.xml
@@ -5,4 +5,7 @@
<name>Florian Schmaus</name>
<email>flow@gentoo.org</email>
</maintainer>
+ <upstream>
+ <remote-id type="github">daid/EmptyEpsilon</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/games-simulation/Manifest.gz b/games-simulation/Manifest.gz
index e3baea169efa..7f4fe4fdc494 100644
--- a/games-simulation/Manifest.gz
+++ b/games-simulation/Manifest.gz
Binary files differ