summaryrefslogtreecommitdiff
path: root/games-simulation/slime-rancher
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /games-simulation/slime-rancher
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'games-simulation/slime-rancher')
-rw-r--r--games-simulation/slime-rancher/Manifest3
-rw-r--r--games-simulation/slime-rancher/metadata.xml8
-rw-r--r--games-simulation/slime-rancher/slime-rancher-1.4.1c_p34605.ebuild59
3 files changed, 70 insertions, 0 deletions
diff --git a/games-simulation/slime-rancher/Manifest b/games-simulation/slime-rancher/Manifest
new file mode 100644
index 000000000000..ffc743a2034f
--- /dev/null
+++ b/games-simulation/slime-rancher/Manifest
@@ -0,0 +1,3 @@
+DIST slime_rancher_1_4_1c_34605.sh 637631767 BLAKE2B e3742178acfb9b80429117a37e8c7ec226345fb20b762ef80ca7ff7d58bcde039a199db5f352e78ce6935b6b261924780f54c84dd706a8031b427c9bd52de2a7 SHA512 c9124a7685c12dab942cde3e4b7e4140156c9d1551043d450c0c2f2eb02d1db61b99f22803b1058634abff86e783c889badf5834f0c2f7048a97dc168c962908
+EBUILD slime-rancher-1.4.1c_p34605.ebuild 1193 BLAKE2B da4062b3f19a369ed4ff092bc5b70af12ba05810734f7a76d4d1d7d699f272317ce212ca000fec0d9666a2f91c9109b1cb02561fb771a1c1b6f903bd81660c57 SHA512 a257db39f7fd3442d995a4730bad04124a95accf40fda7aa5ab0c6075a438805a5f843275a12aa2000811d108bef9cfa655b2a705d07d0495e3381a50507613a
+MISC metadata.xml 253 BLAKE2B 443ca9c8d4f6801169382e87a0ecd1385c56e65229209e7200f9d313ef380e92ae8d7dc3c38e5989a4166289f22607a20b1e13bb960fff6b3d9f78629d8ab020 SHA512 61c4689cbc649d84a00be211b7b5b98dd03e1d3f813eff370df549f2998cd4343f391c18b57cf20e4a8f4dd2311e3bfa04eb60f356f2bbac78f0b68f5091f254
diff --git a/games-simulation/slime-rancher/metadata.xml b/games-simulation/slime-rancher/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-simulation/slime-rancher/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-simulation/slime-rancher/slime-rancher-1.4.1c_p34605.ebuild b/games-simulation/slime-rancher/slime-rancher-1.4.1c_p34605.ebuild
new file mode 100644
index 000000000000..f69d7ad44247
--- /dev/null
+++ b/games-simulation/slime-rancher/slime-rancher-1.4.1c_p34605.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils desktop unpacker xdg
+
+MY_PN="SlimeRancher"
+MY_P="${P//[-.]/_}"
+MY_P="${MY_P//_p/_}"
+
+DESCRIPTION="Cute game where you cultivate slimes on a distant planet"
+HOMEPAGE="http://www.slimerancher.com/"
+SRC_URI="${MY_P}.sh"
+LICENSE="GOG-EULA"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="bindist fetch splitdebug"
+
+RDEPEND="
+ sys-libs/glibc
+ virtual/opengl
+"
+
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}/data/noarch/game"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " https://www.gog.com/game/${PN//-/_}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_prepare() {
+ default
+
+ # Some Unity games have a GUI launcher but this one doesn't use it.
+ rm ${MY_PN}_Data/Plugins/x86_64/ScreenSelector.so || die
+}
+
+src_install() {
+ exeinto "${DIR}"
+ newexe ${MY_PN}.x86_64 ${MY_PN}
+ make_wrapper ${PN} "${DIR}"/${MY_PN}
+
+ insinto "${DIR}"
+ doins -r ${MY_PN}_Data/
+
+ newicon -s 128 ${MY_PN}_Data/Resources/UnityPlayer.png ${PN}.png
+ make_desktop_entry ${PN} "Slime Rancher"
+}