summaryrefslogtreecommitdiff
path: root/games-simulation/openrct2/openrct2-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /games-simulation/openrct2/openrct2-9999.ebuild
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'games-simulation/openrct2/openrct2-9999.ebuild')
-rw-r--r--games-simulation/openrct2/openrct2-9999.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/games-simulation/openrct2/openrct2-9999.ebuild b/games-simulation/openrct2/openrct2-9999.ebuild
index 1058facd68fd..d9c56e6aeb0f 100644
--- a/games-simulation/openrct2/openrct2-9999.ebuild
+++ b/games-simulation/openrct2/openrct2-9999.ebuild
@@ -14,15 +14,18 @@ if [[ ${PV} == 9999 ]]; then
SRC_URI=""
else
KEYWORDS="~amd64 ~x86"
- SRC_URI="https://github.com/OpenRCT2/OpenRCT2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/OpenRCT2/OpenRCT2/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
S="${WORKDIR}/OpenRCT2-${PV}"
fi
TSV="0.1.2"
-SRC_URI+=" https://github.com/OpenRCT2/title-sequences/releases/download/v${TSV}/title-sequence-v${TSV}.zip -> ${PN}-title-sequence-v${TSV}.zip "
-
-OBJV="1.0"
-SRC_URI+=" https://github.com/OpenRCT2/objects/releases/download/v${OBJV}/objects.zip -> ${PN}-objects-v${OBJV}.zip"
+OBJV="1.0.3"
+SRC_URI+="
+ https://github.com/OpenRCT2/title-sequences/releases/download/v${TSV}/title-sequence-v${TSV}.zip
+ -> ${PN}-title-sequence-v${TSV}.zip
+ https://github.com/OpenRCT2/objects/releases/download/v${OBJV}/objects.zip
+ -> ${PN}-objects-v${OBJV}.zip"
LICENSE="GPL-3"
SLOT="0"
@@ -83,9 +86,9 @@ src_configure() {
-DWITH_TESTS="$(usex test)"
-DDOWNLOAD_TITLE_SEQUENCES=OFF
-DDOWNLOAD_OBJECTS=OFF
- -DSYSTEM_GTEST=ON
-DBUILD_SHARED_LIBS=ON
)
+ use test && mycmakeargs+=( -DSYSTEM_GTEST=ON )
cmake-utils_src_configure
}