summaryrefslogtreecommitdiff
path: root/games-simulation/bcs-demo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-simulation/bcs-demo
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-simulation/bcs-demo')
-rw-r--r--games-simulation/bcs-demo/Manifest4
-rw-r--r--games-simulation/bcs-demo/bcs-demo-1.3-r1.ebuild57
-rw-r--r--games-simulation/bcs-demo/metadata.xml29
3 files changed, 90 insertions, 0 deletions
diff --git a/games-simulation/bcs-demo/Manifest b/games-simulation/bcs-demo/Manifest
new file mode 100644
index 000000000000..dbf41fd88123
--- /dev/null
+++ b/games-simulation/bcs-demo/Manifest
@@ -0,0 +1,4 @@
+DIST bcsdemo_v1_3.sh.bin 5965217 BLAKE2B ba69858933c5ff1fbd966cc5038ecf891abea70cb6a7f09e40e698da495a7f3578460f90e033c1455918f7d188e37839ae0f140be8c419911d520e4cef13cd48 SHA512 b3916ac72d21e80a09b80a406ea18ab4365d9c1b8139eec848f2e5d697d3d5afb6f27de5dac31c6b6fd860e3b406a3eae8a28aac0e00134629dbd5906bde816d
+DIST openal-alan-hack-0.0.1.tar.gz 86168 BLAKE2B 77ab97ef9b31b4c3ab00c89afaad7094b6ecc388e296b31969bfbbe3953b812036c1cb4a04a09ad0ca986941d2508469c40f5ab7d458c1ceb5fa78b1f9ca7c81 SHA512 1794461cb917dcf2130977bd0ac9f09bf93cd235dd742d29e50a3e2666e6db60865bacd1927fc4607a4b308dcdf421fa2a186ad2a06eea778069ce712a89d943
+EBUILD bcs-demo-1.3-r1.ebuild 1380 BLAKE2B 7d91114725777944c45b43c6051b27473a7000a708bb8a84ab67d87c9cb7b0c7c8fdf4d7d1a22e5a13d5b716f899d8675372147bc197c99ced40f0c9dd902941 SHA512 a0073df4c848a2c33827072348d1ad2c7de3fdaf5a2b9f3270dae3eadd8fdf2a9ff832b7e32b3ff53a834af4ecf3dcda35250100543834fa81918dbbf3048b5d
+MISC metadata.xml 1473 BLAKE2B 98ce5cff21aaefe1ebe09f390be6e01780902ef652e3f0ddee815b0018652678719c061ef7a88dae81824170f2bdc7fa8b7b024227a2c71f03f04f783d831504 SHA512 2813c65cdae4aa2f8e0d0cb15e3b45af6d842e2ad02bc45783d3eb9fc8acbbd8467241ce7af2fa420bedc39b7c449b398f339cdc868fb6e45e0b5cec68b538c2
diff --git a/games-simulation/bcs-demo/bcs-demo-1.3-r1.ebuild b/games-simulation/bcs-demo/bcs-demo-1.3-r1.ebuild
new file mode 100644
index 000000000000..106a657357f5
--- /dev/null
+++ b/games-simulation/bcs-demo/bcs-demo-1.3-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils unpacker
+
+DESCRIPTION="design and build bridges and then stress test them with trains"
+HOMEPAGE="http://www.chroniclogic.com/pontifex2.htm"
+SRC_URI="ftp://ggdev-1.homelan.com/bcs/bcsdemo_v${PV/./_}.sh.bin
+ http://www.highprogrammer.com/alan/pfx2/openal-alan-hack-0.0.1.tar.gz"
+
+LICENSE="BCS"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+
+RDEPEND="
+ media-libs/libsdl[abi_x86_32(-)]
+ sys-libs/glibc
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXau[abi_x86_32(-)]
+ x11-libs/libXdmcp[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]"
+
+S=${WORKDIR}
+
+dir=/opt/${PN}
+Ddir=${D}/${dir}
+QA_PREBUILT="${dir:1}/*"
+
+src_unpack() {
+ unpack_makeself bcsdemo_v${PV/./_}.sh.bin
+ unpack openal-alan-hack-0.0.1.tar.gz
+}
+
+src_install() {
+ dodir "${dir}"
+
+ tar -zxf bcsdemo.tar.gz -C "${Ddir}" || die
+ rm -f "${Ddir}"/bcs-linux-openal-fixer.sh || die
+
+ exeinto "${dir}"
+# doexe bin/Linux/x86/rungame.sh
+# exeinto ${dir}/lib
+ mv "${Ddir}"/bcs "${Ddir}"/bcs-bin
+ newexe libopenal.so.0.0.6 libopenal.so.0
+ echo '#!/bin/bash' >> "${Ddir}"/bcs
+ echo 'LD_PRELOAD="./libopenal.so.0" ./bcs-bin' >> "${Ddir}"/bcs
+ fperms 755 "${dir}"/bcs
+ make_wrapper bcs-demo ./bcs "${dir}" "${dir}"
+
+ insinto "${dir}"
+ doins *.cfg
+ dodoc readme*
+}
diff --git a/games-simulation/bcs-demo/metadata.xml b/games-simulation/bcs-demo/metadata.xml
new file mode 100644
index 000000000000..6955d95241d3
--- /dev/null
+++ b/games-simulation/bcs-demo/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription>
+Building a bridge that doesn't break is what its all about, although watching
+your bridge creation break and plunge a train into the watery depths below can be
+half the fun. In the Bridge Construction Set you design and build bridges and
+then stress test them to see how your creations hold up under pressure. If when
+test vehicles pass over your bridge they make it safely across you know you've
+succeeded. If they plummet into the river you know you need to go back to the
+drawing board.
+
+The robust physics deployed in the Bridge Construction Set let you build a wide
+variety of bridges that can span the river. The 3D graphics allow you to view
+your bridge from any angle including a first person train view - its like being
+strapped to the front of the train when your bridge is first tested (if this
+happened in real life I think we might have engineers checking all their bridges
+in a simulator).
+
+The Bridge Construction Set includes many types of bridge building levels in
+varying degrees of difficulty from simple to complex with a tutorial secition to
+get you started. A Level Editor is also included so you can create your own
+levels and trade them with others.
+</longdescription>
+</pkgmetadata>