summaryrefslogtreecommitdiff
path: root/games-simulation/EmptyEpsilon/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /games-simulation/EmptyEpsilon/files
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'games-simulation/EmptyEpsilon/files')
-rw-r--r--games-simulation/EmptyEpsilon/files/EmptyEpsilon-Make-CMake-call-find_package-glm.patch35
-rw-r--r--games-simulation/EmptyEpsilon/files/SeriousProton-Unbundle-json11.patch27
2 files changed, 62 insertions, 0 deletions
diff --git a/games-simulation/EmptyEpsilon/files/EmptyEpsilon-Make-CMake-call-find_package-glm.patch b/games-simulation/EmptyEpsilon/files/EmptyEpsilon-Make-CMake-call-find_package-glm.patch
new file mode 100644
index 000000000000..da52f0267f77
--- /dev/null
+++ b/games-simulation/EmptyEpsilon/files/EmptyEpsilon-Make-CMake-call-find_package-glm.patch
@@ -0,0 +1,35 @@
+From 7efb73d1a964f04646dba692323c1affcb25d16e Mon Sep 17 00:00:00 2001
+From: Florian Schmaus <flow@gentoo.org>
+Date: Fri, 8 Oct 2021 11:07:20 +0200
+Subject: [PATCH] Make CMake call find_package(glm)
+
+---
+ CMakeLists.txt | 12 +-----------
+ 1 file changed, 1 insertion(+), 11 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 6fb5c88f6614..9d65d1ef2653 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -106,17 +106,7 @@ if(WITH_DISCORD)
+ endif()
+
+ # GLM
+-set(GLM_BASE_PATH "${EXTERNALS_DIR}")
+-
+-if(NOT EXISTS "${GLM_BASE_PATH}/glm/CMakeLists.txt")
+- set(GLM_ZIP "${DOWNLOADS_DIR}/glm.zip")
+- file(DOWNLOAD "https://github.com/g-truc/glm/releases/download/0.9.9.8/glm-0.9.9.8.zip" "${GLM_ZIP}" TIMEOUT 60 TLS_VERIFY ON)
+-
+- file(MAKE_DIRECTORY "${GLM_BASE_PATH}/glm")
+- execute_process(COMMAND ${CMAKE_COMMAND} -E tar -xf "${GLM_ZIP}" WORKING_DIRECTORY "${GLM_BASE_PATH}")
+-endif()
+-
+-add_subdirectory("${GLM_BASE_PATH}/glm" "${PROJECT_BINARY_DIR}/glm" EXCLUDE_FROM_ALL)
++find_package(glm)
+
+ set(SOURCES
+ src/main.cpp
+--
+2.32.0
+
diff --git a/games-simulation/EmptyEpsilon/files/SeriousProton-Unbundle-json11.patch b/games-simulation/EmptyEpsilon/files/SeriousProton-Unbundle-json11.patch
new file mode 100644
index 000000000000..deb44e9aee00
--- /dev/null
+++ b/games-simulation/EmptyEpsilon/files/SeriousProton-Unbundle-json11.patch
@@ -0,0 +1,27 @@
+From ae5ea143e6a9f57c797a96b9024c8acc60f05828 Mon Sep 17 00:00:00 2001
+From: Florian Schmaus <flo@gentoo.org>
+Date: Fri, 8 Oct 2021 13:26:27 +0200
+Subject: [PATCH] Unbundle json11
+
+---
+ CMakeLists.txt | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4b57a4f6631a..0a06c3186ff5 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -86,10 +86,6 @@ add_subdirectory(src/lua)
+ add_subdirectory(src/GL)
+ add_subdirectory(src/libopus)
+
+-if(SERIOUSPROTON_WITH_JSON)
+- add_subdirectory(src/json11)
+-endif()
+-
+ #---------------------------------File lists-----------------------------------
+ set(source_files #All SeriousProton's objects to compile
+ src/clipboard.cpp
+--
+2.32.0
+