summaryrefslogtreecommitdiff
path: root/games-server/crossfire-server
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-server/crossfire-server
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-server/crossfire-server')
-rw-r--r--games-server/crossfire-server/Manifest6
-rw-r--r--games-server/crossfire-server/crossfire-server-1.71.0-r1.ebuild51
-rw-r--r--games-server/crossfire-server/files/crossfire-server-1.71.0-format.patch20
-rw-r--r--games-server/crossfire-server/metadata.xml11
4 files changed, 88 insertions, 0 deletions
diff --git a/games-server/crossfire-server/Manifest b/games-server/crossfire-server/Manifest
new file mode 100644
index 000000000000..64faf9f2c84f
--- /dev/null
+++ b/games-server/crossfire-server/Manifest
@@ -0,0 +1,6 @@
+AUX crossfire-server-1.71.0-format.patch 1115 BLAKE2B 7bce8fa52889ec1f1ca636c48995ac5110f5fc62965b0e7a8db01f37df8f6339756b290028425fbbe3e93b559126e8571d619ffe55f119007b3416abe5ae71eb SHA512 3d1cf04cc787177776f8f65afbe585ebe5982687313219a6cc64797bf4a992c1b6077ad2ad75b1f7c3372041c9cb0eaadbebee3fb27a25ff5664a8adb48e986f
+DIST crossfire-1.71.0.arch.tar.bz2 3462161 BLAKE2B 4f2c7e9619ceca3aafea03a681e59c04e31c954c91b94e4065a6446d537c6f039fe58c04f50fd5eddb8290b9cb93533772c6c7963b526c537bf297f469ad5bb5 SHA512 f9707dc5dab24d0ba74654c6433e016a58ab4e99da5dade6614491eca00736965bb7fd9a24db4188c3409a0479a88bb0ea55282e519ffcbabf23d82e6a5b975e
+DIST crossfire-1.71.0.maps.tar.bz2 19463076 BLAKE2B a6b1935985d82b53ef1dfd76b91e8d9417f03dceeddbc69154799703597d14d3ffb3dba8cec809345b62e99294ed3adec66cb2c9fae52fface96db8ba75daa7d SHA512 c3940b0a48f1badc14eb81610cfcd4241d140b666b5cb123845dca6ad742a18977ad7ada1d75d738f15f44374896c4dd6047989122257d7cd87362a3af0f97e8
+DIST crossfire-1.71.0.tar.bz2 6712638 BLAKE2B 91957fab3f19e52839eadfcb015a2fd8dfc551230fa55dd00254f39608ffbb8648227f3d2a244a609538ee2e426675e6b58dac73cf565554611ccb40d2839873 SHA512 d867f3393cb18ed78158c9a724d386dd642f0193ace86fef592e7bdc80885b7f7ce3c37be34b77d73b31c939d41e533029f2e7dea405c00d7a67aa3baebd146d
+EBUILD crossfire-server-1.71.0-r1.ebuild 1106 BLAKE2B f6578eae5e58dfe4bec3c20545d4e54ecc5900c8e4a3193f0c0bca83dacb4ede455747e412837c7b204f42d4f83c4e0fc4f8f88a338c3da2edec0ee8c5f716b6 SHA512 2bb94adc5f86a6f38f41b6907855a24e22886befde4f4dd07c4aeb0ae495acc8c928ef8adb3fee3f6f2eae56b763ad58b6bd5430701da62ca507a3fe42e8679b
+MISC metadata.xml 332 BLAKE2B b2b20adc6daa1c491850292a929df2b67738519b81cbab2cd2c2d278176daf4e895a10bc712213abcb41714f27bb0c9e2b1731f970b7381cbf9ffefe6c393666 SHA512 cf046be69b614cd43deba574e8fbd23b566507c694b9f7cbda92d7009d727ac4087de411bf63463561beb3160ecfe7f9fb685574b018466b473535184529ccf7
diff --git a/games-server/crossfire-server/crossfire-server-1.71.0-r1.ebuild b/games-server/crossfire-server/crossfire-server-1.71.0-r1.ebuild
new file mode 100644
index 000000000000..3012afe88c9b
--- /dev/null
+++ b/games-server/crossfire-server/crossfire-server-1.71.0-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="${P/-server/}"
+DESCRIPTION="Server for the crossfire clients"
+HOMEPAGE="http://crossfire.real-time.com/"
+SRC_URI="mirror://sourceforge/crossfire/${PN}/${PV}/${MY_P}.tar.bz2
+ mirror://sourceforge/crossfire/${PN}/${PV}/${MY_P}.maps.tar.bz2
+ mirror://sourceforge/crossfire/${PN}/${PV}/${MY_P}.arch.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+RESTRICT="test"
+
+RDEPEND="
+ net-misc/curl
+ X? (
+ x11-libs/libXaw
+ media-libs/libpng:0=
+ )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ rm -f "${WORKDIR}"/maps/Info/combine.pl # bug #236205
+ ln -s "${WORKDIR}/arch" "${S}/lib" || die
+ eapply "${FILESDIR}"/${P}-format.patch
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_compile() {
+ # work around the collect.pl locking
+ emake -j1 -C lib
+ emake
+}
+
+src_install() {
+ default
+ keepdir /var/lib/crossfire/{account,datafiles,maps,players,template-maps,unique-items}
+ insinto /usr/share/crossfire
+ doins -r "${WORKDIR}/maps"
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/games-server/crossfire-server/files/crossfire-server-1.71.0-format.patch b/games-server/crossfire-server/files/crossfire-server-1.71.0-format.patch
new file mode 100644
index 000000000000..afed04da57f4
--- /dev/null
+++ b/games-server/crossfire-server/files/crossfire-server-1.71.0-format.patch
@@ -0,0 +1,20 @@
+--- a/server/c_chat.c.old 2015-12-15 21:35:30.024866220 +0100
++++ b/server/c_chat.c 2015-12-15 21:36:58.479266312 +0100
+@@ -483,7 +483,7 @@
+ { "You spit over your left shoulder.", "%s spits over his left shoulder." },
+ { "Strut your stuff.", "%s struts proudly." },
+ { NULL, NULL },
+- { "%s patiently twiddles his thumbs.", "You patiently twiddle your thumbs." },
++ { "You patiently twiddle your thumbs.", "%s patiently twiddles his thumbs." },
+ { "You wave.", "%s waves happily." },
+ { "You whistle appreciatively.", "%s whistles appreciatively." },
+ { "Have you got something in your eye?", "%s winks suggestively." },
+@@ -645,7 +645,7 @@
+
+ if (*params == '\0') {
+ if (emotion > EMOTE_FIRST && emotion < EMOTE_LAST && single_emotes[emotion - 1][0] != NULL) {
+- snprintf(buf, sizeof(buf), single_emotes[emotion - 1][0]);
++ snprintf(buf, sizeof(buf), "%s", single_emotes[emotion - 1][0]);
+ snprintf(buf2, sizeof(buf2), single_emotes[emotion - 1][1], op->name);
+ } else {
+ snprintf(buf, sizeof(buf), "You are a nut.");
diff --git a/games-server/crossfire-server/metadata.xml b/games-server/crossfire-server/metadata.xml
new file mode 100644
index 000000000000..baf8c3afc277
--- /dev/null
+++ b/games-server/crossfire-server/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">crossfire</remote-id>
+ </upstream>
+</pkgmetadata>