summaryrefslogtreecommitdiff
path: root/games-rpg/wasteland2/wasteland2-1.9.0.13-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /games-rpg/wasteland2/wasteland2-1.9.0.13-r2.ebuild
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'games-rpg/wasteland2/wasteland2-1.9.0.13-r2.ebuild')
-rw-r--r--games-rpg/wasteland2/wasteland2-1.9.0.13-r2.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/games-rpg/wasteland2/wasteland2-1.9.0.13-r2.ebuild b/games-rpg/wasteland2/wasteland2-1.9.0.13-r2.ebuild
new file mode 100644
index 000000000000..42082b1444ca
--- /dev/null
+++ b/games-rpg/wasteland2/wasteland2-1.9.0.13-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CHECKREQS_DISK_BUILD="22000M"
+CHECKREQS_DISK_USR="21600M"
+inherit check-reqs desktop wrapper
+
+DESCRIPTION="Sequel to 1988 Wasteland, post-apocalyptic computer RPG inspiration for Fallout"
+HOMEPAGE="https://wasteland.inxile-entertainment.com/"
+SRC_URI="gog_wasteland_2_${PV}.tar.gz"
+S="${WORKDIR}/Wasteland 2"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist fetch"
+
+QA_PREBUILT="opt/${PN}/*"
+
+RDEPEND="
+ dev-libs/atk[abi_x86_32(-)]
+ dev-libs/glib:2[abi_x86_32(-)]
+ media-libs/fontconfig:1.0[abi_x86_32(-)]
+ media-libs/freetype:2[abi_x86_32(-)]
+ virtual/glu[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ x11-libs/cairo[abi_x86_32(-)]
+ x11-libs/gdk-pixbuf[abi_x86_32(-)]
+ x11-libs/gtk+:2[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXcursor[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ x11-libs/libXrandr[abi_x86_32(-)]
+ x11-libs/pango[abi_x86_32(-)]"
+
+pkg_nofetch() {
+ einfo "Please buy Wasteland 2"
+ einfo "from https://www.gog.com/ and"
+ einfo "download ${SRC_URI}"
+ einfo "and move it to your DISTDIR directory."
+ einfo
+ einfo "This ebuild was tested with the CLASSICAL edition."
+ einfo "If it works with the deluxe edition too, please"
+ einfo "open a bug report. If not, open a bug report too."
+}
+
+src_install() {
+ local dir=/opt/${PN}
+
+ # over 20GB of data
+ dodir ${dir}
+ mv game/WL2_Data "${ED}"/${dir}/ || die
+
+ exeinto ${dir}
+ doexe game/WL2
+
+ make_wrapper ${PN} ./WL2 ${dir}
+
+ newicon support/gog-wasteland-2.png ${PN}.png
+ make_desktop_entry ${PN} "Wasteland 2"
+
+ dodoc docs/*.pdf
+}