summaryrefslogtreecommitdiff
path: root/games-rpg/pcgen/pcgen-6.04.01-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-rpg/pcgen/pcgen-6.04.01-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-rpg/pcgen/pcgen-6.04.01-r1.ebuild')
-rw-r--r--games-rpg/pcgen/pcgen-6.04.01-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-rpg/pcgen/pcgen-6.04.01-r1.ebuild b/games-rpg/pcgen/pcgen-6.04.01-r1.ebuild
new file mode 100644
index 000000000000..45e32d2039b7
--- /dev/null
+++ b/games-rpg/pcgen/pcgen-6.04.01-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils
+
+DESCRIPTION="D&D character generator"
+HOMEPAGE="http://pcgen.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pcgen/${P}-full.zip"
+
+LICENSE="LGPL-2.1 OGL-1.0a"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ default
+
+ rm -vf *.bat || die
+ sed "/dirname/ c\cd \"\/usr\/share\/${PN}\"" pcgen.sh > "${T}"/${PN} || die
+}
+
+src_install() {
+ dobin "${T}"/${PN}
+ insinto /usr/share/${PN}
+ doins -r *
+ newicon -s 128 system/sponsors/pcgen/pcgen_128x128.png ${PN}.png
+ make_desktop_entry ${PN} PCGen
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}