summaryrefslogtreecommitdiff
path: root/games-rpg/grimrock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-rpg/grimrock
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-rpg/grimrock')
-rw-r--r--games-rpg/grimrock/Manifest3
-rw-r--r--games-rpg/grimrock/grimrock-20150707.ebuild70
-rw-r--r--games-rpg/grimrock/metadata.xml8
3 files changed, 81 insertions, 0 deletions
diff --git a/games-rpg/grimrock/Manifest b/games-rpg/grimrock/Manifest
new file mode 100644
index 000000000000..f98afb3eae90
--- /dev/null
+++ b/games-rpg/grimrock/Manifest
@@ -0,0 +1,3 @@
+DIST Grimrock-Linux-2015-07-07.sh 316846242 BLAKE2B 5d8123b3e2dedf4d6b2ae6f43c9ebe5427e63205b7ff53dc0fba26b0b3a8a1f164b79a3a10776c751aa0fbe29c7ef715412bff826476894eec6aa545da4adec3 SHA512 c90203a747564223281fb61ffcc7ac90f772990f33bb8345aff68c65fbc371f0f1a611645e952a75bd9dbca9e760398c0411eb9adade9c58e525a5b1c4e186db
+EBUILD grimrock-20150707.ebuild 1555 BLAKE2B 11b0bc03dd1b01614dd3899b1d6b615fc34d32b02162b7e750a37da21b12e3b49cd9fce9a155f2c85e9edaba9d19841755bd4afa2acdf29118a69d5837b83a2f SHA512 d46f2401d3daac6767a535175fde51167c8bbf946c4e8ba4608cbad2b6d4da0b3f076c3ff1e9594cb1b802bcd30ea18072ddf252f29f36b35e9946ca2d5992e4
+MISC metadata.xml 253 BLAKE2B 443ca9c8d4f6801169382e87a0ecd1385c56e65229209e7200f9d313ef380e92ae8d7dc3c38e5989a4166289f22607a20b1e13bb960fff6b3d9f78629d8ab020 SHA512 61c4689cbc649d84a00be211b7b5b98dd03e1d3f813eff370df549f2998cd4343f391c18b57cf20e4a8f4dd2311e3bfa04eb60f356f2bbac78f0b68f5091f254
diff --git a/games-rpg/grimrock/grimrock-20150707.ebuild b/games-rpg/grimrock/grimrock-20150707.ebuild
new file mode 100644
index 000000000000..03275c50c9a5
--- /dev/null
+++ b/games-rpg/grimrock/grimrock-20150707.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop gnome2-utils unpacker
+
+TIMESTAMP="${PV:0:4}-${PV:4:2}-${PV:6:2}"
+MY_PN="Grimrock"
+DESCRIPTION="Legend of Grimrock: The ultimate dungeon crawling RPG + modding engine"
+HOMEPAGE="http://www.grimrock.net/"
+SRC_URI="Grimrock-Linux-${TIMESTAMP}.sh"
+
+SLOT="0"
+LICENSE="all-rights-reserved"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="fetch bindist splitdebug"
+
+QA_PREBUILT="/opt/${PN}/${MY_PN}.bin"
+
+RDEPEND="media-libs/freeimage
+ media-libs/freetype:2
+ media-libs/openal
+ media-libs/libsdl2[opengl,sound,video]
+ media-libs/libvorbis
+ sys-libs/zlib[minizip]
+ virtual/opengl
+ x11-libs/libX11"
+
+DEPEND="app-arch/xz-utils"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_unpack() {
+ myarch=$(usex amd64 x86_64 x86)
+ unpack_makeself
+
+ local i
+ for i in subarch instarchive_all instarchive_linux_${myarch}; do
+ ln -snf "${i}" "${i}.tar.xz" || die
+ unpack ./"${i}.tar.xz"
+ done
+}
+
+src_install() {
+ local dir=/opt/${PN}
+
+ insinto "${dir}"
+ doins ${PN}.{dat,png}
+
+ exeinto "${dir}"
+ newexe ${MY_PN}.bin{.${myarch},}
+ dosym "../..${dir}"/${MY_PN}.bin /usr/bin/${PN}
+
+ doicon -s 256 ${PN}.png
+ newicon -s 64 ${MY_PN}.png ${PN}.png
+ make_desktop_entry ${PN} "Legend of ${MY_PN}"
+
+ dodoc README.linux
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }
diff --git a/games-rpg/grimrock/metadata.xml b/games-rpg/grimrock/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-rpg/grimrock/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>