summaryrefslogtreecommitdiff
path: root/games-rpg/eternal-lands-data
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-rpg/eternal-lands-data
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-rpg/eternal-lands-data')
-rw-r--r--games-rpg/eternal-lands-data/Manifest5
-rw-r--r--games-rpg/eternal-lands-data/eternal-lands-data-1.9.3-r1.ebuild99
-rw-r--r--games-rpg/eternal-lands-data/metadata.xml20
3 files changed, 124 insertions, 0 deletions
diff --git a/games-rpg/eternal-lands-data/Manifest b/games-rpg/eternal-lands-data/Manifest
new file mode 100644
index 000000000000..0576dca4f609
--- /dev/null
+++ b/games-rpg/eternal-lands-data/Manifest
@@ -0,0 +1,5 @@
+DIST EL_sound_191.zip 43002046 BLAKE2B 450fd0fbff0fefbbffb1154ecb3e1e97ec8eb447d961e1442900af629c612c5a6f14f673a0c2820f7403b79ae0b4920a17f1e2a1b3457a5cc47daca0deb54bca SHA512 cc4103d6cdafffcf3926f0e90ca2555b09b22d9e00947f9e1790cfa5b7c945cff16f935ede886b498ac86028b77e8f1ead6eecab2d59848100233eed373c1310
+DIST el_linux_193.zip 67104165 BLAKE2B 8e83cc00ef766f829793880952cf852adc7081a095ee3cee4f483c6fff7f9c0a293556483506fe4d09b5681ea7b7c5796e876a92e06f739d92b5fba1e7129f51 SHA512 95de984998bfc27525b7986895d1154a74c6e4dbffb9bf115c1284213acf56a470967b55e0507ed6aacd67f972bce4689aa7cffb9acd16d92bf448f195dc4f0c
+DIST el_music_full-20060803.zip 65511882 BLAKE2B 618fe476473f00371f50f9249a11aaa7b9da28caae41e072f6cf6a5d74d640b58182586f92a770bef45c80f19c1b46408b6ac2625972ba804d4c1967f01546c6 SHA512 dbd24cb20331d3640b3a5891faaf88aa0e71ba0564dfde347f2ea0fcb7e0f2700f1324ee8e988c551efb943183bbc823d4ee0373ed2b1f6d0300df76e25a524c
+EBUILD eternal-lands-data-1.9.3-r1.ebuild 3170 BLAKE2B 0868cf1594d2acf6f0cb853674c9de2de381a09f777cffd798a14f1f7d9d0ee13697fa927a4c5e978bf61c0270a9eaa5bdf73af9e1f76b70819500a270352d6e SHA512 98ed0c7cfa0ef77b571195fce7ac9ddc1d1e749fe12c935101405222800efe5f3b0226f16d4e100b8d21e80acb6ab4290ad7d52bd8919b0debe52b08575d877c
+MISC metadata.xml 707 BLAKE2B 27ac7d1be17ce87ec9f76b8b6613a995a315f775b22b04adc7bfce8af873196145fa32f76557e8b03da3215f1aa8e847072ed7f355aee288820810cbbd515dae SHA512 1128694f4485b282c424ab67e933779dc10265f051078d62fdab077a13c7d95888b55d048402474501a4483dd1d52189295d3c08ef8e298640153d3fbd3261cd
diff --git a/games-rpg/eternal-lands-data/eternal-lands-data-1.9.3-r1.ebuild b/games-rpg/eternal-lands-data/eternal-lands-data-1.9.3-r1.ebuild
new file mode 100644
index 000000000000..cdcd0ac6284b
--- /dev/null
+++ b/games-rpg/eternal-lands-data/eternal-lands-data-1.9.3-r1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MUSIC_DATE="20060803"
+
+MY_PV="${PV//_/}"
+MY_PV="${MY_PV//./}"
+MY_PN="${PN%*-data}"
+DESCRIPTION="An online MMORPG written in C and SDL"
+HOMEPAGE="http://www.eternal-lands.com"
+SRC_URI="http://www.eternal-lands.com/el_linux_193.zip
+ music? ( mirror://gentoo/el_music_full-${MUSIC_DATE}.zip )
+ sound? ( http://www.eternallands.co.uk/EL_sound_191.zip )"
+# WARNING: The music file is held at
+# http://www.eternal-lands.com/page/music.php
+# We only mirror it so that it is versioned by the date we mirrored it
+# AND prefixed with el_ so as not cause any conflicts. Maybe oneday they will
+# version their music, maybe not.
+
+LICENSE="eternal_lands"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="bloodsuckermaps music sound"
+
+DEPEND="app-arch/unzip
+ !bloodsuckermaps? ( !games-rpg/eternal-lands-bloodsucker )"
+
+PDEPEND="bloodsuckermaps? ( >=games-rpg/eternal-lands-bloodsucker-3.0_p20110618 )"
+
+# Maybe one day upstream will do things in a consistent way.
+S="${WORKDIR}/el_linux"
+
+src_prepare() {
+ # Move our music files to the correct directory
+ if use music ; then
+ mkdir music || die
+ mv ../*.ogg ../*.pll music || die
+ fi
+
+ # Fix assertion error with >=libxml2-2.9 (see bug #449352)
+ xmllint --noent actor_defs/actor_defs.xml > actor_defs.xml || die "Failed parsing actor_defs.xml"
+ mv actor_defs.xml actor_defs || die
+ eapply_user
+}
+
+src_install() {
+ # These are provided by eternal-lands ebuild
+
+ rm license.txt
+ rm commands.lst
+
+ # don't install maps if using alternate maps
+ if use bloodsuckermaps ; then
+ rm maps/anitora.dds maps/cave1.dds maps/cont2map10.dds
+ rm maps/cont2map11.dds maps/cont2map12.dds maps/cont2map13.dds
+ rm maps/cont2map14.dds maps/cont2map15.dds maps/cont2map16.dds
+ rm maps/cont2map17.dds maps/cont2map18.dds maps/cont2map19.dds
+ rm maps/cont2map1.dds maps/cont2map20.dds maps/cont2map21.dds
+ rm maps/cont2map22.dds maps/cont2map23.dds maps/cont2map24.dds
+ rm maps/cont2map2.dds maps/cont2map3.dds maps/cont2map4.dds
+ rm maps/cont2map5.dds maps/cont2map6.dds maps/cont2map7.dds
+ rm maps/cont2map8.dds maps/cont2map9.dds maps/irilion.dds
+ rm maps/legend.dds maps/map11.dds maps/map12.dds
+ rm maps/map13.dds maps/map14f.dds maps/map15f.dds
+ rm maps/map2.dds maps/map3.dds maps/map4f.dds
+ rm maps/map5nf.dds maps/map6nf.dds maps/map7.dds
+ rm maps/map8.dds maps/map9f.dds maps/seridia.dds
+ rm maps/startmap.dds
+ fi
+
+ insopts -m 0660
+ insinto /usr/share/games/eternal-lands
+ doins -r 2dobjects 3dobjects actor_defs animations maps meshes \
+ particles skeletons shaders textures languages shaders skybox \
+ *.lst 3dobjects.txt *.xml \
+ || die "doins failed"
+
+ if use music ; then
+ doins -r music
+ fi
+
+ # Removed sound from above - need to handle sound support
+
+ cd "${WORKDIR}"
+ if use sound ; then
+ doins -r sound
+ fi
+}
+
+pkg_postinst() {
+ # Ensure that the files are writable by the game group for auto
+ # updating.
+ chmod -R g+rw "${EROOT}"usr/share/games/eternal-lands || die
+
+ # Make sure new files stay in games group
+ find "${EROOT}"usr/share/games/eternal-lands -type d -exec chmod g+sx {} \; || die
+}
diff --git a/games-rpg/eternal-lands-data/metadata.xml b/games-rpg/eternal-lands-data/metadata.xml
new file mode 100644
index 000000000000..35a82f4ea804
--- /dev/null
+++ b/games-rpg/eternal-lands-data/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>rich0@gentoo.org</email>
+ <name>Rich Freeman</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription>
+ Eternal Lands is a FREE MMORPG (massively multiplayer online role playing game)
+ </longdescription>
+ <use>
+ <flag name="bloodsuckermaps">Will install Bloodsucker's Maps in place of the official map files</flag>
+ <flag name="music">Enables in-game music</flag>
+ <flag name="sound">Enables in-game sound effects</flag>
+ </use>
+</pkgmetadata>