summaryrefslogtreecommitdiff
path: root/games-rpg/egoboo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-rpg/egoboo
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-rpg/egoboo')
-rw-r--r--games-rpg/egoboo/Manifest4
-rw-r--r--games-rpg/egoboo/egoboo-2.8.1-r1.ebuild59
-rw-r--r--games-rpg/egoboo/files/egoboo-2.8.1-gentoo.patch56
-rw-r--r--games-rpg/egoboo/metadata.xml11
4 files changed, 130 insertions, 0 deletions
diff --git a/games-rpg/egoboo/Manifest b/games-rpg/egoboo/Manifest
new file mode 100644
index 000000000000..5b2fe184b5cd
--- /dev/null
+++ b/games-rpg/egoboo/Manifest
@@ -0,0 +1,4 @@
+AUX egoboo-2.8.1-gentoo.patch 2233 BLAKE2B c2cf8754e956d1032461d9ee1ea6dae42e1969042647ec37bfc65f2fe702863386de406bfa35df76392bd38e65e10a9ec5956c84a83191fda767f53afee22121 SHA512 277e453c95ee908b064987eae732b37a6ee9c2d903532017eb8a8951458a16b5195694f8165ba7146b1ca609be6155e4df20212b8c3cb3b056c4249bc4f3e1f3
+DIST egoboo-2.8.1.tar.gz 150029960 BLAKE2B 582db0f3c033523f7b55e205aec5f7012301e3edb7a4667f49d6c4a26f99572b4652e3cf4b8ed0f9e4c4cf2f6129615a315955d0193f851fc7c16ab7eaf7e482 SHA512 5793a63ba90f461ae99bcb81bf4ddf287b203bc2d401e1f697f1f4f93e1d681954e09b23938eb1a36e7dd535e2d12b8882efd77572cc63392cad5f9462ac3054
+EBUILD egoboo-2.8.1-r1.ebuild 1254 BLAKE2B 93110e7e81f3df2960de016efb1da9b4aafdbf705727d287637b3ae880559561c0e7be806a75f7a395c89cecefce5b07333c95c30ab583c2777cd8d60d1d1990 SHA512 3ba98b1a1ed0a4af22dff6726ebc58e12c5cfca79575bc3f553ee9d196122803f5d870d0c7a93433ed46b6bf9733e4a553d82e9a44b98bf94e2e8d9e41ad5c01
+MISC metadata.xml 329 BLAKE2B e5d902b3bdacb0c6028e113c2617030dc6730c03b278cafc1ca077053ac9c9dc472d39a842fb18a506c979ae4f52dd21c1f4166f9e8f07289b8c66d6344c62a8 SHA512 c3152f5db54eb4ae254c36981adb9556ff0eb37b267cd1dd25efc1428249d826e4c37b6166034acf98229f6f3ac681d7edb9681c69fd2f88e9394dff04fbd5fb
diff --git a/games-rpg/egoboo/egoboo-2.8.1-r1.ebuild b/games-rpg/egoboo/egoboo-2.8.1-r1.ebuild
new file mode 100644
index 000000000000..108aefdfcecc
--- /dev/null
+++ b/games-rpg/egoboo/egoboo-2.8.1-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="A 3d dungeon crawling adventure in the spirit of NetHack"
+HOMEPAGE="http://egoboo.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-games/physfs
+ media-libs/libsdl[joystick,video]
+ media-libs/sdl-image
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf
+ net-libs/enet:0
+ virtual/glu
+ virtual/opengl"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+src_prepare() {
+ edos2unix src/game/platform/file_linux.c \
+ src/game/network.c \
+ src/game/Makefile
+ default
+ sed -i \
+ -e "s:@GENTOO_CONFDIR@:/etc/${PN}:" \
+ -e "s:@GENTOO_DATADIR@:/usr/share/${PN}:" \
+ src/game/platform/file_linux.c || die "sed failed"
+ rm -rf src/enet || die
+}
+
+src_compile() {
+ emake -C src/game PROJ_NAME=egoboo-2.x
+}
+
+src_install() {
+ dodoc BUGS.txt Changelog.txt doc/*.txt doc/*.pdf
+
+ insinto /usr/share/${PN}
+ doins -r basicdat modules
+ insinto /etc/${PN}
+ doins -r controls.txt setup.txt
+
+ newbin src/game/egoboo-2.x ${PN}
+
+ newicon basicdat/icon.bmp ${PN}.bmp
+ make_desktop_entry ${PN} Egoboo /usr/share/pixmaps/${PN}.bmp
+}
diff --git a/games-rpg/egoboo/files/egoboo-2.8.1-gentoo.patch b/games-rpg/egoboo/files/egoboo-2.8.1-gentoo.patch
new file mode 100644
index 000000000000..2f1205a45118
--- /dev/null
+++ b/games-rpg/egoboo/files/egoboo-2.8.1-gentoo.patch
@@ -0,0 +1,56 @@
+--- a/src/game/platform/file_linux.c 2012-04-29 21:45:29.627419281 +0200
++++ b/src/game/platform/file_linux.c 2012-04-29 21:45:29.628419211 +0200
+@@ -79,9 +79,9 @@
+ strncpy( linux_dataPath, PREFIX "/share/games/egoboo-2.x", SDL_arraysize( linux_dataPath ) );
+ #else
+ // these are read-only directories
+- strncpy( linux_configPath, "/etc/egoboo-2.x/", SDL_arraysize( linux_configPath ) );
++ strncpy( linux_configPath, "@GENTOO_CONFDIR@", SDL_arraysize( linux_configPath ) );
+ strncpy( linux_binaryPath, "/games/", SDL_arraysize( linux_binaryPath ) );
+- strncpy( linux_dataPath, "/share/games/egoboo-2.x/", SDL_arraysize( linux_dataPath ) );
++ strncpy( linux_dataPath, "@GENTOO_DATADIR@", SDL_arraysize( linux_dataPath ) );
+ #endif
+
+ // the log file cannot be started until there is a user data path to dump the file into
+--- a/src/game/network.c 2012-04-29 20:14:31.482179973 +0200
++++ b/src/game/network.c 2012-04-29 20:14:52.077730184 +0200
+@@ -37,7 +37,7 @@
+ #include "egoboo_setup.h"
+ #include "egoboo.h"
+
+-#include "enet/enet.h"
++#include <enet/enet.h>
+ #include "file_common.h"
+
+ #include <stdarg.h>
+--- a/src/game/Makefile 2012-04-29 20:17:09.303070070 +0200
++++ b/src/game/Makefile 2012-04-29 20:18:21.047023847 +0200
+@@ -33,8 +33,7 @@
+ # the compiler options
+
+-CC := gcc
+-INC := -I. -I.. -I../enet/include ${SDLCONF_I} -I./extensions -I./file_formats -I./platform
+-LDFLAGS := ${SDLCONF_L} -L../enet/lib -lSDL_ttf -lSDL_mixer -lGL -lGLU -lSDL_image -lphysfs -lenet
++INC := -I. -I.. ${SDLCONF_I} -I./extensions -I./file_formats -I./platform
++LDLIBS := ${SDLCONF_L} -lSDL_ttf -lSDL_mixer -lGL -lGLU -lSDL_image -lphysfs -lenet -lm
+
+ # use different options if the environmental variable PREFIX is defined
+ ifdef ($(PREFIX),"")
+@@ -43,7 +43,7 @@
+ OPT := -Os -Wall -DPREFIX=\"${PREFIX}\" -D_NIX_PREFIX
+ endif
+
+-CFLAGS := ${OPT} ${INC}
++CFLAGS += ${INC} -DENET11
+
+ #------------------------------------
+ # definitions of the target projects
+@@ -52,7 +52,7 @@
+ all: ${EGO_BIN}
+
+ ${EGO_BIN}: ${EGO_OBJ}
+- ${CC} -o $@ $^ ${LDFLAGS} ${CFLAGS}
++ ${CC} -o $@ $^ ${LDFLAGS} ${CFLAGS} ${LDLIBS}
+
+ clean:
+ rm -f ${ENET_OBJ} ${EGO_OBJ} ${EGO_BIN}
diff --git a/games-rpg/egoboo/metadata.xml b/games-rpg/egoboo/metadata.xml
new file mode 100644
index 000000000000..d8a2d5fe278b
--- /dev/null
+++ b/games-rpg/egoboo/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">egoboo</remote-id>
+ </upstream>
+</pkgmetadata>